tip goes out of the screen

Bug #37507 reported by Étienne BERSAC on 2006-03-31
36
Affects Status Importance Assigned to Milestone
Mozilla Firefox
Confirmed
Medium
firefox (Ubuntu)
Medium
Unassigned
Nominated for Dapper by Freddie
xulrunner-1.9 (Ubuntu)
Medium
Unassigned
Nominated for Dapper by Freddie

Bug Description

Hello,

When pointing the cursor to an element, a yellow tip appear. If the tip has not enough place right to the cursor, the tip should move to the left in order to be completely readable (like firefox do).

This should be the case in Epiphany too.

Étienne.

Should this bug depend on 45375? At the very least, it might attract a little more attention to this bug, but I've know idea whether the actual FIX is dependant on bug 45375.

Étienne BERSAC (bersace) wrote :

Hello,

When pointing the cursor to an element, a yellow tip appear. If the tip has not enough place right to the cursor, the tip should move to the left in order to be completely readable (like firefox do).

This should be the case in Epiphany too.

Étienne.

Sebastien Bacher (seb128) wrote :

Thanks for your bug. What version of Ubuntu do you use? What do you call an element? An toolbar button? An HTML element? The tooltips on GTK widgets are placed to the screen without any issue on my dapper installation (aligned to the border as required), maybe you could do a screenshot of your issue?

Changed in epiphany-browser:
assignee: nobody → desktop-bugs
status: Unconfirmed → Needs Info

Le 2 avr. 06 à 16:47, Sebastien Bacher a écrit :

> Thanks for your bug. What version of Ubuntu do you use?
up2date dapper.

> What do you call an element? An toolbar button? An HTML element?
Any HTML element with the title attribute. Note that i do not have
this bug with firefox.

> maybe you could do a screenshot of your issue?
Screenshot attached.

Étienne.

Le 2 avr. 06 à 16:47, Sebastien Bacher a écrit :

Thanks for your bug. What version of Ubuntu do you use?
up2date dapper.

What do you call an element? An toolbar button? An HTML element?
Any HTML element with the title attribute. Note that i do not have this bug with firefox.

maybe you could do a screenshot of your issue?
Screenshot attached.

Étienne.

Sebastien Bacher (seb128) wrote :

Thank you for the screenshot. That's known upstream as http://bugzilla.gnome.org/show_bug.cgi?id=129456, which is a gtkmozembed issue: https://bugzilla.mozilla.org/show_bug.cgi?id=233371
Reassigning to firefox

Changed in epiphany-browser:
assignee: desktop-bugs → ijackson
status: Needs Info → Confirmed
Ian Jackson (ijackson) wrote :

Thanks to Sebastian for finding the upstream bug.

I think this issue should be dealt with upstream; we don't have the resources to develop or maintain an appropriate patch.

So I am setting this bug to Rejected (LP assure me that this is the right status even though I agree with the complaint).

Changed in firefox:
status: Confirmed → Rejected
Changed in firefox:
status: Unconfirmed → Confirmed

Could someone be persuaded to review the patch?

Christian, you have to request review to get this in. Does the patch still apply cleanly?

The title wording is incorrect - "wrapping" is not the solution.
There are cases where the tooltip wraps but is still cropped over the edge of the screen.

Alexander Sack (asac) wrote :

will update the bug in bmo and try to get that landed for xulrunner-1.9.

Changed in firefox:
status: Invalid → Won't Fix
assignee: ijackson → nobody
Changed in xulrunner-1.9:
importance: Undecided → Medium
status: New → Triaged

Created attachment 296135
updated for trunk

seems to fix the problem for me.

Comment on attachment 296135
updated for trunk

I can't review my own patch.

the idea was to get feedback on whether i missed something while adapting this for trunk.

Alexander Sack (asac) on 2008-01-09
Changed in xulrunner-1.9:
status: Triaged → Fix Committed

Alexander, your patch diverged since bug 408823 landed

Created attachment 297343
after bug 408823 landing

make the previous patch apply cleanly.

Comment on attachment 297343
after bug 408823 landing

I don't know enough GTK to review this effectively. Please try... marco, or maybe caillon would be willing.

This patch looks reasonable to me. I wonder if GTK+ 2.12's new tooltip API would be more amenable to being driven at a low level as gtkmozembed needs.

Comment on attachment 297343
after bug 408823 landing

+ // Ideally we'd query the cursor size and hotspot,
+ // but there appears to be no way to do that */

odd comment syntax // */

is there an upstream bug for this?

Comment on attachment 297343
after bug 408823 landing

>Index: embedding/browser/gtk/src/EmbedWindow.cpp

>+ gint x, y;
>+ gdk_window_get_origin(widget->window, &x, &y);
>+
>+ x += aXCoords;
>+ y += aYCoords;
>+
>+ // Ideally we'd query the cursor size and hotspot,
>+ // but there appears to be no way to do that */
>+ int xoffset = 8, yoffset = 8;

You're using gints above so use them here, too. And fix the comment.

>+ if (gtk_widget_get_direction(widget) == GTK_TEXT_DIR_RTL) {
>+ x -= req.width + xoffset;
>+ } else {
>+ x += xoffset;
>+ }
>
>- // and show it.
>- gtk_widget_show_all(sTipWindow);
>+ if (x + req.width > monitor.x + monitor.width)
>+ x = monitor.x + monitor.width - req.width;
>+ else if (x < monitor.x)
>+ x = monitor.x;
>+
>+ if (y + req.height + yoffset <= monitor.y + monitor.height)
>+ y += yoffset;
>+ else
>+ y -= req.height + yoffset;

Please use consistent bracing.

r=caillon with those nits addressed.

Another dupe was reported in gnome bugzilla. Alexander?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xulrunner-1.9 - 1.9~b3+nobinonly-0ubuntu1

---------------
xulrunner-1.9 (1.9~b3+nobinonly-0ubuntu1) hardy; urgency=low

  * release FIREFOX_3_0b3_RELEASE

  [ Alexander Sack ]
  * submit patch that ships xpcshell to bugzilla
    - rename debian/patches/ship_xpcshell.patch =>
             debian/patches/bz410617_att295212_ship_xpcshell.patch
    - update debian/patches/series
  * fix tooltip in epiphany: previously displayed out of screen bounds
    (LP: #37507)
    - add debian/patches/bz233371_att297343_fix_outofscreen_embed_tooltip.patch
    - update debian/patches/series
  * use default upstream gcc tweaks for improved performance - especially of the
    javascript engine
    - update debian/rules
  * update global extension/plugin patch to apply cleanly against latest code
    - update debian/patches/bzXXX_gre_extension_plugin_support.patch
  * fix pyxpcom build failure introduced by recent commit
    - add debian/patches/bzXXX_fix_pyxpcom_build_failure.patch
    - update debian/patches/series
  * add distro independent global install locations for extensions,
    /usr/lib/mozilla/extensions and /usr/share/mozilla/extensions
    - update debian/xulrunner-1.9.dirs
  * support embedded tarball layout when either there is a *.tar.bz2 in orig tarball
    or if DEBIAN_MOZCLIENT_EMBEDDED is not unset (you will need this to produce embedded
    tarballs during |get-orig-source|
    - update debian/rules
  * bump minimum libnss3-dev build requirements to >= 3.12.0~1.9b3
    - update debian/control
  * bump minimum libnspr4-dev build requirements to >= 4.7.0~1.9b3
    - update debian/control

  [ Fabien Tassin ]
  * Drop patches applied upstream
    - drop debian/patches/bz410617_att295212_ship_xpcshell.patch
    - drop debian/patches/bz404634_att294921.patch
    - drop debian/patches/bz386610_python2.5_ftbfs_amd64.patch
    - drop debian/patches/bz373918_att295042.patch
    - drop debian/patches/bz408062_unstable_pc.patch
    - drop debian/patches/bz384304_fix_recursive_symlinks.patch
    - update debian/patches/series
  * Refresh diverged patches:
    - update debian/patches/bzXXX_pc_honour_system_nspr_nss.patch
    - update debian/patches/rename_venkman_addon.patch
    - update debian/patches/bz344818_cairo_xrender.patch
  * Install links for all .so libs in the -dev package
    - update debian/patches/dont_install_so_in_dev.patch
  * Bump gtk requirement to 2.12 as per Mozilla bug 412432
    - update debian/control
  * Add #DEBHELPER# token to postinst/prerm scripts
    - update debian/xulrunner-1.9.{postinst,prerm}
  * Install previously missed libdbusservice.so
    - update debian/xulrunner-1.9.install
  * Update venkman patch to also rename locales
    - update debian/patches/rename_venkman_addon.patch
  * Bump requirement for system cairo to >= 1.5.8 as we now need
    the newly added cairo_path_extents()
    - update debian/rules
  * Include mozilla-devscripts file using -include so ifneq could be omitted
    - update debian/rules
  * Fix missing .so symlinks regression
    - update debian/patches/dont_install_so_in_dev.patch

 -- Alexander Sack <email address hidden> Wed, 13 Feb 2008 11:47:21 +0100

Changed in xulrunner-1.9:
status: Fix Committed → Fix Released
Changed in firefox:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.