[jaunty] gnome-web-photo symbol lookup error

Bug #350594 reported by UncleOwen on 2009-03-28
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Prism
Fix Released
Undecided
Unassigned
gnome-web-photo (Ubuntu)
Undecided
Unassigned
xulrunner-1.9 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gnome-web-photo

With the latest update to gnome-web-photo (0.6-0ubuntu2) I get:

$ gnome-web-photo --mode=photo --format=ppm http://www.google.de/intl/de_de/images/logo.gif /dev/stdout
/usr/bin/gnome-web-photo.real: symbol lookup error: /usr/lib/xulrunner-1.9.0.8/libpyxpcom.so: undefined symbol: PyUnicodeUCS2_DecodeUTF16

This error also affects Prism/XULRunner for the last days. Not sure exactly when it started but it was working on 25th of March but it not on 30th March.

Error message is:
$ prism-google-mail
/usr/lib/xulrunner-1.9.0.8/xulrunner-bin: symbol lookup error: /usr/lib/xulrunner-1.9.0.8/libpyxpcom.so: undefined symbol: PyUnicodeUCS2_DecodeUTF16

It looks like something has changed in the underlying python build.

Dave Lyon (tuxrocket) wrote :

I'm also seeing the same problem in Jaunty beta after upgrading yesterday. My custom prism apps stopped working with the aforementioned PyUnicode error.

jtuchscherer (jtuchscherer) wrote :

Same problem with all prism applications. Here is one example:

~$ prism-facebook
/usr/lib/xulrunner-1.9.0.8/xulrunner-bin: symbol lookup error: /usr/lib/xulrunner-1.9.0.8/libpyxpcom.so: undefined symbol: PyUnicodeUCS2_DecodeUTF16

Szabó Balázs (bszabo-netlab) wrote :

~$ prism-google-mail
/usr/lib/xulrunner-1.9.0.8/xulrunner-bin: symbol lookup error: /usr/lib/xulrunner-1.9.0.8/libpyxpcom.so: undefined symbol: PyUnicodeUCS2_DecodeUTF16

prism-facebook
/usr/lib/xulrunner-1.9.0.8/xulrunner-bin: symbol lookup error: /usr/lib/xulrunner-1.9.0.8/libpyxpcom.so: undefined symbol: PyUnicodeUCS2_DecodeUTF16
System is fully updated.
Monday, march 30, 2009.

Iván Campaña (ivan-campana) wrote :

Confirmed with latest Jaunty Beta, even though running the same applications in Firefox goes just well

/usr/lib/xulrunner-1.9.0.8/xulrunner-bin: symbol lookup error: /usr/lib/xulrunner-1.9.0.8/libpyxpcom.so: undefined symbol: PyUnicodeUCS2_DecodeUTF16

ldd /usr/lib/xulrunner-1.9.0.8/libpyxpcom.so
 linux-gate.so.1 => (0xb7ee9000)
 libpthread.so.0 => /lib/tls/i686/cmov/libpthread.so.0 (0xb7ea2000)
 libxpcom.so => not found
 libxul.so => not found
 libplds4.so => /usr/lib/libplds4.so (0xb7e9d000)
 libplc4.so => /usr/lib/libplc4.so (0xb7e98000)
 libnspr4.so => /usr/lib/libnspr4.so (0xb7e62000)
 libdl.so.2 => /lib/tls/i686/cmov/libdl.so.2 (0xb7e5e000)
 libpython2.6.so.1.0 => /usr/lib/libpython2.6.so.1.0 (0xb7c09000)
 libutil.so.1 => /lib/tls/i686/cmov/libutil.so.1 (0xb7c05000)
 libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb7b16000)
 libm.so.6 => /lib/tls/i686/cmov/libm.so.6 (0xb7af0000)
 libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb7ae1000)
 libc.so.6 => /lib/tls/i686/cmov/libc.so.6 (0xb797e000)
 /lib/ld-linux.so.2 (0xb7eea000)
 libz.so.1 => /lib/libz.so.1 (0xb7967000)

Alexander Sack (asac) wrote :

works for me on amd64; if you move your $HOME/.prism folder to a safe place, does prism start again?

Moved my .prism folder out and tried again. Same error.

One thing of note: I do have google-gears installed in prism which may be a factor.

Is there a way to start prism with safe mode? I tried:
prism-google-mail -safe-mode
and
prism-google-mail --safe-mode

and they gave the same error. Couldn't find documentation on safe mode in prism.

Dave Lyon (tuxrocket) wrote :

same for me- moving .prism folder did not help

Alexander Sack (asac) on 2009-03-31
Changed in gnome-web-photo (Ubuntu):
status: New → Invalid
Changed in prism:
status: New → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xulrunner-1.9 - 1.9.0.8+nobinonly-0ubuntu2

---------------
xulrunner-1.9 (1.9.0.8+nobinonly-0ubuntu2) jaunty; urgency=low

  * zero change rebuild to fix damage by python transition; see
    LP: #351988 and LP: #350594

 -- Alexander Sack <email address hidden> Tue, 31 Mar 2009 02:30:14 +0200

Changed in xulrunner-1.9:
status: New → Fix Released
UncleOwen (anakin-skyw) wrote :

Looking good, thanks.

Confirmed - fixed problem for prism. Thanks for such a quick fix.

Confirmed, bug fixed, prism/associated prism applications are now functioning.
This has everything to do with python. I * YOU PYTHON PEOPLES ><
Turning into frickin java here.

Changed in gnome-web-photo:
status: Invalid → Fix Released
Changed in prism:
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers