firefox crashed with SIGSEGV in XVisualIDFromVisual()

Bug #264094 reported by Salvador Velázquez de la Cruz on 2008-09-02
146
Affects Status Importance Assigned to Milestone
nspluginwrapper
Undecided
auto-gb.public
xulrunner-1.9 (Ubuntu)
Undecided
Unassigned
Nominated for Intrepid by Projess

Bug Description

Binary package hint: firefox-3.0

I just open a new mail from pidgin, there were some pages saved, that opened automatically together with gmail (mail from pidgin)

versions:
intrepid alpha 4 all updates applied
kernel: 2.6.27-2-generic
firefox: 3.0.1+build1+nobinonly-0ubuntu2

if you need more information please tell me, sorry if my english is bad

ProblemType: Crash
Architecture: amd64
DistroRelease: Ubuntu 8.10
ExecutablePath: /usr/lib/firefox-3.0.1/firefox
NonfreeKernelModules: ath_hal nvidia
Package: firefox-3.0 3.0.1+build1+nobinonly-0ubuntu2
ProcAttrCurrent: unconfined
ProcCmdline: /usr/lib/firefox-3.0.1/firefox http://mail.google.com/mail
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: firefox-3.0
StacktraceTop:
 XVisualIDFromVisual () from /usr/lib/libX11.so.6
 ?? ()
 ?? ()
 ?? ()
 ?? ()
Title: firefox crashed with SIGSEGV in XVisualIDFromVisual()
Uname: Linux 2.6.27-2-generic x86_64
UserGroups: adm admin cdrom dialout fuse lpadmin plugdev sambashare

StacktraceTop:raise () from /lib/libpthread.so.0
?? ()
?? ()
?? ()

kseise (kevin-seise) wrote :

MIne had nothing to do with Pidgin. I opened two tabs in Firefox and that was it.

Projess (projess) wrote :

The same happens to me without regard to what is happening on any page or any user activity.

eiaro (eiaro) wrote :

I had the same bug, but removed flashplugin-nonfree and now it seems to work.

Jose Luis Rodilla (jlrodilla) wrote :

Same bug here.

Jean.c.h (slug71) wrote :

Same bug here, was just trying to browse the Radioshack webpage.

Intrepid 64 Alpha-4, All updates applied.

Ernst Sjöstrand (ernstp) wrote :

so perhaps this bug has something to do with nspluginwrapper, all seem to be amd64?

Looks like an issue with new changes introduced in nspluginwrapper 1.1.0 to add support for windowless plugins (eg. Flash 10).

The X11 visual (ws_info->visual) seems to be getting mucked somewhere, making XVisualIDFromVisual unhappy.

ibizatunes (ibizatunes) wrote :

Yeah same here, alpha 4 fully patched

Sebastien Bacher (seb128) wrote :

confirmed, there is several duplicates already

Changed in firefox-3.0:
status: New → Confirmed
Sef (jo-ker) wrote :

same bug here.

locust (marineworks) wrote :

same here !
 intrepid 64 - 2.6.27-3

But it seems perhaps also related to java (....?)
On a heavy flash site (www.corriere.it ) firefox hangs on waiting from js.corriere.it

best regards
david

Jose Luis Rodilla (jlrodilla) wrote :

I'm having this error everyday since, at least, one month ago in amd64

According to the author of the upstream package, nspluginwrapper, this bug has been fixed in the latest release:

http://gwenole.beauchesne.info/en/blog/2008/10/13/nspluginwrapper_1.1.2

Updated package has landed in Intrepid, this bug can be closed.

Jean.c.h (slug71) on 2008-12-30
Changed in nspluginwrapper:
status: New → Fix Released
Jean.c.h (slug71) on 2008-12-30
Changed in xulrunner-1.9:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

  • auto-gb.public Edit

Bug watches keep track of this bug in other bug trackers.