epiphany-browser, yelp, devhelp and midbrowser uninstallable when -updates not enabled

Bug #253462 reported by Brian Brazil on 2008-07-30
4
Affects Status Importance Assigned to Milestone
xulrunner-1.9 (Ubuntu)
Undecided
Jamie Strandboge

Bug Description

Binary package hint: xulrunner-1.9

The xulrunner-1.9 in hardy-security (1.9.0.1+build1+nobinonly-0ubuntu0.8.04.3) contains a Breaks: epiphany-gecko << 2.22.1.1-0ubuntu1.8.04.1. As the newest version of epiphany-gecko available in hardy and hardy-security is 2.22.1.1-0ubuntu1, this is breaking upgrades. Similarly with yelp. You already appear to have fixed this for firefox-3.0 per bug 247494 by pushing to hardy-security, please do the same for epiphany-browser and yelp.

This is affecting all gNewSense users, and is a release blocker for us.

KarlGoetz (kgoetz) wrote :

i'll have a crack at this.

Changed in xulrunner-1.9:
assignee: nobody → kgoetz
KarlGoetz (kgoetz) wrote :

btw, this should probably be filed against yelp/epiphany, so i'll set 'also affects' for them later.

KarlGoetz (kgoetz) on 2008-08-03
Changed in xulrunner-1.9:
assignee: kgoetz → nobody
Jamie Strandboge (jdstrand) wrote :

Also affects devhelp and midbrowser. This is due to this in debian/control:
Breaks: epiphany-gecko (<< 2.22.1.1-0ubuntu1.8.04.1),
        yelp (<< 2.22.1-0ubuntu2.8.04.1),
        midbrowser (<< 0.3.0rc1),
        devhelp (<< 0.19-1ubuntu1.8.04.1),
        firefox-3.0 (<< 3.0.1)

This was added in 1.9~rc1+nobinonly-0ubuntu1~8.04.1. Need to pull rebuild the above -updates packages in -security.

Changed in xulrunner-1.9:
assignee: nobody → jdstrand
status: New → In Progress
Changed in xulrunner-1.9:
status: In Progress → Fix Committed
Changed in xulrunner-1.9:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers