epiphany-gecko crashed with SIGSEGV in __kernel_vsyscall()

Bug #230808 reported by Trouilliez vincent on 2008-05-15
8
Affects Status Importance Assigned to Milestone
XULRunner
Fix Released
Undecided
Unassigned
xulrunner-1.9 (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: epiphany-browser

Since upgrading to Hardy, Epiphany keeps crashing, say about once a day.

It generally seems random, with no obvious cause, but managed to find a way to reproduce the particular crash that his apport bug report refers to. Hopefully fixing this particular crash will also fix all the others that I can't find a pattern to.

To reproduce this bug:

1) visit this web page:

http://email.ednmag.com/cgi-bin2/DM/y/h5bz0PBzow0Dar0DbHa0Ea&rid=1909849583

2) Increase the fon size using the keyboard shortcut: Control + "+".

This causes Epiphany to crash either instantly, or following a minute or two of hanging.

ProblemType: Crash
Architecture: i386
Date: Thu May 15 20:10:03 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/epiphany-gecko
NonfreeKernelModules: nvidia
Package: epiphany-gecko 2.22.1.1-0ubuntu1
PackageArchitecture: i386
ProcCmdline: epiphany-gecko
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: epiphany-browser
StacktraceTop:
 __kernel_vsyscall ()
 raise () from /lib/tls/i686/cmov/libpthread.so.0
 ?? () from /usr/lib/xulrunner-1.9b5/libxul.so
 ?? ()
 ?? ()
Title: epiphany-gecko crashed with SIGSEGV in __kernel_vsyscall()
Uname: Linux 2.6.24-16-generic i686
UserGroups: adm admin audio cdrom dialout dip fax floppy fuse lpadmin plugdev scanner tape vboxusers video

StacktraceTop:__kernel_vsyscall ()
raise () from /lib/tls/i686/cmov/libpthread.so.0
?? () from /usr/lib/xulrunner-1.9b5/libxul.so
?? ()
?? ()

Pedro Villavicencio (pedro) wrote :

Thanks for your bug report. Please try to obtain a backtrace http://wiki.ubuntu.com/DebuggingProgramCrash and attach the file to the bug report. This will greatly help us in tracking down your problem.

Changed in epiphany-browser:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: New → Incomplete

Backtrace attached.

However, despite I installed the debug symbols/packages for epipnany-gecko as well as epiphany -gecko-extensions, well despite that, when I asked gdb for the backtrace, as you can see from the log, it complained that there was NO degug symbols ?! How comes ? :-/

(gdb) backtrace full
#0 0x00000000 in ?? ()
No symbol table info available.

Sebastien Bacher (seb128) wrote :

the crash seems to be a xulrunner one, you should install xulrunner-1.9-dbgsym too

Done. I have attached the resulting backtrace.

Sebastien Bacher (seb128) wrote :

that's a xulrunner crash, reassigning to xulrunner-1.9

Changed in epiphany-browser:
assignee: desktop-bugs → nobody
status: Incomplete → New

On Mon, May 26, 2008 at 08:16:38AM -0000, Launchpad Bug Tracker wrote:
> 1) visit this web page:
>
> http://email.ednmag.com/cgi-bin2/DM/y/h5bz0PBzow0Dar0DbHa0Ea&rid=1909849583
>
> 2) Increase the fon size using the keyboard shortcut: Control + "+".
>

Good catch

 affects ubuntu/xulrunner-1.9
 status triaged

 affects xulrunner
 status incomplete

Should be forwarded upstream

 - Alexander

Changed in xulrunner-1.9:
status: New → Triaged
Pedro Villavicencio (pedro) wrote :

i cannot reproduce this anymore with latest package on jaunty could you please test as well Trouilliez and report back? thanks in advance.

Changed in xulrunner-1.9:
status: Triaged → Incomplete

Hi Perdro,

I can't tell about Jaunty as it's not released yet so I can't test. However I am on 8.10 now, and epiphany doesn't crash anymore on this web page. So I think we can close this bug ! :-)

Jonathan Thomas (echidnaman) wrote :

Great! Glad it got fixed. :)
Also closing the unused upstream task.

Changed in xulrunner-1.9:
status: Incomplete → Fix Released
Changed in xulrunner:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers