print selection option causes firefox to crash

Bug #212316 reported by Brian on 2008-04-05
4
Affects Status Importance Assigned to Milestone
firefox-3.0 (Ubuntu)
Medium
Unassigned
xulrunner-1.9 (Ubuntu)
Undecided
Unassigned

Bug Description

When I attempt to print a portion of a web page that I have selected one of two things happens:
1. Firefox 3 will crash and vanish from my screen without any error message. When I restart Firefox 3 it asks if I want to recover the pages I was viewing when it crashed.
2. Firefox 3 will act like it is printing the selection on the page, but the printer never shows any activity. When I check the status of the document under the print job manger its says STOPPED, and restarting the print job just results in it says STOPPED again in a few seconds.
I don't seem to have any other issues printing from any other applications, it seems to only be Firefox 3 that has the problem. My machine was last updated on 2008-04-05, so I think I have fairly current packages. [firefox-3.0 (3.0~b4+nobinary-0ubuntu1), firfox-3.0-gnome-support (3.0~b4+nobinonly=0ubuntu1), cupsys (1.3.7-1ubuntu1)]
Thanks.

Brian (jmail524) wrote :

To add one more oddity to this problem. One of the machines I own doesn't crash when printing a selected area from Firefox 3. A blank page just comes out of the printer.

Brian (jmail524) wrote :

I have now noticed that this may not be a firefox bug. I have the print problem in all of my applications when I try to print a selection of the document.

PS: Why has the "print selection" option been moved. It is now located in probably the most inconvenient place possible.

PJSingh5000 (pjsingh5000) wrote :

Print selection does not work in Firefox 3 beta on Kubuntu Hardy (KDE 3).
The printer produces a blank page.
I did tested the print selection feature in Kate, ant it works fine.

Alexander Sack (asac) wrote :

Does this crash still happen? If so, please run firefox like

 strace -f -eopen firefox &> /tmp/ffox.log.txt

reproduce the crash.

and attach the /tmp/ffox.log.txt file.

Changed in firefox-3.0:
importance: Undecided → Medium
status: New → Incomplete
PJSingh5000 (pjsingh5000) wrote :

The crash still happens. Trace is attached.

On Sun, Jun 08, 2008 at 04:03:48AM -0000, PJSingh5000 wrote:
> The crash still happens. Trace is attached.
>
> ** Attachment added: "ffox.log.txt"
> http://launchpadlibrarian.net/15119151/ffox.log.txt
>

RC1 will be on your system soonish. Please let us know if it doesnt go
away.

 status incomplete

 - Alexander

Brian (jmail524) wrote :

I just wanted to update this thread. (Sorry I lost contact for a while.)

My system has been updated through the Ubuntu Hardy repositories and I now have Firefox 3.0.1 (3.0.1+build1+nobinonly-0ubuntu0.8.04.2). Everything seems to be working perfectly, my problems as described above have seemed to disappear. (Hopefully PJSingh5000's problems have disappeared as well.)

I appreciate everyone's diligence in making Firefox such an excellent browser.

Thanks.
Brian

PJSingh5000 (pjsingh5000) wrote :

Firefox 3.0.1 has fixed the print selection issue. Thank You!

Alexander Sack (asac) wrote :

On Sat, Jul 26, 2008 at 01:44:44AM -0000, PJSingh5000 wrote:
> Firefox 3.0.1 has fixed the print selection issue. Thank You!
>

thanks for the follow up

 affects ubuntu/firefox-3.0
 status fixreleased
 affects ubuntu/xulrunner-1.9
 status fixreleased

 - Alexander

Changed in firefox-3.0:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments