review make install target and package-static files

Bug #194342 reported by Alexander Sack on 2008-02-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
firefox-3.0 (Ubuntu)
High
Fabien Tassin
xulrunner-1.9 (Ubuntu)
High
Fabien Tassin

Bug Description

Binary package hint: xulrunner-1.9

we should be sure before final release that the make install isn't missing any file we might want.

to do that auditing, we need at least a diff of the filenames in dist/bin and /usr/lib/$APP-$VERSION/ at least.

A diff of IDL and .h filenames would be beneficial as well.

Alexander Sack (asac) wrote :

this should happen _before_ hardy beta

Changed in firefox-3.0:
importance: Undecided → High
milestone: none → ubuntu-8.04-beta
status: New → Confirmed
Changed in xulrunner-1.9:
importance: Undecided → High
milestone: none → ubuntu-8.04-beta
status: New → Confirmed
Changed in firefox-3.0:
assignee: nobody → fta
Changed in xulrunner-1.9:
assignee: nobody → fta
Fabien Tassin (fta) wrote :

Here is xulrunner-1.9 using the forthcoming mozilla-devscripts 0.5 compare module:

ix:~/bzr/build-area/xulrunner-1.9-1.9~b4~cvs20080215t0338+nobinonly$ debian/rules compare
## Compare the content of dist/bin and debian/tmp...
-.autoreg
-nsinstall
-regxpcom
## =================================================
## Compare the content of debian/tmp and the debs...
-usr/lib/xulrunner-addons/extensions/{59c81df5-4b7a-477b-912d-4e0fdf64e5f2}/chrome/chatzilla.jar
-usr/lib/xulrunner-addons/extensions/{59c81df5-4b7a-477b-912d-4e0fdf64e5f2}/chrome/icons/default/chatzilla-window16.xpm
-usr/lib/xulrunner-addons/extensions/{59c81df5-4b7a-477b-912d-4e0fdf64e5f2}/chrome/icons/default/chatzilla-window.ico
-usr/lib/xulrunner-addons/extensions/{59c81df5-4b7a-477b-912d-4e0fdf64e5f2}/chrome/icons/default/chatzilla-window.xpm
-usr/lib/xulrunner-addons/extensions/{59c81df5-4b7a-477b-912d-4e0fdf64e5f2}/chrome.manifest
-usr/lib/xulrunner-addons/extensions/{59c81df5-4b7a-477b-912d-4e0fdf64e5f2}/components/chatzilla-service.js
-usr/lib/xulrunner-addons/extensions/{59c81df5-4b7a-477b-912d-4e0fdf64e5f2}/install.rdf
-<email address hidden>/platform/OS2/chrome/icons/default/winInspectorMain.ico
-<email address hidden>/platform/WINNT/chrome/icons/default/winInspectorMain.ico
## End of Compare

Looks good.

I didn't compare the SDK for the 1st test, which is supposed to be a full copy (using tar | tar).

Fabien Tassin (fta) wrote :

and here is firefox-3.0:

ix:~/bzr/build-area/firefox-3.0-3.0~b4~cvs20080215t1220+nobinonly$ debian/rules compare
## Compare the content of dist/bin and debian/tmp...
-components/browsercompsbase.xpt
-components/browser-feeds.xpt
-components/browserplaces.xpt
-components/browsersearch.xpt
+components/browser.xpt
-components/fuel.xpt
-components/microsummaries.xpt
-components/migration.xpt
-components/safebrowsing.xpt
-components/sessionstore.xpt
-components/shellservice.xpt
-<email address hidden>/platform/OS2/chrome/icons/default/winInspectorMain.ico
-<email address hidden>/platform/WINNT/chrome/icons/default/winInspectorMain.ico
-LICENSE
-nsinstall
+removed-files
## =================================================
## Compare the content of debian/tmp and the debs produced...
-usr/lib/firefox-3.0b4pre/libjemalloc.so
## End of Compare

I'll fix libjemalloc.so in the firefox-3.0.head bzr branch (it's new to beta4).
About the xpt, I'm not sure.

Alexander Sack (asac) wrote :

ok, but thats debian/tmp vs. debs? ... how about dist/bin vs. debian/tmp (or debs)?

Fabien Tassin (fta) wrote :

you have both

1/ Compare the content of dist/bin and debian/tmp
2/ Compare the content of debian/tmp and the debs produced

Alexander Sack (asac) wrote :

yes, but the above comment doesn't show the results for compare2, does it?

Alexander Sack (asac) wrote :

oh, sorry. apparently i oversaw the first paste.

Alexander Sack (asac) wrote :

OK, looking at https://bugs.edge.launchpad.net/ubuntu/+source/xulrunner-1.9/+bug/194342/comments/3
i think we should

 1. add the nsinstall to -dev
 2. install .autoreg in normal package and touch it in postinst of every package shipping components/extensions
 3. think about chatzilla.

Alexander Sack (asac) wrote :

this looks good now, but should be reconfirmed for final release.

Changed in xulrunner-1.9:
milestone: ubuntu-8.04-beta → ubuntu-8.04
Changed in firefox-3.0:
milestone: ubuntu-8.04-beta → ubuntu-8.04
Alexander Sack (asac) wrote :

mozilla-devscripts compare output cut out of http://launchpadlibrarian.net/13413793/buildlog_ubuntu-hardy-i386.xulrunner-1.9_1.9~cvs20080413t1131%2Bnobinonly-0ubuntu1~fta1_FULLYBUILT.txt.gz

## Compare the content of dist/bin and debian/tmp...
-.autoreg
-nsinstall
-regxpcom
## =================================================
## Compare the content of debian/tmp and the debs produced...
+etc/xulrunner-1.9/system-greprefs.js
+usr/lib/xulrunner-1.9b5/.autoreg
-<email address hidden>/platform/OS2/chrome/icons/default/winInspectorMain.ico
-<email address hidden>/platform/WINNT/chrome/icons/default/winInspectorMain.ico
-usr/lib/xulrunner-addons/extensions/{59c81df5-4b7a-477b-912d-4e0fdf64e5f2}/chrome.manifest
-usr/lib/xulrunner-addons/extensions/{59c81df5-4b7a-477b-912d-4e0fdf64e5f2}/chrome/chatzilla.jar
-usr/lib/xulrunner-addons/extensions/{59c81df5-4b7a-477b-912d-4e0fdf64e5f2}/chrome/icons/default/chatzilla-window.ico
-usr/lib/xulrunner-addons/extensions/{59c81df5-4b7a-477b-912d-4e0fdf64e5f2}/chrome/icons/default/chatzilla-window.xpm
-usr/lib/xulrunner-addons/extensions/{59c81df5-4b7a-477b-912d-4e0fdf64e5f2}/chrome/icons/default/chatzilla-window16.xpm
-usr/lib/xulrunner-addons/extensions/{59c81df5-4b7a-477b-912d-4e0fdf64e5f2}/components/chatzilla-service.js
-usr/lib/xulrunner-addons/extensions/{59c81df5-4b7a-477b-912d-4e0fdf64e5f2}/install.rdf
## End of Compare

... the difference is intentional. closing xulrunner-1.9 task.

Changed in xulrunner-1.9:
status: Confirmed → Fix Released
Alexander Sack (asac) wrote :

compare target is rnu by default since 3.0 b5.

From: http://launchpadlibrarian.net/13136118/buildlog_ubuntu-hardy-i386.firefox-3.0_3.0~b5%2Bnobinonly-0ubuntu1_FULLYBUILT.txt.gz

## Compare the content of dist/bin and debian/tmp...
-LICENSE
-components/browser-feeds.xpt
-components/browsercompsbase.xpt
-components/browserplaces.xpt
-components/browsersearch.xpt
-components/fuel.xpt
+components/browser.xpt
-components/microsummaries.xpt
-components/migration.xpt
-components/sessionstore.xpt
-components/shellservice.xpt
-nsinstall
+removed-files
## =================================================
## Compare the content of debian/tmp and the debs produced...
+usr/lib/firefox-3.0b5/.autoreg
+usr/share/apport/package-hooks/firefox-3.0.py
## End of Compare

Changed in firefox-3.0:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers