Word spacing issue in Firefox 3

Bug #193108 reported by riahmatic
26
Affects Status Importance Assigned to Milestone
Mozilla Firefox
Fix Released
Medium
pango-graphite (Ubuntu)
Undecided
Unassigned
xulrunner-1.9 (Ubuntu)
Low
Unassigned

Bug Description

Running Hardy 2.6.24-8-generic #1 SMP Thu Feb 14 20:40:45 UTC 2008 i686 GNU/Linux

A recent update replaced Firefox 2.0.0.12 with Firefox 3.0b3. Upon loading Firefox 3 for the first time (after a system restart), spacing between words on all web pages and chrome pages were the width of 4-5 spaces instead of one. The only text not affected is the window titlebar.

Even in a newly created Hardy user account Firefox still has this appearance.

Revision history for this message
In , Martijn-martijn (martijn-martijn) wrote :

I have no idea, which patch might have caused this, maybe roc knows more about this?

Revision history for this message
In , Roc-ocallahan (roc-ocallahan) wrote :

I don't really know, the timeframe might make it just a new-textframe thing. Someone just needs to debug it.

Revision history for this message
In , Joe Smith (yasumoto7) wrote :

Created attachment 283276
Ubuntu 7.10 with pango-graphite

I just installed pango-graphite_0.9.2-3_i386.deb from http://packages.debian.org/lenny/pango-graphite/i386/download and restarted firefox, and have the same spacing issue. It's not increasing the amount of spaces, just increasing the length of whitespace for each space. I'm also getting this warning:

** (gecko:8265): WARNING **: Exception in gr::RangeSegment

at least 100 times in the terminal that I'm running this from.

I'm running Ubuntu 7.10 beta, and Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a9pre) Gecko/2007100209 Minefield/3.0a9pre ID:2007100209

Revision history for this message
In , Joe Smith (yasumoto7) wrote :

When I uninstall the package, the spaces return to the normal length

Revision history for this message
In , Aleksej (aleksejrs) wrote :

Filed a bug on this in Debian's BTS: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=445185

Revision history for this message
In , Aleksej (aleksejrs) wrote :

Still reproduced with the same pango-graphite and Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9b3pre) Gecko/2007121304 Minefield/3.0b3pre

Revision history for this message
riahmatic (riahmatic) wrote :

Running Hardy 2.6.24-8-generic #1 SMP Thu Feb 14 20:40:45 UTC 2008 i686 GNU/Linux

A recent update replaced Firefox 2.0.0.12 with Firefox 3.0b3. Upon loading Firefox 3 for the first time (after a system restart), spacing between words on all web pages and chrome pages were the width of 4-5 spaces instead of one. The only text not affected is the window titlebar.

Even in a newly created Hardy user account Firefox still has this appearance.

Revision history for this message
riahmatic (riahmatic) wrote :

Screen shot. Notice the wide word spacing.

Revision history for this message
nzk (nzknzknzk) wrote :

Are you able to reproduce this bug, or does it happen only once?

Revision history for this message
nzk (nzknzknzk) wrote :

Also, have you tried any other web pages? And does this persist throughout the entire session, or only immediately after opening?

Revision history for this message
riahmatic (riahmatic) wrote :

It happens on all web pages throughout the session each time I run Firefox. All rendered text seems to be affected; web pages, dialogs, address bar, chrome, view-source, everything.

Happens for all users too, even root.

Revision history for this message
nzk (nzknzknzk) wrote :

Have you tried using a different desktop environment?

Revision history for this message
Alexander Sack (asac) wrote :

maybe you have tweaked your font settings at some point?

Changed in firefox-3.0:
status: New → Incomplete
importance: Undecided → Low
Revision history for this message
riahmatic (riahmatic) wrote :

I haven't tried a different desktop environment yet.

I did tweak font settings, but even on an un-tweaked fresh account it happens. I downloaded previous builds of Firefox and it only seems to happen in beta 3, whether the repo version or downloaded tar version.

Revision history for this message
Kevin Kubasik (kkubasik) wrote :

I can confirm this as well. If someone needs a specific config file that causes this, please e-mail me and I will e-mail it.

Changed in firefox-3.0:
status: Incomplete → Confirmed
Revision history for this message
Blasse (koralik) wrote :

I can confirm also. The same happens with Swiftfox and Seamonkey2 (both based on gecko 1.9)

Revision history for this message
Kevin Kubasik (kkubasik) wrote :

Is there any specific information people need to help diagnose this bug?

Revision history for this message
In , David Leverton (dleverton) wrote :

I think this is happening due to the call to pango_font_find_shaper in gfxPangoFonts.cpp line 501: the implementation for PangoFcFont simply returns the first shaper that claims to cover the relevant script, without considering the engine's covers() function. This causes Mozilla to call the Graphite shaper even for a non-Graphite font, which doesn't work very well.

I'll let someone else figure out whether this should be fixed in Mozilla or Pango....

Revision history for this message
In , Karlt (karlt) wrote :

Thanks, David. Yes it looks like pango_fc_font_find_shaper should use
pango_map_get_engines and _pango_engine_shape_covers like get_shaper_and_font
in pango-context.c.

However gfxPangoFont::GetCharSize is not being used for complex characters and
so could(/should) just use pango_font_get_glyph_extents.

Revision history for this message
Joe Pimentel (joe-b-pimentel) wrote :

Same here (after an upgrade from Firefox 3.0b3 to 3.0b4 and now 3.0b5).
Kubuntu (based on Hardy development branch - 2.6.24-15-386)

Revision history for this message
John Vivirito (gnomefreak) wrote :

Can you please test this with a new profile or using safe-mode like:
firefox -safe-mode
and see if you can still reproduce this.

Changed in firefox-3.0:
assignee: nobody → mozilla-bugs
Revision history for this message
riahmatic (riahmatic) wrote :

I still experience this in safe mode with a fresh profile on Firefox 3.0b5. It also happens with Mozilla XULRunner 1.9b5 - 2008040514 and when switching to KDE.

Revision history for this message
Joe Pimentel (joe-b-pimentel) wrote : Re: [Bug 193108] Re: Word spacing issue in Firefox 3

Same problem in safe-mode.
Joe

On 4/9/08, John Vivirito <email address hidden> wrote:
> Can you please test this with a new profile or using safe-mode like:
> firefox -safe-mode
> and see if you can still reproduce this.
>
> ** Changed in: firefox-3.0 (Ubuntu)
> Assignee: (unassigned) => Mozilla Bugs (mozilla-bugs)
>
>
> --
> Word spacing issue in Firefox 3
> https://bugs.launchpad.net/bugs/193108
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Revision history for this message
John Vivirito (gnomefreak) wrote :

Added package xulrunner-1.9 due to comments.

Revision history for this message
Chris Lawrence (lawrencc) wrote :

I tracked this problem down on one of my Debian boxes; this may also apply to Ubuntu, but I'm not sure.

The culprit appears to be the pango-graphite package. If I purge it, the Exceptions and spacing bugs go away, suggesting that Firefox has no clue how to deal with the Graphite extensions to TrueType/OpenType fonts.

Revision history for this message
Joe Pimentel (joe-b-pimentel) wrote :
  • unnamed Edit (1.3 KiB, text/html; charset=ISO-8859-1)

Gotcha!
Worked like a charm at Ubuntu Hardy 8.04 - Mozilla/5.0 (X11; U; Linux i686;
en-US; rv:1.9b5) Gecko/2008040514 Firefox/3.0b5!
After package remove multiple spaces turn into single spaces.
I was using Opera Browser since this bug starts.
Now I'll return back to FF3.
Thanks very much for this answer.
Best Regards,
Joe

On Wed, May 7, 2008 at 12:08 PM, Chris Lawrence <email address hidden> wrote:

> I tracked this problem down on one of my Debian boxes; this may also
> apply to Ubuntu, but I'm not sure.
>
> The culprit appears to be the pango-graphite package. If I purge it,
> the Exceptions and spacing bugs go away, suggesting that Firefox has no
> clue how to deal with the Graphite extensions to TrueType/OpenType
> fonts.
>
> --
> Word spacing issue in Firefox 3
> https://bugs.launchpad.net/bugs/193108
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Revision history for this message
riahmatic (riahmatic) wrote :

Brilliant!
Indeed it works now after purging pango-graphite.

Revision history for this message
John Vivirito (gnomefreak) wrote :

this is not really a firefox issue

Changed in firefox-3.0:
status: Confirmed → Invalid
Revision history for this message
John Vivirito (gnomefreak) wrote :

Changed package to pango-graphite Firefox doesn suggest remocommend or depend on this pacakge it should be fixed in package.
Marked confirmed

Changed in xulrunner-1.9:
status: New → Confirmed
Revision history for this message
H5N1 (h5n1-vir) wrote :

In Linux Mint Daryna this issue affects all menu items too.
If it could be of any use I can provide a screenshot.

Revision history for this message
wasimo (martinjws01) wrote :

I had the same problem, as mentionned here, with Firefox 3. Maybe you would like to take a look at my bug report. The bug number is 247129, which is now marked as duplicate. I , too, could resolve my problem by purging pango-graphite, thanks to JM Williams and Chris Lawrence.

Revision history for this message
H5N1 (h5n1-vir) wrote :

I solved just with removing the pango-graphite package.
Didn't need to purge, just remove :)

Revision history for this message
In , Karlt (karlt) wrote :

The changes that landed in bug 385263 have fixed this for pango-graphite-2.3 on Gentoo (http://bugs.gentoo.org/show_bug.cgi?id=209765).

Revision history for this message
In , Aleksej (aleksejrs) wrote :

Verified fixed on Debian GNU/Linux with:

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b1pre) Gecko/20080926211849 Minefield/3.1b1pre
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b1pre) Gecko/20080929020532 Minefield/3.1b1pre

as opposed to
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b1pre) Gecko/20080924020520 Minefield/3.1b1pre

Revision history for this message
Dabian (dabian) wrote :

I can confirm this bug. Until the package is removed (and/or purged), spacing is ugly in firefox-3.0.
(For some reason it does not affect Firefox-2.0)

I am not sure if its a bug in firefox or this package. But it seems this package is to blame, since removing it solves the problem.

Changed in firefox-3.0:
status: Invalid → Confirmed
Revision history for this message
Florian Hars (hars) wrote :

According to the Mozilla bug I added this is indeed a problem in firefox and fixed in the upstream trunk.

Changed in firefox:
status: Unknown → Fix Released
Alexander Sack (asac)
Changed in firefox-3.0:
assignee: mozilla-bugs → nobody
status: Confirmed → Triaged
Revision history for this message
In , John Vivirito (gnomefreak) wrote :

Was this fixed in xulrunner or pango-* package?

Revision history for this message
John Vivirito (gnomefreak) wrote :

By the looks of the upstream bug it was fixed in pango-* but i asked to make sure and xulrunner 1.9 has been released.

Revision history for this message
In , Karlt (karlt) wrote :

(In reply to comment #11)

Mozilla code is no longer using pango_font_find_shaper, so you could expect a fix in xulrunner-1.9.1b1.

Revision history for this message
John Vivirito (gnomefreak) wrote :

This will be fixed in xulrunner-1.9.1b1 we have not yet started packaging it for Ubuntu, When we do this bug report after tests can be closed. Maybe it will hit for Jaunty.

Changed in pango-graphite:
status: Confirmed → Invalid
Revision history for this message
Sander Deryckere (sanderd17) wrote :

Hi, I have exactly the same problem as described above, my spaces are about three times as big as they should be and it doesn't matter if I run ff in safe mode or in another user mode. I've tried to completely remove ff and install it again but it didn't make any difference. When I saw this post I've tried to search for pango-graphite and remove it but I saw it wasn't installed. Installing *-graphite and removing it again didn't make any difference. If anyone knows what to do please tell me.

Revision history for this message
Dabian (dabian) wrote :

Seems the bug is fixed upstream! Bug #247129 ( https://bugs.launchpad.net/bugs/247129 )

Is this still a problem for Ubuntu?

Revision history for this message
Dabian (dabian) wrote :

OK, messed up the bug number. Here is the real upstream bug:

mozilla-bugs #397860 ( https://bugzilla.mozilla.org/show_bug.cgi?id=397860 )

Changed in firefox:
importance: Unknown → Medium
Revision history for this message
Phillip Susi (psusi) wrote :

This package has been removed from Ubuntu. Closing all related bugs.

Changed in xulrunner-1.9 (Ubuntu):
status: Triaged → Invalid
Revision history for this message
JobIgen (jobigenvamdrup) wrote :

According to Bugzilla, the bug has been fixed upstream.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.