[Hardy] epiphany does not start, libplds4.so not found

Bug #177280 reported by Jos Dehaes on 2007-12-18
56
Affects Status Importance Assigned to Milestone
xulrunner-1.9 (Ubuntu)
Undecided
Alexander Sack

Bug Description

the nspr package contains (among others):
/usr/lib/libnspr4.so.0d
/usr/lib/libplc4.so.0d
/usr/lib/libplds4.so.0d

but epiphany is linked agains libpld4.so:

jos@hamerkeuh:~/Desktop$ ldd /usr/bin/epiphany-browser
 linux-gate.so.1 => (0xffffe000)
 libenchant.so.1 => /usr/lib/libenchant.so.1 (0xb7fa5000)
 libplds4.so => not found
 libplc4.so => not found
 libnspr4.so => not found

The nspr package should contain .so symlinks to the real libs.

Tony Yarusso (tonyyarusso) wrote :

Confirm the symptom here. However, I'm not sure about the package hint - my guess would have been xulrunner-1.9.

Changed in nspr:
status: New → Confirmed
zdnko (zdnko) wrote :

I confirm too.
I add symlinks and epiphany run.

bye

Alexander Sack (asac) wrote :

this will be fixed once we use system-nspr for xulrunner.

Changed in nspr:
assignee: nobody → asac
status: Confirmed → In Progress

I just had this in Alpha 2 of Gobuntu Hardy.

Note that this small problem leaves Gobuntu users with no usable browser (to, for example, browse the Internet to find out that they need to create symlinks). Can we make the epiphany package create the symlinks until system-nspr is used?

Alexander Sack (asac) wrote :

next upload will land within the next few days.

Changed in xulrunner-1.9:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (5.7 KiB)

This bug was fixed in the package xulrunner-1.9 - 1.9~b3~cvs20080101t1000+nobinonly-0ubuntu1

---------------
xulrunner-1.9 (1.9~b3~cvs20080101t1000+nobinonly-0ubuntu1) hardy; urgency=low

  * happy new year release for hardy (1.9b3 pre, CVS 20080101t1000) features:
    - use system-cairo (LP: #152210, LP: #164640)
    - use system-nspr/nss (LP: #177280)
    - proper pkg-config files for -unstable and system-nspr/nss (see below)
    - backed-out microb changes (back to square zero)
    - fix various embedding issues (see below)

  [ Fabien Tassin ]
  * Disable bz404634_att290373.patch and bz373196_att281782.patch until trunk
    is back in shape after the MicroB mass back out (See MozBug #408238)
    - update debian/patches/series
  * new upstream snapshot (1.9b3 pre, CVS 20071228t0918)
  * Drop patch committed upstream:
    - drop debian/patches/bz287150_att291740_hppa_fix.patch
    - update debian/patches/series
  * Add support for mozilla-devscripts
    - update debian/control
    - update debian/rules

  [ Alexander Sack ]
  * drop patches for mozilla bug #404634 completely to prepare landing of
    improved patch:
    - drop debian/patches/bz404634_att290305.patch
    - drop debian/patches/bz404634_att290373.patch
    - update debian/patches/series
  * land improved patch for mozilla bug #404634 that properly disables
    url-classifier if no profile is setup and makes nsUrlClassifierDBService
    fall-back to NS_APP_USER_PROFILE_50_DIR if NS_APP_USER_PROFILE_LOCAL_50_DIR
    is not provided by embedding app.
    - add debian/patches/bz404634_att294921.patch
    - update debian/patches/series
  * remove bz373196_att281782.patch completely from tree as it tackled a MICROB
    regression, which should now be fixed.
  * add %FULL_NSPR_CFLAGS% to libxul-embedding* Cflags .pc files to fix
    builds of embedders that link against system-nspr enabled xul
    - update debian/patches/bzXXX_pc_honour_system_nspr_nss.patch
  * do not export zlib headers with bogus symbols during make install if
    system zlib is used. This breaks embedders and happens if MOZ_INSTALLER
    is enabled.
    - add debian/patches/bzXXX_no_zlib_export_if_native.patch
    - update debian/patches/series
  * drop mozilla-devscripts from build-depends as its not needed for the
    actual package build process. Take care that debian/rules disables the
    mozilla-devscripts include if it doesn't exist
    - update debian/control
    - update debian/rules
  * add gtkmozembed_internal.h symbols to glue (mozilla bug 373918):
    - add debian/patches/bz373918_att295042.patch
    - update debian/patches/series
  * add support for GRE extensions and plugins. We now search in PROFILE, APP
    and GRE dir.
    - add debian/patches/bzXXX_gre_extension_plugin_support.patch
    - update debian/patches/series
  * explicitly create addon directories /usr/lib/xulrunner-addons/{plugins,extensions}
    - update debian/xulrunner-1.9.dirs
  * drop hard-coded --with-system-nspr and --with-system-nss from CONFIGURE
    flags
    - update debian/rules
  * don't enforce lower bound of system cairo and system nss versions
    - update debian/control

xulrunner-1.9 (1.9~b2+nobinonly-0ubuntu1) hard...

Read more...

Changed in xulrunner-1.9:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers