firefox .deb overwrites firefox.cfg which stores systemwide settings such as startpage, proxy

Bug #139543 reported by Janåke Rönnblom on 2007-09-14
6
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Medium
Mozilla Bugs
firefox-3.0 (Ubuntu)
High
Unassigned
xulrunner-1.9 (Ubuntu)
High
Fabien Tassin

Bug Description

Binary package hint: firefox

/usr/lib/firefox/firefox.cfg is used for systemwide settings of startpage, proxysettings, enable/disable of functions for all users of a system. firefox.cfg is overwritten by the latest update to Feisty (2.0.0.6+1-0ubuntu1) and all of my machines need to have a fix applied!

I use it to control a number of machines that are running Feisty in a kiosksetup and automatic updates applied. This behaviour breaks the machines!

In the lab I tried setting the firefox.cfg with chattr +i but then the updated firefox .deb isn't installed.

Alexander Sack (asac) wrote :

I can confirm that we currently do this and I see the point. However I have currently no fix for it, but we should definitly do something about this in firefox 3.0 / hardy.

Thanks,
 - Alexander

Changed in firefox:
assignee: nobody → mozilla-bugs
importance: Undecided → Medium
status: New → Confirmed

I have an app that adds some proxy settings to the firefox.cfg file. But with the latest version of Firefox this file seems crypted, and when I use my app to add settings (eg: lockPref("network.proxy.http_port", 8080);) then Firefox displays an error when it is launched (error reading config file)
What are the crypted settings? Could I remove them?
Or is it possible to switch to an unencrypted version or to crypt my proxy settings?
Thanks

Yves Glodt (yglodt) wrote :

Is there no possibility to put global, system-wide settings into /etc/firefox/pref/firefox.js ?
I tried so but had no success. If this worked we would not need to edit firefox.cfg at all.

Martin Marcher (martinmarcher) wrote :

Please correct this it is a showstopper for me to use ubuntu+firefox in our company _on all clients_.

I'd have to switch to debian to be able to reuse most parts of the infrastructure but configuring all your desktop goodies on debian is quit a lot of work....

Alexander Sack (asac) wrote :

there is /usr/lib/firefox/obscure-tool to uncrypt and crypt the .cfg file if you really need a fix for now.

Alexander Sack (asac) wrote :

(obscure-tool is in firefox-dev package)

On Sun, Feb 24, 2008 at 10:22:53PM -0000, Electro wrote:
> ** Also affects: firefox-3.0 (Ubuntu)
> Importance: Undecided
> Status: New
>

 affects ubuntu/firefox-3.0
 status confirmed
 importance high

we should look into this for ffox 3 / xul 1.9.

 affects ubuntu/firefox
 status wontfix

 - Alexander

Changed in firefox:
status: Confirmed → Won't Fix
Changed in firefox-3.0:
importance: Undecided → High
status: New → Confirmed
Fabien Tassin (fta) wrote :

The bug is in xulrunner-1.9, not in firefox-3.0. Fix committed in bazaar.

Changed in xulrunner-1.9:
assignee: nobody → fta
importance: Undecided → High
status: New → Fix Committed
Alexander Sack (asac) wrote :

this is not fix committed - yet.

We will now ship a /etc/xulrunner-1.9/ubuntu-greprefs.js file where administrators can add their general.config.filename gre setting.

You can the use either an absolute path that will apply for _all_ xulrunner applications or a relative path, which will be relative to the application install directory.

For instance it should be possible to set sysprefs/my-firefox.cfg, which then could be configured by the administrator in /etc/firefox-3.0/pref/

Changed in xulrunner-1.9:
status: Fix Committed → Triaged
Alexander Sack (asac) wrote :

Note: i added the proper fix to my local branch for now and will push this once the test build has finished.

Alexander Sack (asac) wrote :

firefox 3 will benefit from the xulrunner 1.9 patch, but isn't directly affected - code base wise.

Changed in firefox-3.0:
status: Confirmed → Invalid
Alexander Sack (asac) wrote :

fix available now. allowing administrators to lock preferences is an important use-case. milestoning as well to honour that fact.

Changed in xulrunner-1.9:
milestone: none → ubuntu-8.04
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (3.2 KiB)

This bug was fixed in the package xulrunner-1.9 - 1.9~b5+nobinonly-0ubuntu1

---------------
xulrunner-1.9 (1.9~b5+nobinonly-0ubuntu1) hardy; urgency=low

  [ Fabien Tassin <email address hidden> ]
  * Drop patch applied upstream
    - drop debian/patches/bz333308_attXXXX_make_clean_cleaner.patch
    - update debian/patches/series
  * Set LDFLAGS so dpkg-buildpackage doesn't use -Wl,-Bsymbolic-functions
    - update debian/rules
  * Add support for a defaults/syspref directory containing system wide
    preferences that will not be silently overwritten at each upgrade
    (LP: #207281, #203538).
    It works for both libxul apps such as firefox 3 and xulrunner
    applications such as prism
    - add debian/patches/add_syspref_dir.patch
    - update debian/patches/series
  * Fix broken RSS subscription
    - add debian/patches/bz423060_att312807_fix_rss_subscription.patch
    - update debian/patches/series
  * Bump depends to libnspr4-dev >= 4.7.1~beta2 and libnss3-dev >= 3.12.0~beta3
    - update update debian/control
  * Hook up mozilla-devscript's compare module to binary-post-install
    - update debian/rules

  [ Alexander Sack <email address hidden> ]
  * switch to in-source jpeg to fix rendering issues at zoom levels
    (LP: #182038); this measure should give us some performance
    improvements.
    - update debian/rules
  * make pref extensions read defaults/autoconfig from NS_GRE_DIR instead
    of NS_APP_DEFAULTS_50_DIR. If it turns out to be a bad decision, we should
    reconsider this patch.
    - add debian/patches/bzXXX_autoconfig_in_gre.patch
    - update debian/patches/series
  * install system-greprefs in /etc/xulrunner-1.9/ and create the proper
    link in $pkglibdir/greprefs to it (LP: #139543)
    - add debian/system-greprefs.js
    - update debian/rules
  * ship versioned link libsqlite3.so.0 => libsqlite3.so in $pkglibdir to
    allow liferea workaround for LP: #203413 - "Liferea creates many corrupt
    copies of places.sqlite in" by setting LD_LIBRARY_PATH properly
    - update debian/rules
  * ship .autoreg file in pkglibdir to allow autoreg touches by
    plugins/extensions et al.
    - update debian/rules
  * touch .autoreg in xulrunner-1.9.postinst and
    xulrunner-1.9-gnome-support.postinst
    - update debian/xulrunner-1.9.postinst
    - add debian/xulrunner-1.9-gnome-support.postinst
  * hook in lp-export-xpi.mk from mozilla-devscript to export en-US
    translation templates to debian/lp-export-xpis/; in turn, make
    mozilla-devscripts a hard build-depends
    - update debian/rules
    - update debian/control
  * consider NS_GRE_DIR/.autoreg to trigger component registry upgrades.
    - add debian/patches/bzXXX_gre_autoreg.patch
    - update debian/control/series
  * Fix "Dom Inspector not compatible" by bumping maxVersion field in
    extension install.rdf
    - add debian/patches/inspector_maxversion_bump.patch
    - update debian/patches/series
  * Fix xulrunner side for bug "firefox needs restart after plugin install to
    detect and activate them"; we scan for new plugins in GRE at startup runtime
    - update debian/patches/bzXXX_gre_extension_plugin_support.patch

 -- Fabien Tassin <email address hidden> ...

Read more...

Changed in xulrunner-1.9:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers