firefox-granparadiso crashes with segmentation fault

Bug #133581 reported by Shirish Agarwal on 2007-08-20
6
Affects Status Importance Assigned to Milestone
firefox-3.0 (Ubuntu)
High
Mozilla Bugs
xulrunner-1.9 (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: firefox-granparadiso

Hi all,
        firefox-granparadiso 3.0a7 crashes with a segmentation fault on http://home.arcor.de/maatrix/texts/india04.html . First of all here is my list of plugins :-

Generated: Mon Aug 20 2007 09:31:04 GMT+0530 (IST)
User Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a7) Gecko/2007081820 GranParadiso/3.0a7
Build ID: 2007081820

Enabled Extensions: [6]
- Adblock Plus 0.7.5.1: http://adblockplus.org/
- APNG Edit 1.0: http://www.mozilla.org/
- DOM Inspector 1.9a7: http://www.mozilla.org/projects/inspector/
- DownThemAll! 1.0b1: http://downthemall.net/
- MR Tech Local Install 5.3.2.5: http://www.mrtech.com/extensions/local_install/
- RefControl 0.8.9: http://www.stardrifter.org/refcontrol/

Disabled Extensions: [1]
- Foxmarks Bookmark Synchronizer 1.0.1: http://www.foxmarks.com/

Total Extensions: 7

Installed Themes: [1]
- Firefox (default): http://www.mozilla.org/

Installed Plugins: (10)
- Default Plugin
- DivX® Web Player
- GCJ Web Browser Plugin 0.92
- mplayerplug-in 3.40
- QuickTime Plug-in 6.0 / 7
- QuickTime Plug-in 7.1.3
- RealPlayer 9
- Totem Web Browser Plugin 2.19.6
- Windows Media Player Plug-in 10 (compatible; Totem)
- Windows Media Player Plugin

After this I installed all the -dbgsym files requested in https://wiki.ubuntu.com/MozillaTeam/Bugs & produce a log. Unfortunately I don't think it will help you in any way. But still attaching it all the same.

Shirish Agarwal (shirishag75) wrote :
Shirish Agarwal (shirishag75) wrote :

I disabled all plugins, it crashed saying segmented fault on that hyperlink, I made a new profile, it crashed again saying segmented fault on the hyperlink given above. I tried obtaining a traceback using https://wiki.ubuntu.com/DebuggingFirefoxDevels but then firefox-granparadiso-bin wouldn't responding after attaching gdb to it. For the whole exercise, the only exception I did from the wiki was :-

instead of firefox -g 2>&1 | tee ~/Desktop/gdb-firefox.log it was

firefox-granparadiso -g 2>&1 | tee ~/Desktop/gdb-firefox.log

Please lemme know if anything more has to be done.

Shirish Agarwal (shirishag75) wrote :

More stuff, the same URL runs fine in firefox 2.0.0.6 as well as icecape without any issues.

Thank you Shirish Agarwal, I can confirm this crash with last granparadiso (3.0~alpha7-0ubuntu6), however I can not add a report with debug symbols because there seems to be a problem with de dbgsym pacakage:

(gutsy_chroot)root@paleo:~# ls -lh /var/cache/apt/archives/firefox-granparadiso-dbgsym_3.0~alpha7-0ubuntu6_i386.ddeb
-rw-r--r-- 1 root root 8.0K Aug 18 20:25 /var/cache/apt/archives/firefox-granparadiso-dbgsym_3.0~alpha7-0ubuntu6_i386.ddeb

Changed in firefox-granparadiso:
assignee: nobody → mozilla-bugs
importance: Undecided → High
status: New → Incomplete

btw the crash happens w/o any extension or plugin installed

Is this still an issue on more recent versions of firefox-3.0?

Martin Heitzer (martin-heitzer) wrote :

The bug is not reproducable for me with firefox-3.0 beta 3 installed on a hardy machine - with many plugins and extensions installed.

Alexander Sack (asac) wrote :

most crashes in firefox-granparadiso should be fixed by xulrunner-1.9 in hardy.

Changed in firefox-3.0:
status: Incomplete → Invalid
Changed in xulrunner-1.9:
importance: Undecided → Medium
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments