can't install in pbuilder Setting up xulrunner-1.9.2 (1.9.2.3+nobinonly-0ubuntu2)

Bug #566776 reported by Dimitri John Ledkov on 2010-04-19
60
This bug affects 11 people
Affects Status Importance Assigned to Milestone
xulrunner-1.9.2 (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: xulrunner-1.9.2

I logged into pbuilder

$ apt-get install xulrunner-dev

Dpkg then hangs at

Setting up xulrunner-1.9.2 (1.9.2.3+nobinonly-0ubuntu2) ...

With xulrunner-bin process taking up all system resources:

  PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
29774 root 20 0 33784 112 32 R 98 0.0 3:48.10 xulrunner-bin

I then kill it and get:

Setting up xulrunner-1.9.2 (1.9.2.3+nobinonly-0ubuntu2) ...
Terminated
dpkg: error processing xulrunner-1.9.2 (--configure):
 subprocess installed post-installation script returned error exit status 143

I've left it xulrunner-bin running for 3 hours on my quite modern laptop so there is definatly something strange going on.

Please advice if you need any further information.

Laurent Bigonville (bigon) wrote :

Same problem here.

the call to "xulrunner --gre-version" gets stuck in postinstallation script

Changed in xulrunner-1.9.2 (Ubuntu):
status: New → Confirmed
Laurent Bigonville (bigon) wrote :

Output of /usr/bin/xulrunner-1.9.2 -g -d strace

Chris Coulson (chrisccoulson) wrote :

Is this still happening (with xulrunner-2.0, as 1.9.2 is going away)?

Changed in xulrunner-1.9.2 (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Laurent Bigonville (bigon) wrote :

Looks like it's fixed in 2.0

alq (alq666) wrote :

I'm experiencing a similar issue and I've gotten gdb to show where xulrunner-bin is stuck: https://gist.github.com/850080

alq (alq666) wrote :

Traced back to https://bugzilla.mozilla.org/show_bug.cgi?id=474155. The gdb output shows very clearly that jemalloc is re-entring code that's not reentrant on 10.04.2 amd64.

Chris Coulson - It is still happening with xulrunner-1.9.2, which is part of Lucid, which is supported up to 13.04, which makes it really hard to provide builds for LTS. It's been more than a year, and I got bitten by this bug again.

Changed in xulrunner-1.9.2 (Ubuntu):
status: Incomplete → Confirmed
Bernhard Reiter (ockham-razor) wrote :

Also happening for me with 11.04 amd64 when trying to pdebuild a package that depends on xulrunner-1.9.2-dev in a 11.04 amd64 cowbuilder. Note that the bugzilla bug report linked from comment #6 links to another launchpad bug, #333624 (which unfortunately has been set to invalid. Should it be reopened for xulrunner-1.9.2-dev?)

Dimitri John Ledkov (xnox) wrote :

Nothing should build-dep on xulrunner any more, horay for fast releases.

If it's broken in pbuilder for you, can you test in sbuild please?

Changed in xulrunner-1.9.2 (Ubuntu):
status: Confirmed → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.