build failure on ia64

Bug #555127 reported by Matthias Klose
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xulrunner-1.9.2 (Ubuntu)
Fix Released
High
Chris Coulson
Lucid
Fix Released
High
Chris Coulson

Bug Description

Binary package hint: xulrunner-1.9.2

1.9.2.2%2Bnobinonly-0ubuntu1

makes xulrunner-1.9.2-dev package uninstallable, and breaks the openjdk-6 build

c++ -o TestPoisonArea.o -c -fvisibility=hidden -DOSTYPE=\"Linux2.6\" -DOSARCH=Linux -D_IMPL_NS_LAYOUT -I. -I. -I../../../dist/include -I../../../dist/include/nsprpub -I/usr/include/nspr -I/usr/include/nss -I/usr/include -fPIC -fno-rtti -fno-exceptions -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wno-invalid-offsetof -Wno-long-long -pedantic -g -fno-strict-aliasing -fshort-wchar -pthread -pipe -DNDEBUG -DTRIMMED -Os -freorder-blocks -fno-reorder-functions -DMOZILLA_CLIENT -include ../../../mozilla-config.h -Wp,-MD,.deps/TestPoisonArea.pp TestPoisonArea.cpp
TestPoisonArea.cpp:178:2: error: #error "Need return instruction for this architecture"
TestPoisonArea.cpp: In function 'uintptr_t ReserveNegativeControl()':
TestPoisonArea.cpp:382: error: 'RETURN_INSTR' was not declared in this scope
make[6]: *** [TestPoisonArea.o] Error 1
make[6]: Leaving directory `/build/buildd/xulrunner-1.9.2-1.9.2.2+nobinonly/build-tree/mozilla/layout/base/tests'
make[5]: *** [libs] Error 2

Matthias Klose (doko)
Changed in xulrunner-1.9.2 (Ubuntu):
milestone: none → ubuntu-10.04-beta-2
status: New → Confirmed
Revision history for this message
Steve Langasek (vorlon) wrote :

This also blocks couchdb from rebuilding on ia64 and holds xulrunner-1.9.1 in component-mismatches, so marking as high; not particularly tied to beta2, however.

Changed in xulrunner-1.9.2 (Ubuntu Lucid):
importance: Undecided → High
milestone: ubuntu-10.04-beta-2 → ubuntu-10.04
Revision history for this message
Chris Coulson (chrisccoulson) wrote :

I've disabled the unit tests for xulrunner on ia64 for now until we figure out why it's not working

Changed in xulrunner-1.9.2 (Ubuntu Lucid):
status: Confirmed → Fix Committed
assignee: nobody → Chris Coulson (chrisccoulson)
Revision history for this message
Chris Coulson (chrisccoulson) wrote :

FWIW, the test which is failing seems to allocate a block of memory and then fills it with return instructions. The return instruction for the build architecture is defined at the top of the source file, but there is no return instruction defined for ia64

/* This program assumes that a whole number of return instructions fit into
 * 32 bits, and that 32-bit alignment is sufficient for a branch destination.
 */

#if defined __i386__ || defined __x86_64__ || \
  defined __i386 || defined __x86_64 || \
  defined _M_IX86 || defined _M_AMD64
#define RETURN_INSTR 0xC3C3C3C3 /* ret; ret; ret; ret */

#elif defined __arm__ || defined _M_ARM
#define RETURN_INSTR 0xE12FFF1E /* bx lr */

// PPC has its own style of CPU-id #defines. There is no Windows for
// PPC as far as I know, so no _M_ variant.
#elif defined _ARCH_PPC || defined _ARCH_PWR || defined _ARCH_PWR2
#define RETURN_INSTR 0x4E800020 /* blr */

#elif defined __sparc || defined __sparcv9
#define RETURN_INSTR 0x81c3e008 /* retl */

#else
#error "Need return instruction for this architecture"
#endif

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xulrunner-1.9.2 - 1.9.2.3+nobinonly-0ubuntu1

---------------
xulrunner-1.9.2 (1.9.2.3+nobinonly-0ubuntu1) lucid; urgency=low

  * New upstream release v1.9.2.3 (FIREFOX_3_6_3_RELEASE)

  * Provide a dummy xulrunner-1.9 binary package to handle a case where
    the update-alternatives calls in the old prerm script fail when the
    package is removed after a Hardy => Lucid upgrade, if no other
    xulrunner version is present on the system (LP: #525621)
    - update debian/control
    - add debian/xulrunner-1.9.prerm
  * Use the dummy xulrunner-1.9 package to clean up obsolete conffiles
    during Hardy => Lucid upgrades
    - add debian/xulrunner-1.9.preinst
  * Refreshed patches for new upstream source
    - update debian/patches/add_syspref_dir.patch
  * Disable unit tests for now on ia64 (LP: #555127)
    - update debian/rules
 -- Chris Coulson <email address hidden> Thu, 08 Apr 2010 01:19:03 +0100

Changed in xulrunner-1.9.2 (Ubuntu Lucid):
status: Fix Committed → Fix Released
Revision history for this message
Matthias Klose (doko) wrote :

still fails to build, still blocking openjdk-6 builds:

dh_install: xulrunner-1.9.2-testsuite missing files (debian/tmp/usr/lib/xulrunner-1.9*/chrome/pageloader.jar), aborting
make: *** [binary-post-install/xulrunner-1.9.2] Error 2
dpkg-buildpackage: error: /usr/bin/fakeroot debian/rules binary-arch gave error exit status 2

Changed in xulrunner-1.9.2 (Ubuntu Lucid):
status: Fix Released → Triaged
Revision history for this message
Chris Coulson (chrisccoulson) wrote :

B'ah, that's because it's not running the test-suite any more.

Ok, I will try to fix and reenable the test-suite properly tomorrow

Revision history for this message
Micah Gersten (micahg) wrote : Re: [Bug 555127] Re: build failure on ia64

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

How about making it only include the test suite if it's enabled?

On 04/12/2010 09:14 PM, Chris Coulson wrote:
> B'ah, that's because it's not running the test-suite any more.
>
> Ok, I will try to fix and reenable the test-suite properly tomorrow
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iEYEARECAAYFAkvD2DIACgkQTniv4aqX/Vlz1QCeMOfY0n0yc0Qmbrec9iumQ2Sg
swsAnRZnxALLwgCZdshcL9u3v1B8N9TU
=0/Ah
-----END PGP SIGNATURE-----

Changed in xulrunner-1.9.2 (Ubuntu Lucid):
status: Triaged → In Progress
Changed in xulrunner-1.9.2 (Ubuntu Lucid):
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xulrunner-1.9.2 - 1.9.2.3+nobinonly-0ubuntu2

---------------
xulrunner-1.9.2 (1.9.2.3+nobinonly-0ubuntu2) lucid; urgency=low

  * Fix unit test failures on IA-64 - specify a return instruction for this
    architecure (LP: #555127)
    - add debian/patches/fix_ia64_unit_test_failure.patch
    - update debian/patches/series
  * Re-enable unit tests on IA-64
    - update debian/rules
 -- Chris Coulson <email address hidden> Tue, 13 Apr 2010 16:54:43 +0100

Changed in xulrunner-1.9.2 (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers