package xulrunner-1.9 1.9.0.18+build1+nobinonly-0ubuntu0.8.04.1 failed to install/upgrade: subprocess installed pre-removal script returned error exit status 2

Bug #525621 reported by Mario Limonciello on 2010-02-22
34
This bug affects 6 people
Affects Status Importance Assigned to Milestone
xulrunner-1.9.2 (Ubuntu)
High
Chris Coulson
Nominated for Lucid by Chris Coulson

Bug Description

Binary package hint: xulrunner-1.9

during a hardy -> lucid dist-upgrade (probably the cleanup at the end?)

ProblemType: Package
Architecture: amd64
Date: Mon Feb 22 01:30:19 2010
DistroRelease: Ubuntu 10.04
ErrorMessage: subprocess installed pre-removal script returned error exit status 2
Package: xulrunner-1.9 1.9.0.18+build1+nobinonly-0ubuntu0.8.04.1
ProcVersionSignature: Ubuntu 2.6.32-14.20-generic
SourcePackage: xulrunner-1.9
Title: package xulrunner-1.9 1.9.0.18+build1+nobinonly-0ubuntu0.8.04.1 failed to install/upgrade: subprocess installed pre-removal script returned error exit status 2
Uname: Linux 2.6.32-14-generic x86_64

Mario Limonciello (superm1) wrote :
Rolf Leggewie (r0lf) wrote :

from your dpkg terminal log:
Removing xulrunner-1.9 ...
update-alternatives: error: no alternatives for xulrunner.
update-alternatives: error: no alternatives for xulrunner.
dpkg: error processing xulrunner-1.9 (--purge):
 subprocess installed pre-removal script returned error exit status 2

I just ran into the exact same issue when upgrading an i386 hardy server to lucid

tags: added: hardy2lucid
removed: amd64
Changed in xulrunner-1.9 (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Micah Gersten (micahg) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as Triaged and let them handle it from here. Thanks for taking the time to make Ubuntu better! Please report any other issues you may find.

Changed in xulrunner-1.9 (Ubuntu):
assignee: nobody → Micah Gersten (micahg)
milestone: none → ubuntu-10.04-beta-1
status: Confirmed → Triaged
Rolf Leggewie (r0lf) wrote :

seems to affect not only hardy2lucid, but jaunty2karmic as well -> bug 400848 which I think is a dupe

Rolf Leggewie (r0lf) wrote :

FWIW, reinstalling http://de.archive.ubuntu.com/ubuntu/pool/main/x/xulrunner-1.9/xulrunner-1.9_1.9.0.18+build1+nobinonly-0ubuntu0.8.04.1_i386.deb (to get u-a to reinstall xulrunner-1.9 alternatives) before removing the package worked fine now.

I spotted something on the console to the effect of "old postinst script returned an error, trying the one from the package instead, that seems to have gone OK". I'm a little surprised about that, the package was at the latest version AFAIR.

Micah Gersten (micahg) wrote :

Deferring to Beta 2.

Changed in xulrunner-1.9 (Ubuntu):
milestone: ubuntu-10.04-beta-1 → ubuntu-10.04-beta-2
Micah Gersten (micahg) on 2010-04-01
Changed in xulrunner-1.9 (Ubuntu):
assignee: Micah Gersten (micahg) → Chris Coulson (chrisccoulson)
Chris Coulson (chrisccoulson) wrote :

This will probably need to be fixed in xulrunner-1.9.2 by providing a transitional package for Hardy users

affects: xulrunner-1.9 (Ubuntu) → xulrunner-1.9.2 (Ubuntu)
Changed in xulrunner-1.9.2 (Ubuntu):
status: Triaged → In Progress
Chris Coulson (chrisccoulson) wrote :

bzr commit -m '* Provide a dummy xulrunner-1.9 binary package to handle a case where
  the update-alternatives calls in the old prerm script fail when the
  package is removed after a Hardy => Lucid upgrade, if no other
  xulrunner version is present on the system (LP: #525621)
  - update debian/control
  - add debian/xulrunner-1.9.prerm
* Use the dummy xulrunner-1.9 package to clean up obsolete conffiles
  during Hardy => Lucid upgrades
  - add debian/xulrunner-1.9.preinst' --fixes 'lp:525621'
Committing to: /home/chr1s/src/xulrunner/xulrunner-1.9.2.head/
modified debian/changelog
modified debian/control
added debian/xulrunner-1.9.preinst
added debian/xulrunner-1.9.prerm
Committed revision 528.

Changed in xulrunner-1.9.2 (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xulrunner-1.9.2 - 1.9.2.3+nobinonly-0ubuntu1

---------------
xulrunner-1.9.2 (1.9.2.3+nobinonly-0ubuntu1) lucid; urgency=low

  * New upstream release v1.9.2.3 (FIREFOX_3_6_3_RELEASE)

  * Provide a dummy xulrunner-1.9 binary package to handle a case where
    the update-alternatives calls in the old prerm script fail when the
    package is removed after a Hardy => Lucid upgrade, if no other
    xulrunner version is present on the system (LP: #525621)
    - update debian/control
    - add debian/xulrunner-1.9.prerm
  * Use the dummy xulrunner-1.9 package to clean up obsolete conffiles
    during Hardy => Lucid upgrades
    - add debian/xulrunner-1.9.preinst
  * Refreshed patches for new upstream source
    - update debian/patches/add_syspref_dir.patch
  * Disable unit tests for now on ia64 (LP: #555127)
    - update debian/rules
 -- Chris Coulson <email address hidden> Thu, 08 Apr 2010 01:19:03 +0100

Changed in xulrunner-1.9.2 (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers