Can't uninstall/remove xulrunner-1.9.1

Bug #367354 reported by Arne Nordmann on 2009-04-26
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xulrunner-1.9.1 (Ubuntu)
Undecided
Unassigned

Bug Description

If I want to remove xulrunner-1.9.1 with synaptic, aptitude or dpkg, it fails and I get the following error(s) (german):

>sudo apt-get remove xulrunner-1.9.1
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut
Lese Status-Informationen ein... Fertig
Die folgenden Pakete werden ENTFERNT:
  xulrunner-1.9.1
0 aktualisiert, 0 neu installiert, 1 zu entfernen und 0 nicht aktualisiert.
1 nicht vollständig installiert oder entfernt.
Nach dieser Operation werden 21,5MB Plattenplatz freigegeben.
Möchten Sie fortfahren [J/n]?
> j
(Lese Datenbank ... 104717 Dateien und Verzeichnisse sind derzeit installiert.)
Entferne xulrunner-1.9.1 ...
update-alternatives: Fehler oder EOF beim Lesen von /var/lib/dpkg/alternatives/xulrunner für update_mode ()
dpkg: Fehler beim Bearbeiten von xulrunner-1.9.1 (--remove):
 Unterprozess pre-removal script gab den Fehlerwert 2 zurück
Bus error
dpkg: Fehler beim Aufräumen:
 Unterprozess post-installation script gab den Fehlerwert 135 zurück
Fehler traten auf beim Bearbeiten von:
 xulrunner-1.9.1
E: Sub-process /usr/bin/dpkg returned an error code (1)

I'm using an up-to-date Kubuntu 9.04.

jehon (jeanhonlet) wrote :

Same problem for me....

Making an apt-get upgrade today, firefox refuse to install...

Same problem in file /var/lib/dpkg/alternatives/xulrunner

That file is empty, and seems to cause problem to dpkg.

Any clue?

Thank for support

jehon (jeanhonlet) wrote :

Problem solved by editing /var/lib/dpkg/alternatives/xulrunner:

content who should be there:

auto
/usr/bin/xulrunner

/usr/bin/xulrunner-1.9
50

Don't know what it does!

After that, I made a remove --purge, and reinstall it and things seems to come back

ubername (ubername) wrote :

I tried the solution mentioned by jehon on 2009-06-15 but continue to get:

E: xulrunner-1.9: subprocess pre-removal script returned error exit status 2

ubername (ubername) wrote :

Should have posted this with my comment above

:~$ sudo apt-get remove xulrunner-1.9 --purge
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  g++-4.3 java-common sun-java6-bin libx264-65 sun-java6-jre
  libstdc++6-4.3-dev liblrdf0
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED
  xulrunner-1.9*
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
2 not fully installed or removed.
After this operation, 26.8MB disk space will be freed.
Do you want to continue [Y/n]? y
(Reading database ... 138408 files and directories currently installed.)
Removing xulrunner-1.9 ...
update-alternatives: error or eof reading /var/lib/dpkg/alternatives/xulrunner for version ()
dpkg: error processing xulrunner-1.9 (--purge):
 subprocess pre-removal script returned error exit status 2
Errors were encountered while processing:
 xulrunner-1.9
E: Sub-process /usr/bin/dpkg returned an error code (1)

Lyubomir Georgiev (krull) wrote :

My /var/lib/dpkg/alternatives/xulrunner was empty.

So I did "sudo rm /var/lib/dpkg/alternatives/xulrunner"

then reinstalled xulrunner-1.9.1 (like: sudo apt-get install xulrunner-1.9.1 )

then ... purged xulrunner-1.9.1 ( sudo apt-get purge xulrunner-1.9.1 )

Now everything is fine

thdr (kotsilieris) wrote :

that did the trick for me too

jehon (jeanhonlet) wrote :

Ubername:

>> update-alternatives: error or eof reading /var/lib/dpkg/alternatives/xulrunner for version ()

That line show you didn't fill in correctly the file...

John Vivirito (gnomefreak) wrote :

This was fixed as i recall, please confirm that it has been.

jehon (jeanhonlet) wrote :

Never had the problem again...

Never get into the same situation neither

Thanks for your support!

Changed in xulrunner-1.9.1 (Ubuntu):
status: New → Fix Released
Matt Pharoah (mr-exuberant) wrote :

When attempting to do the security updates yesterday (Jan 8, 2010), I am now experiencing this error. I tried purging xulrunner-1.9.1, then getting back the packages I need (using update manager to get desktop-couch back and apt-get install firefox to get the rest back, but I'm still getting the same errors.)

sudo apt-get install xulrunner-1.9.1
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be upgraded:
  xulrunner-1.9.1
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
15 not fully installed or removed.
Need to get 0B/9,102kB of archives.
After this operation, 0B of additional disk space will be used.
(Reading database ... 238918 files and directories currently installed.)
Preparing to replace xulrunner-1.9.1 1.9.1.6+nobinonly-0ubuntu0.9.10.1 (using .../xulrunner-1.9.1_1.9.1.7+nobinonly-0ubuntu0.9.10.1_amd64.deb) ...
Unpacking replacement xulrunner-1.9.1 ...
/rm/rm: cannot remove `/usr/lib/xulrunner-1.9.1.6/python/xpcom/__init__.pyo': No such file or directory
dpkg: warning: old post-removal script returned error exit status 1
dpkg - trying script from the new package instead ...
/rm/rm: cannot remove `/usr/lib/xulrunner-1.9.1.7/python/xpcom/__init__.pyo': No such file or directory
dpkg: error processing /var/cache/apt/archives/xulrunner-1.9.1_1.9.1.7+nobinonly-0ubuntu0.9.10.1_amd64.deb (--unpack):
 subprocess new post-removal script returned error exit status 1
/rm/rm: cannot remove `/usr/lib/xulrunner-1.9.1.7/python/xpcom/__init__.pyo': No such file or directory
dpkg: error while cleaning up:
 subprocess new post-removal script returned error exit status 1
Errors were encountered while processing:
 /var/cache/apt/archives/xulrunner-1.9.1_1.9.1.7+nobinonly-0ubuntu0.9.10.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

This is pretty annoying because I am unable to use Firefox on Ubuntu now.

Changed in xulrunner-1.9.1 (Ubuntu):
status: Fix Released → Confirmed
Matt Pharoah (mr-exuberant) wrote :

Nevermind. I found that the problem was simply that when I replaced rm with a shell script that executes rm $* -I to require confimation, this caused dpkg to fail when removing files. I'm not sure why this problem only affected xulrunner and no other packages I installed and removed, but I guess it required that rm be a binary file rather than a shell script, which isn't a bug.

Changed in xulrunner-1.9.1 (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions