Ubuntu

On login to xubuntu session, starts nautilus which ruins desktop

Reported by Puppu Tuppu on 2011-08-28
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xubuntu-meta (Ubuntu)
Medium
Unassigned

Bug Description

WORKAROUND: killall nautilus

When I login using the "xubuntu" session, it starts nautilus which automatically overwrites the xfce desktop with the nautilus desktop and brings the nautilus menu panel to the upper edge of the screen (file, edit, etc.)

This is probably not expected behavior.

Also, it often fails to start xfwm

ProblemType: BugDistroRelease: Ubuntu 11.10
Package: xubuntu-desktop 2.137
ProcVersionSignature: Ubuntu 3.0.0-9.14-generic 3.0.3
Uname: Linux 3.0.0-9-generic i686
Architecture: i386
Date: Sun Aug 28 21:45:21 2011
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bashSourcePackage: xubuntu-meta
UpgradeStatus: Upgraded to oneiric on 2011-08-24 (4 days ago)

Puppu Tuppu (puppu-tuppu) wrote :

Thank you for reporting this bug. Unfortunately, we need more information to begin working to resolve this issue. I have done many installations of Xubuntu Oneiric. Nautilus has not installed by default. How did nautilus get installed? What are the steps to reproduce this issue?

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

I think "Puppu Tuppu" has installed additional programs (like rhythmbox), that have nautilus as a dependence. The workaround is removing the Nautilus/Files process on the Session & Startup -> Application Autostart list or just with the old but good:

sudo apt-get --purge remove nautilus

I think that an official fix preventing this behaviour should be implemented.

Best Regards

Francesco

Puppu Tuppu (puppu-tuppu) wrote :

Nope.

xyz@ubuntu:~$ aptitude search ~i\!~M
i apache2-mpm-prefork - Apache HTTP Server - traditional non-threaded model
i byobu - powerful, text based window manager and shell multiplexer
i comix - GTK Comic Book Viewer
i fglrx - Video driver for the AMD graphics accelerators
i google-chrome-stable - The web browser from Google
i language-pack-en - translation updates for language English
i linux-generic - Complete Generic Linux kernel
i skype - Skype
i spotify-client-gnome-support - Spotify desktop gnome support
i ubuntu-minimal - Minimal core of Ubuntu
i ubuntu-standard - The Ubuntu standard system
i xubuntu-desktop - Xubuntu desktop system
xyz@ubuntu:~$

Though I would suggest you note xubuntu-desktop now depends on several gnome apps and libraries.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xubuntu-meta (Ubuntu):
status: New → Confirmed

Nautilus has not installed by default. How did nautilus get installed? What are the steps to reproduce this issue?

Changed in xubuntu-meta (Ubuntu):
status: Confirmed → Incomplete
description: updated
Micah Gersten (micahg) on 2011-09-25
description: updated
description: updated

This issue should now be fixed in Oneiric Ocelot. To use Nautilus as the default file manager now requires specific action on the part of the user. As long as Thunar is installed, it should run instead of Nautilus.

Changed in xubuntu-meta (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers