Xubuntu Desktop CD needs more than 128 MB RAM to boot

Bug #70561 reported by Otto Kekäläinen on 2006-11-06
26
Affects Status Importance Assigned to Milestone
xubuntu-meta (Baltix)
Undecided
Unassigned
xubuntu-meta (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: xubuntu-live

The specs for Xubuntu Desktop CD say that it requires 128 MB RAM to boot. This seems to be incorrect.

I've booted the Xubuntu Desktop CD on an older laptop (Fujitsu E-series with 128 MB RAM). The desktop is missing all panels and is extremely slow. Command "free -m" on console shows that all memory has been used and there is 0 MB RAM left.

When I add some swap space with "swapon /dev/hda2" (which I have made into a swap partition) everything starts workin much smoother, which confirms that the issue is simply that Xubuntu Desktop CD uses more than 128 MB of RAM to run.

Unfortunately I could not install Xubuntu using Ubiquity, since the every step where hard drive partitions are scanned (startup of gparted, startup of partitioning, startup of copying files) the systems seems to automatically unmount the swap partition, thus killing the memory of all applications and thus also the Ubiquity installer halts.

Daniele Favara (nomed) wrote :

i noticed the same.

Talking to casper maintainer a while ago he told he would accept a patch to allow the creation of swap devices even on fat partition.

Then .. it's true that ubiquity umount swap devices as it's suppoesed to format them too.

The gtk frontend needs mem, there is a text frontend sitting there that could be used.

It would even be nice to see how it works using libexo where possible

Changed in xubuntu-meta:
assignee: nobody → xubuntu-team
status: Unconfirmed → Confirmed
Otto Kekäläinen (otto) wrote :

I tested Xubuntu Desktop CD on another laptop, and there "free -m" showed that the default Xubuntu used 329 MB of RAM.

there is an hot discussion on the devel list:

https://lists.ubuntu.com/archives/xubuntu-devel/2006-November/002423.html.

we'll probably came back to this bug when that discussion is over :).

On 11/7/06, Otto Kekäläinen <email address hidden> wrote:
> I tested Xubuntu Desktop CD on another laptop, and there "free -m"
> showed that the default Xubuntu used 329 MB of RAM.
>
> --
> Xubuntu Desktop CD needs more than 128 MB RAM to boot
> https://launchpad.net/bugs/70561
>

--
----
http://dsslive.org
----

tarski (guy-laffitte) wrote :

   I found a way to install Xubuntu Dapper on a little machine ( laptop IBM Thinkpad with 128 MB memory ).

   The main problem is that ubiquity unmounts all swap parttions during disk partitioning.

   My solution needs two tricks :
1 Use a swap partition on a USB key,
2 Prevent ubiquity from unmounting it.

   I added a third trick : create a little ext3 partition on the USB key to store the interesting log files which are generally lost in case of system crash or freeze ( unmounting swap partition on a machine with not enough memory often leads to system freeze ).

   In what follows, I suppose that the USB key is recognized as device 'sda'. With gparted, create a swap partition sda1 of at least 100 MB, and an ext3 partiton sda2 of about 10 MB. Then, perform the following actions in a terminal :
1 sudo su
   # to feel quiet in following actions
2 swapon /dev/sda1
3 mkdir -p /media/sda2
4 mount /dev/sda2 /media/sda2 -t ext3 -o defaults
5 cd /media/sda2
6 touch syslog
7 touch partman
8 cd /var/log
9 ln -s /media/sda2/partman
10 mkdir -p installer
11 cd installer
12 ln -s /media/sda2/syslog
13 cd /usr/lib/python2.4/site-packages/ubiquity
14 rm -f misc.pyc
15 rm -f misc.pyo
   # to force python interpreter to recompile misc.py file
16 mousepad misc.py &
17 In 'disable_swap', replace line

        if swap.startswith('/dev'):

   by the three following lines

        if swap.startswith('/dev/sda'):
            pass
        elif swap.startswith('/dev'):

   then save the file and exit mousepad.

18 Launch the installer

Andrew Yeomans (ayeomans) wrote :

I've just confirmed this bug is still true with Feisty Herd 5 Xubuntu desktop CD on a 128MB system (which includes 2MB shared graphics ram).

The CD will very slowly boot to an X desktop with the "Install" icon and the CD icon, but no panels. The Installer will start, but hangs on the second page.

It's a shame the desktop CD can't be used on a 128Mb system even as a demo/repair CD.

Jani Monoses (jani) wrote :

I've lately found out that edgy and current feisty have a regression from dapper and do not enable existing swap partiotions at boot. That should help in this case (and makes Ubuntu/GNOME uninstallable via ubiquity with 256M). The bugfix will hopefully be committed soon.
However if you do not have swap there's no helping it AFAIK :(

Kari Aliranta (kpaliran) wrote :

It seems to me that even 192 mb ram may not be enough - see a bug report I wrote before noticing this one:

https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/105971

Changed in xubuntu-meta:
importance: Undecided → Medium
arrrghhh (arrrghhh) wrote :

i can confirm as well - to some extent.

my work laptop started with 128mb of ram, with 2mb to video. i just used the alternate text-based installer no problem. every attempt to boot a live disc GUI failed. so after it was installed, everything ran so SLOW! what's depressing is the copy of XP actually runs fine. i figured xubuntu would run better than XP, but i was wrong. at any rate, i stole some ram from my old work laptop and managed to get 51`2mb in it. still isn't as snappy as XP, which is very disappointing, and probably the main thing ubuntu needs to work on in general is snappiness of the GUIs!

can't beat the stability tho... which is why i don't use XP!

Changed in xubuntu-meta:
assignee: xubuntu-team → nobody
Tomi Urankar (tomi0) wrote :

ARRRGHHHH
I have the same problem. I thought XUBUNTU would work normal with 128MB RAM as is stated on many pages but that is just not true. It works much slower than XP does.

I have created a new BUG report just for this BUG here:
https://bugs.launchpad.net/ubuntu/+bug/161962

Please report your problems there

Documentation has been updated to note that 192mb of ram is required to install Xubuntu using the Xubuntu Desktop CD. Hopefully I'll have time in Intrepid (the next version after the upcoming Hardy release) to look at ways to reduce memory consumption in the Xubuntu desktop.

Changed in xubuntu-meta:
importance: Medium → Wishlist
status: Confirmed → Triaged

Does xubuntu intrepid make use of the new compcache functionality? Or does this happen automatically? This could probably save ram.

It should be using the new compcache functionality, yes. It would be nice if someone could test and see how the desktop cd's ram requirements have changed and if 128mb is enough to do an install again.

Changed in xubuntu-meta (Baltix):
status: New → Invalid
Charlie Kravetz (charlie-tca) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. However, I am closing it because the bug has been fixed in the latest development version of Ubuntu - the Jaunty Jackalope. It won't be fixed in previous versions of Ubuntu because the package doesn't fit the requirements for backporting. See https://help.ubuntu.com/community/UbuntuBackports for more information.

I am able to run the Xubuntu jaunty-desktop-i386.iso cd dated 2009-04-11 on my P2, 400MHz cpu with 128MB ram. This is a compaq with a Intel 440LQ motherboard. Running the desktop, it is very slow, but in terminal using "free -m" I got Total 118, Used 116, Free 2

I was able to install from the cd menu, not from the desktop. I can use the desktop install with 192MB ram.

Changed in xubuntu-meta (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers