libfuse2 no longer included in jammy, required for AppImages

Bug #1965636 reported by Sean Davis
42
This bug affects 8 people
Affects Status Importance Assigned to Milestone
kubuntu-meta (Ubuntu)
Fix Released
Undecided
Unassigned
Jammy
Fix Released
Undecided
Unassigned
lubuntu-meta (Ubuntu)
Confirmed
Undecided
Unassigned
Jammy
Confirmed
Undecided
Unassigned
ubuntu-budgie-meta (Ubuntu)
Fix Released
Undecided
Unassigned
Jammy
Fix Released
Undecided
Unassigned
ubuntu-meta (Ubuntu)
Won't Fix
Undecided
Unassigned
Jammy
Won't Fix
Undecided
Unassigned
ubuntukylin-meta (Ubuntu)
Confirmed
Undecided
Unassigned
Jammy
Confirmed
Undecided
Unassigned
ubuntustudio-meta (Ubuntu)
Fix Released
Undecided
Unassigned
Jammy
Fix Released
Undecided
Unassigned
xubuntu-meta (Ubuntu)
Fix Released
Undecided
Unassigned
Jammy
Fix Released
Undecided
Unassigned

Bug Description

Attempting to run an AppImage in Xubuntu 22.04 displays the following error:

$ ./cryptomator-1.6.5-x86_64.AppImage
dlopen(): error loading libfuse.so.2

AppImages require FUSE to run.
You might still be able to extract the contents of this AppImage
if you run it with the --appimage-extract option.
See https://github.com/AppImage/AppImageKit/wiki/FUSE
for more information

---

Simply installing libfuse2 resolves this issue. Some flavors seem to still include it. I noticed that today's Ubuntu MATE daily still does. Ubuntu and Xubuntu do not.

Ubuntu: https://cdimage.ubuntu.com/daily-live/current/jammy-desktop-arm64.manifest
Xubuntu: https://cdimage.ubuntu.com/xubuntu/daily-live/current/jammy-desktop-amd64.manifest
Ubuntu MATE: https://cdimage.ubuntu.com/ubuntu-mate/daily-live/current/jammy-desktop-amd64.manifest

Tags: jammy
Changed in ubuntustudio-meta (Ubuntu):
status: New → Fix Committed
Sean Davis (bluesabre)
Changed in xubuntu-meta (Ubuntu):
status: New → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xubuntu-meta - 2.240

---------------
xubuntu-meta (2.240) jammy; urgency=medium

  * Refreshed dependencies
  * Added language-selector-common to core, desktop
  * Added libfuse2 to core-recommends, desktop-recommends (LP: #1965636)

 -- Sean Davis <email address hidden> Sat, 19 Mar 2022 15:39:38 -0400

Changed in xubuntu-meta (Ubuntu):
status: Fix Committed → Fix Released
Changed in ubuntustudio-meta (Ubuntu):
status: Fix Committed → Fix Released
Rik Mills (rikmills)
Changed in kubuntu-meta (Ubuntu):
status: New → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kubuntu-meta - 1.418

---------------
kubuntu-meta (1.418) jammy; urgency=medium

  * Refreshed dependencies
  * Added libfuse2 to desktop-recommends (LP: #1965636)

 -- Rik Mills <email address hidden> Mon, 21 Mar 2022 07:24:00 +0000

Changed in kubuntu-meta (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
probono (probono) wrote :

Apparently this affects most if not all flavors of Ubuntu. Especially the default flavor.

The AppImage format for distributing applications is centered around the idea that a user can boot the Ubuntu Live ISO, download an application in AppImage format, make it executable, and run it without having to install anything.

Not having libfuse2 and fusermount on the Live ISO breaks this for all existing AppImages out there.

AppImage tooling (the tools application authors use to produce AppImages of their software) will have to be updated by the AppImage project, but even once it is, it will take considerable time until all application authors release updated AppImages of their software.

Hence, asking for a defined grace period until fuse2 gets removed from the Ubuntu Live ISO.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lubuntu-meta (Ubuntu):
status: New → Confirmed
Changed in ubuntu-budgie-meta (Ubuntu):
status: New → Confirmed
Changed in ubuntu-meta (Ubuntu):
status: New → Confirmed
Changed in ubuntukylin-meta (Ubuntu):
status: New → Confirmed
Changed in ubuntu-budgie-meta (Ubuntu):
status: Confirmed → Fix Released
Norbert (nrbrtx)
tags: added: jammy
Revision history for this message
Steve Langasek (vorlon) wrote :

fuse has been demoted from Ubuntu main in favor of fuse3; it would not be appropriate to re-promote it to main and expand the security surface of a default Ubuntu install (fuse is a very security-relevant facility), and Ubuntu images build only from main. So this is a wontfix for the Ubuntu desktop, libfuse2 is not going to be brought back into the default install and users who want to use libfuse2-dependent AppImages will need to install this library themselves beforehand.

Our community flavors are free to make their own decisions about whether to bundle libfuse2 by default, as several of them did before the release.

Changed in ubuntu-meta (Ubuntu):
status: Confirmed → Won't Fix
Changed in ubuntu-meta (Ubuntu Jammy):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers