[users-admin] Unlock -> "Could not authenticate. An unexpected error has occurred."

Bug #194496 reported by Anders on 2008-02-22
36
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-system-tools (Ubuntu)
Undecided
Unassigned
xubuntu-meta (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gnome-system-tools

Similarly to the behaviour reported in Bug #183673, I can't unlock my users settings / add new users etc. Running a completely updated Hardy Alpha.

$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.04
DISTRIB_CODENAME=hardy
DISTRIB_DESCRIPTION="Ubuntu hardy (development branch)"

$ dpkg -l gnome-system-tools | cat
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-f/Unpacked/Failed-cfg/Half-inst/t-aWait/T-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-==========================================-====================================-================================================
ii gnome-system-tools 2.21.90-0ubuntu1 Cross-platform configuration utilities for GNOME

$ dpkg -l policykit | cat
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-f/Unpacked/Failed-cfg/Half-inst/t-aWait/T-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-==========================================-====================================-=============================================================
ii policykit 0.7-2ubuntu4 framework for managing administrative policies and privileges

Pedro Villavicencio (pedro) wrote :

Thanks for your report, can you test the same with a new user created on your system? thanks.

Changed in gnome-system-tools:
status: New → Incomplete
Basilio Kublik (sourcercito) wrote :

Hi there
is this reproducible at all?

Thanks

Changed in gnome-system-tools:
importance: Undecided → Low
Jim Campbell (jwcampbell) wrote :

This appears to be very similar to Bug #185589 (at least the title and initial portions of the report).

For the record, I have experienced this same issue using Xubuntu hardy. Selecting Applications > System > Users and Groups, and then Selecting "Unlock" produces the "cannot unlock user&groups: "could not authenticate. An unexpected error has occurred"" message.

$ dpkg -l gnome-system-tools | cat
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-f/Unpacked/Failed-cfg/Half-inst/t-aWait/T-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-==========================================-=============================-================================================
ii gnome-system-tools 2.21.92-0ubuntu1 Cross-platform configuration utilities for GNOME

$ dpkg -l policykit | cat
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-f/Unpacked/Failed-cfg/Half-inst/t-aWait/T-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-==========================================-=============================-=============================================================
ii policykit 0.7-2ubuntu4 framework for managing administrative policies and privileges

Jim Campbell (jwcampbell) wrote :

I have also experienced this error on my thinkpad t60 using xubuntu hardy. details provided below.

Changed in gnome-system-tools:
status: Incomplete → Confirmed
Jim Campbell (jwcampbell) wrote :

Ok, after doing further research, policykit-gnome was not installed on my xubuntu system. Installing policykit-gnome fixed this problem.

I will report back up through to the Xubuntu team to make sure that policykit-gnome is included in the xubuntu seeds, as it does not currently appear to be included.

changing assignment of package to xubuntu-desktop for now.

Jim Campbell (jwcampbell) wrote :

Lionel, is policykit-gnome included as part of Xubuntu-desktop? It doesn't appear to be, and without it, items like users & groups, network, time & date, system services, etc (the primary gnome-utils under applications > system) do not work.

installing policykit-gnome fixes this problem.

Changed in policykit-gnome:
assignee: nobody → mrpouit
Jim Campbell (jwcampbell) wrote :

Downloaded most recent ISO of xubuntu live cd (03/03/08) and this problem is fixed on the default installation. Thanks. Sorry for any confusion on this report, it just took some additional research to verify the current status.

Changed in xubuntu-meta:
status: Confirmed → Fix Released
nidal22 (nidal22) wrote :

Hello,
I tried to add Synpatic Package Manager from the Main menu after it disapeared from ( system-> Adminstration), but when I check Synpatic Package Manager, it uncheck by itself, same for other item in (Main Menu->Administration)

My computer crashed yesterday after using hardware test, after booting I had a problem with $HOME/.dmrc and fixed it. This morring, neither sudo or gksu are working any more.

I ckecked sudoers file, I get this error

nidal@dell-640m:~$ cat /etc/sudoers
cat: /etc/sudoers: Permission denied

I used revovery mode ( visudo) to check it, I did not find my user name in the list, I added myself and I checked the file permission: 440, but still sudo is not working.

Thanks, Nidal

PS: I have an open thread http://ubuntuforums.org/showthread.php?t=736805

Jean-Noel Rey (jnrey) wrote :

It would be nice if I could only install policykit-gnome. When I sudo apt-get I get E: invalid operation. So I am stuck with the unlock thing.

Jean-Noel Rey (jnrey) wrote :

Found a way to reinstall policykit-gnome on Hardy Beta. Unfortunately it didn't help. Stuck.

Changed in xubuntu-meta:
assignee: mrpouit → nobody
Daniel Morales (danielmorales) wrote :

This bug seems works fine to me now. (Installing from Xubuntu daily build)

nrp (nelsonricciardi) wrote :

I'm having the same problem. Installed 8.04 today. Clean install. Previous version was 7.10.

That was 5 hours ago. Now I can't start anything as root and I'm stuck in a system withou an admin. I have two users, both without admin rights.

How can I solve this problem? I surely don't want to install everything from scratch again.

Thanks for any hint.

Feistybird (bryanjen-tw) wrote :

Same problem here, The users-admin's 'Unlock' button is grayed out

It's a newly installed 8.04, last package update was 10 hrs ago.

Reinstalling the policykit-gnome doesn't make any difference...

Feistybird (bryanjen-tw) wrote :

Further more, I can't use time-admin neither, The 'Unlock' button also grayed out.
I've tried add my user's name to the polkituser group, but still can't get it right.

Feistybird (bryanjen-tw) wrote :

One more thing, when I'm installing 8.04, I've left my previous 7.10's /home partition without re-format, and I created exactly the same user's account name as I've used in Gusty, I wonder could this problem caused by the previous Gusty's config file under /home/user's folder?

My friend's clean installed Hardy (new /home/user directory) doesn't have such problem.

This problem seems to be fixed for me in the released version of Hardy.

Pedro Villavicencio (pedro) wrote :

ok, thanks for the feedback.

Changed in gnome-system-tools:
status: New → Fix Released
Feistybird (bryanjen-tw) wrote :

I think I've my problem solved.

The 'Unlock' button worked if I just type 'users-admin' in the terminal, (without sudo or gksu in front of the command)

Then I checked my 'users-admin' launcher setting in the alacarte menu editor, the command was 'gksu users-admin', so I simply delete the 'gksu', and it worked properly without 'gksu'

I guess it could be caused by my previous installation of 8.04 Release Candidate version, it left the old launcher setting in my home directory, so even I made a clean install of the formal 8.04 release later, the menu still uses the old setting (gksu users-admin) of my home directory.

Magnus (koma-lysator) wrote :

I've got the same problem on an system upgraded from 7.10 to release version of 8.04.

I cannot unlock the network settings, I get the "could not authenticate. An unexpected error has occurred".

I also cannot enter my WPA passphrase in the network manager. It just keeps asking for the passphrase over and over again.

Maybe these things are related?

NoOp (glgxg) wrote :

Clean install of Ubuntu 8.04 - fully updated as of May 16, 2008. I can reproduce the problem by the following:

Boot & reset the bios clock to 00:00:00 12/31/1987, bring up Ubuntu without a
network connection, Ubuntu login comes up with the bios time setting (31 Dec
1987), as expected. Enter username & password & Heron splash screen comes up. However, before it completes the desktop, it provides a popup telling me:

====
The computer clock appears to be wrong
The session might encounter issues if the computer clock
is not properly configured. Please consider adjusting it.
Current date is 12/31/1987
 Ignore Adjust the Clock
====

But then of course, I attempt to authenticate in order to adjust the clock and receive "Could not authenticate" , so I can't adjust it from the popup & can't get past the splash screen. Drop to a terminal (C-A-F1), connect to the network, reinit networking (sudo /etc/init.d/networking restart), Ubuntu goes out and gets the correct time. Switch back to gdm (C-A-F7) and the Ubuntu desktop completes without any further intervention from me.

I also have difficulties on this laptop authenticating using update-manager. The update manager will hang at "Update" and does not make it to the authentication screen. I end up having to kill UA and updating from the terminal (sudo apt-get update/upgrade). That problem also sometimes occurs on my other laptop & I wonder if it is memory related; both only have 128MB of RAM.

Reproducible: Always
policykit-gnome is installed - version 0.7-2ubuntu1
gnome-system-tools is installed - version 2.22.0-ubuntu9
Kernel - 2.6.24-16-generic

Let me know if I can provide any additional information from the logs to help.

Jean-Noel Rey (jnrey) wrote :

Have finally managed to solve that for myself.

Have you checked /etc/hosts. With hardy, the initial entry was something like:

127.0.0.1 localhost
127.0.1.1 aaa.bbb.com

when it should be

127.0.0.1 localhost
127.0.1.1 aaa.bbb.com <name of machine, e.g. ubuntu>

On 05/17/2008 12:14 AM, Jean-Noel Rey wrote:
> Have finally managed to solve that for myself.
>
> Have you checked /etc/hosts. With hardy, the initial entry was something
> like:
>
> 127.0.0.1 localhost
> 127.0.1.1 aaa.bbb.com
>
> when it should be
>
> 127.0.0.1 localhost
> 127.0.1.1 aaa.bbb.com <name of machine, e.g. ubuntu>
>

Thanks for the suggestion, but that was the first thing that I changed
on all my hardy machines. And actually I've found that:

127.0.0.1 localhost <machinename>
127.0.1.1 <machinename>

works well.

Jean-Noel Rey (jnrey) wrote :

Thank you for this NoOp, so this hosts config works as well.

Did it solve this Bug ?

NoOp (glgxg) wrote :

On 05/17/2008 11:21 AM, Jean-Noel Rey wrote:
> Thank you for this NoOp, so this hosts config works as well.
>
> Did it solve this Bug ?
>

Yes. Modifying the hosts file was necessary on all my hardy systems
(either upgraded or fresh install) due to failing to find localhost. So
it may resolve _this_ bug for others.

However, it does not resolve the issue with not being able to
authenticate, in the repeatable case I mentioned (fails to authenticate
when attempting to set the clock).

Apologies for mixing bugs, but as an added note; I've found another bug
that actually matched the symptoms I am seeing with update-manager which
may, may not be related:
https://bugs.launchpad.net/ubuntu/+source/gksu/+bug/187982
[update-manager fails to bring up the password prompt for root privileges]
In that case, the workaround provided in:
https://bugs.launchpad.net/ubuntu/+source/gksu/+bug/187982/comments/19
works. And it appears that there are multiple authentication issues.

Russell (russellp) wrote :

Exactly the same problem here. Fresh 8.04 Ubuntu install - fully updated as of today, 02 June. The only actions taken were:

1. Full update via Synaptic
2. Set static IP via Network Manager
3. Add machine to Active Directory domain using Likewise Open
4. Reboot

Attempting to unlock Network Manager (or Users) results in the error message and a full desktop lock - only crtl-alt-bkspc works.

Have tried reinstalling policykit - same problem.

Have checked /etc/hosts and the default did not have "machinename" in the 127.0.0.1 line. Added machine name and retested. Failure still occurred.

Russell (russellp) wrote :

Ran network-admin from the command line. Error output was:

CRITICAL **: did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

Error output took appx. 16 seconds to appear.

Russell (russellp) wrote :

Rinsed and repeated steps on a clean machine to verify - same problem. Likewise Open must change something that prevents local authentication.

Russell (russellp) wrote :

Used Likewise Open from their site, rather the the Ubuntu Hardy repository, and the bug is not present. Version installed was 4.1.0_2921 (rather than 4.0.5).

Sorry for any inconvenience.

tk (thomas9-gmx) wrote :

I've got the same problem (ubuntu 8.04) when adding user "admin" (which of course should not be able, but it is)

sheeparegreat (sheeparegreat) wrote :

I had the same problem after I installed Hardy via debootstrap.

I solved the problem by reinstalling the policy package and purging the old config:

# aptitude purge policykit
# apt-get install ubuntu-desktop

HTH,

Simon

buntunub (mckisick) wrote :

I had this same problem and found the issue to be with PolicyKit group settings. Common thread here seems to be -

1. Ensure /etc/hosts file is correct
2. Ensure appropriate users are added to the "polkituser" group in /etc/group

Brian Fallik (bfallik) wrote :

I have the same problem and am dumbfounded that I've now rendered a Dell pre-installed with Hardy unusable via a few seemingly straightforward commands, and without any hint of a warning.

After creating an 'admin' account and adding it into the Administrators role (as well as manually adding it to polkituser group), the admin user is unable to unlock any services with the identical symptom as comment 26 in this bug report. I've tried both the suggestions in comment 30 and 31, with neither working. 'admin' was the 2nd account I created since I wanted to recreate my original user.

Unfortunately I deleted the original account, naively assuming Ubuntu would just work and the new account would allow me to setup the machine. Now I'm stuck - I can't change any settings graphically because none of the policykit permissions can be unlocked, and I'm hesitant to start changing /etc files because I know how much fun it can be battling gui admin components while hand editing their underlying config files.

Please help. This is unbelievably frustrating.

Ademar Arvati Filho (arvati) wrote :

I have the same problem and i discovered that ubuntu-desktop was not apearing to be installed on synaptic. I installed and the problem is gone.

flick (flick-flickharrison) wrote :

Gah! I followed Simon Lewis's intructions - it purged policykit AND network manager along with it, which means NO NETWORK i.e. NO network installs. I.e. NM is dead and I can't re=install it.

Having a bugger of a time getting a USB key to mount with a new NM package (xubuntu bug), and then I find the package is missing the MAKE compiler. Crikey!

So now I'm kinda stuck... I have an XO without ethernet and a now-missing NM...

flick (flick-flickharrison) wrote :

So after discovering I had no compiler on my system and not wanting to learn how to install one without a compiler or network access (!!) I went another route - search the interwebs to find out how to get on the web WITHOUT network manager -

1. Startup Ubuntu - my desktop is dead so I have to hit alt-f1 on boot to get a terminal window.
2. turn off wpa on my home network to avoid dizziness of config options
3. iwconfig eth0 essid mynetworkname
4. dhclient

and THEN re-install the desktop after it confirmed a network connection. Yeesh!

Now we'll see if this actually solves my permissions problems...

flick (flick-flickharrison) wrote :

No dice - installed xubuntu desltop through apititude. Still no admin permissions.

Andrew Pam (xanni) wrote :

I have the same problem. After upgrading from Dapper to Hardy, I can't use any admin tools even after checking /etc/hosts and adding my username to the "admin" and "polkituser" groups in /etc/group and /etc/gshadow. I always get "Could not authenticate. An unexpected error has occurred." when using the graphical tools, and the following appears on the console:

** (users-admin:9736): CRITICAL **: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

Andrew Pam (xanni) wrote :

Note: All hardy updates are installed, so if this is "Fix released" it certainly hasn't helped me.

leon (daniel-leonhardt) wrote :

Same problem - can not unlock admin functions such as users/groups, date & time etc. Error - "could not authenticate. An unexpected error has occurred".

Also, strangely both Add / Remove & Synaptic Package Manager apps disappeared from my application and system menus.

Cause - created a system account named "admin" with root like privelidges

*** Resloution ***
 delete "admin" account. Seeing as I couldn't unlock the user admin tool GUI, had to remove it from the command shell. Command = deluser admin

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers