Add a music player

Bug #1934926 reported by Yousuf 'Jay' Philips
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xubuntu-meta (Ubuntu)
Undecided
Unassigned

Bug Description

Xubuntu previously shipped a music player until 2016, but still needs one. Here are the two contenders.

1. rhythmbox (8,473kb): It ships in different ubuntu flavors and xfce distros.
2. pragha (2,293kb): Lighter than rhythmbox and ships with openSUSE xfce.

In the mailing list, both of them received equal amount of praise from subscribers, so the xfce team has to make a final decision.

ML
https://lists.ubuntu.com/archives/xubuntu-devel/2021-May/012062.html

Revision history for this message
Stephen Michael Kellat (skellat) wrote (last edit ):

The opportunity was taken to review pragha on my test Impish Indri box on Wednesday. I downloaded some test music files from the 78 RPM record conversion collection on the Internet Archive (https://archive.org/details/78rpm) and selected some streaming radio sources from the front page selection on PublicRadioFan.com (http://publicradiofan.com/). The software was installed from the repository and utilized without customization.

The downloaded music files did play correctly. Playing streaming radio from any source was a bit complicated initially as I couldn't figure out what to select to open a stream. The UI is focused on building a playlist from a library and streams do not fit that paradigm well.

The software is considered minimalist. The problem with pragha is that it is not sufficiently flexible for general use. It feels stuck on a paradigm of maintaining a single playlist. For some users that may be okay but we have a broader audience to serve especially when streaming radio/streaming audio is still a thing.

It appears that rhythmbox can handle the job although it has its own idiosyncracies. For example it puts streaming radio under an "FM Radio" plugin. If I wanted to listen to the rolling news feed stream from WKSU-FM (http://stream.wksu.org/wksu4.128.mp3.m3u) I would have to have that plugin enabled first then add the feed to its roster before I could listen to it.

I would recommend rhythmbox as the most stable and user-friendly option at this point.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xubuntu-meta (Ubuntu):
status: New → Confirmed
Revision history for this message
Michael Lueck (mlueck) wrote :

+1 vote for rhythmbox to be added to Xubuntu

Revision history for this message
Sean Davis (bluesabre) wrote :
Revision history for this message
Максим Терентьев (maxitso) wrote :

+1 pragha

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xubuntu-meta - 2.238

---------------
xubuntu-meta (2.238) impish; urgency=medium

  * Refreshed dependencies
  * Added baobab to desktop-recommends (LP: #1934932)
  * Added gnome-disk-utility to desktop-recommends (LP: #1934932)
  * Added rhythmbox to desktop-recommends (LP: #1934926)
  * Added xfce4-clipman-plugin to desktop-recommends (LP: #1934925)
  * Removed pidgin from desktop-recommends (LP: #1936417)
  * Removed pidgin-otr from desktop-recommends

 -- Sean Davis <email address hidden> Wed, 21 Jul 2021 07:13:01 -0400

Changed in xubuntu-meta (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers