Depend on gnome-software to prevent upgrade to snap-store-desktop

Bug #1922157 reported by Sean Davis
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xubuntu-meta (Ubuntu)
Undecided
Unassigned

Bug Description

In recent releases, GNOME Software receives an update and is upgraded to Snap Store. Snap Store doesn't support Debian packages, so this is a regression in functionality. Other flavors have reportedly remedied this by adding a dependency on GNOME Software to prevent it's removal/replacement.

Drew Howden (drewhowden)
Changed in xubuntu-meta (Ubuntu):
status: New → Opinion
Revision history for this message
Yousuf 'Jay' Philips (philipz85) wrote :

This was the text from telegram that David gave "oops @philipz ... I did ping in ubuntu flavors irc about this when I found the same thing in ubuntu budgie. Since you have gnome-software as a recommendation in your seeds, update manager will "upgrade" it to a snap. your seed needs to be adjusted to make gnome-software a dependency"

Revision history for this message
Sean Davis (bluesabre) wrote :

@philipz85, thanks. I found the related change:

https://launchpadlibrarian.net/474881551/ubuntu-budgie-meta_0.64_0.65.diff.gz

I'll work on landing a similar fix for Xubuntu.

Revision history for this message
fossfreedom (fossfreedom) wrote :

I am not sure why this is marked as opinion. I can confirm that discussing with various Canonical staff back in April last year, the mechanism used to uplift to the snap would be blocked if gnome-software was a dependency not a recommendation. We did this for 20.04 and works through upgrades to 20.10 and 21.04

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xubuntu-meta - 2.237

---------------
xubuntu-meta (2.237) hirsute; urgency=medium

  * Refreshed dependencies
  * Moved gnome-software to desktop (LP: #1922157)

 -- Sean Davis <email address hidden> Fri, 16 Apr 2021 07:25:06 -0400

Changed in xubuntu-meta (Ubuntu):
status: Opinion → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers