libreoffice-gnome should be installed by default on xubuntu

Bug #1689008 reported by Björn
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xubuntu-meta (Ubuntu)
Undecided
Unassigned

Bug Description

Hi,

the libreoffice-gnome package should be installed by default on every Xubuntu installation. If it's missing it's not possible to open Libreoffice documents from SMB sources (gvfs).

ProblemType: Bug
DistroRelease: Ubuntu 17.04
Package: libreoffice-gnome 1:5.3.1-0ubuntu2
ProcVersionSignature: Ubuntu 4.10.0-20.22-generic 4.10.8
Uname: Linux 4.10.0-20-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
ApportVersion: 2.20.4-0ubuntu4
Architecture: amd64
CurrentDesktop: XFCE
Date: Sun May 7 07:42:38 2017
InstallationDate: Installed on 2017-03-20 (47 days ago)
InstallationMedia: Xubuntu 16.10 "Yakkety Yak" - Release amd64 (20161012.2)
SourcePackage: libreoffice
UpgradeStatus: Upgraded to zesty on 2017-04-14 (22 days ago)

Revision history for this message
Björn (netaddict) wrote :
information type: Public → Public Security
Revision history for this message
Tyler Hicks (tyhicks) wrote : Bug is not a security issue

Thanks for taking the time to report this bug and helping to make Ubuntu better. We appreciate the difficulties you are facing, but this appears to be a "regular" (non-security) bug. I have unmarked it as a security issue since this bug does not show evidence of allowing attackers to cross privilege boundaries nor directly cause loss of data/privacy. Please feel free to report any other bugs you may find.

information type: Public Security → Public
Revision history for this message
Markus Baumann (mark.us) wrote : Re: package should be installed by default on xubuntu

I agree. Many use NAS or file servers today and this should be a basic functionality.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libreoffice (Ubuntu):
status: New → Confirmed
Changed in xubuntu-meta (Ubuntu):
status: New → Confirmed
Olivier Tilloy (osomon)
summary: - package should be installed by default on xubuntu
+ libreoffice-gnome should be installed by default on xubuntu
no longer affects: libreoffice (Ubuntu)
Revision history for this message
Sean Davis (bluesabre) wrote :

I just tested Xubuntu Bionic and found that SMB sources are available if they have already been mounted in the file manager. libreoffice-gtk is installed and libreoffice-gnome is not.

Revision history for this message
Sean Davis (bluesabre) wrote :

Correction. The files are browseable with libreoffice-gtk but cannot be opened. They can in fact be opened with libreoffice-gnome.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xubuntu-meta - 2.225

---------------
xubuntu-meta (2.225) bionic; urgency=medium

  * Refreshed dependencies
  * Added libreoffice-gnome to desktop-recommends [amd64 arm64 i386
    ppc64el s390x]
    - Enables editing files accessed with gvfs (LP: #1689008)
    - Pulls libreoffice-gtk3 which is graphically similar to
      libreoffice-gtk2 but better supported (LP: #1762569)
  * Removed libreoffice-gtk from desktop-recommends [amd64 arm64 i386
    ppc64el s390x]

 -- Sean Davis <email address hidden> Wed, 11 Apr 2018 21:40:15 -0400

Changed in xubuntu-meta (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Markus Baumann (mark.us) wrote :

Great, thanks for your effort

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers