Ubuntu

[SRU] Documentation does not match shipped system version (11.10 shipped with 12.04)

Reported by Stephen Michael Kellat on 2013-08-01
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Xubuntu Website
Undecided
Elizabeth Krumbach Joseph
xubuntu-docs (Ubuntu)
High
Pasi Lallinaho
Precise
High
Pasi Lallinaho

Bug Description

[Impact]

 * Inappropriate documentation was shipped from 11.10 with 12.04 as it was not updated

 * Preparatory to the 12.04.3 release updated offline documentation has been prepared to serve users

 * This follows from our documentation rejuvenation effort in 13.04 to bring documentation up to an appropriate level of quality.

[Test Case]

 * Open documentation, it should claim it is for 11.10 which is not the correct version of the operating system

[Regression Potential]

 * Risks are minimal except that users may have been relying on outdated documentation since release. This would remove that risk from users that has existed from the release of 12.04 and ensure that from the new point release forward proper documentation is available.

 * Any documentation relied upon by users showing tips or tricks will not carry over to the new documentation. As the old documentation related to a prior version of the operating system this is considered a minor disruption as documentation should in fact relate to the version at-hand.

[Other Info]

 * Documentation continues to be prepared in DocBook

 * Sponsored upload will be required in this instance as knome does not have upload rights though he has commiter rights. The branch will be linked after the bug is posted.

 * There will be a need eventually to broaden the number of commiters for Xubuntu documentation. That will need to be addressed at a later date.

 * The full fix is in the trunk of the precise branch. Previously there was no precise branch and no documentation for 12.04. We have remedied that in this case.

Pasi Lallinaho (knome) on 2013-08-01
Changed in xubuntu-docs (Ubuntu):
importance: Undecided → High
status: New → Fix Committed
milestone: none → ubuntu-12.04.3
Changed in xubuntu-docs (Ubuntu):
status: Fix Committed → New
description: updated
tags: added: sponsored-uploads
description: updated
Elizabeth Krumbach Joseph (lyz) wrote :

The documentation as been completed and I have built+uploaded them to http://docs.xubuntu.org/1204/

Changed in xubuntu-website:
assignee: nobody → Elizabeth Krumbach Joseph (lyz)
status: New → Fix Released
summary: - Documentation does not match shipped system version (11.10 shipped with
- 12.04)
+ [SRU] Documentation does not match shipped system version (11.10 shipped
+ with 12.04)
Changed in xubuntu-docs (Ubuntu):
status: New → Confirmed

Built a test version in ppa:skellat/tests as https://launchpad.net/~skellat/+archive/tests/+files/xubuntu-docs_12.04.0_all.deb

debdiff attached for consideration.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1207493

tags: added: iso-testing
Sebastien Bacher (seb128) wrote :

Thanks for the work, I've sponsored the change

Changed in xubuntu-docs (Ubuntu):
status: Confirmed → Fix Released
Changed in xubuntu-docs (Ubuntu Precise):
importance: Undecided → High
status: New → In Progress

Hello Stephen, or anyone else affected,

Accepted xubuntu-docs into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/xubuntu-docs/12.04.0 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in xubuntu-docs (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Jack Fromm (jjfrv8) wrote :

Installed the 12.04.0 package from -proposed today. It did replace the 11.10 documentation with the correct 12.04 version but it appears there are some missing pieces in the package. Two screenshots are attached which show the problems. According to one of the developers I consulted, Offline-docs-initial-sceen.png indicates that css might be missing. The lower image in Offline-docs-index-page-comparison.png seems to show that there is an image file missing.

Jack Fromm (jjfrv8) wrote :

I'm scratching my head trying to figure out what is missing from the successful build in my test PPA and the unsuccessful build in precise-proposed. My test PPA's build can be found here: https://launchpad.net/~skellat/+archive/tests/+sourcepub/3403385/+listing-archive-extra

tags: added: verification-failed
removed: verification-needed
Sebastien Bacher (seb128) wrote :

The debdiff on this bug (which was used for the sponsoring) seems to be buggy/different from what was uploaded to the ppa test

Sean Davis (smd-seandavis) wrote :

I am attaching a fresh debdiff, please let me know if you have any concerns.

Pasi Lallinaho (knome) wrote :

I can confirm that a package built from the new debdiff fixes all the issues.

Sebastien Bacher (seb128) wrote :

@Sean: thanks, I've bumped the version to 12.04.1 (can't reuse the same version that 12.04.0 which was already uploaded to precise-proposed) and sponsored the change

Colin Watson (cjwatson) wrote :

Hello Stephen, or anyone else affected,

Accepted xubuntu-docs into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/xubuntu-docs/12.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: removed: verification-failed
tags: added: verification-needed
Pasi Lallinaho (knome) wrote :

Attaching the .dsc and .tar.gz files to get the binary image files updated as well.

Pasi Lallinaho (knome) wrote :
Sebastien Bacher (seb128) wrote :

reuploaded as 12.04.2

Colin Watson (cjwatson) wrote :

Hello Stephen, or anyone else affected,

Accepted xubuntu-docs into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/xubuntu-docs/12.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Pasi Lallinaho (knome) on 2014-02-05
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xubuntu-docs - 12.04.2

---------------
xubuntu-docs (12.04.2) precise; urgency=low

  [ Pasi Lallinaho]
  * Backport the looks from 12.10+ documentation.

  [ Jack Fromm ]
  * Update application menu paths to reflect their state in 12.04
  * Update application names and GUI labels
  * Add or remove steps to instructions where applicable

  [ Stephen Michael Kellat ]
  * Prepare for Stable Release Update (Closes LP: #1207493)

  [ Sean Davis ]
  * Prepare packaging for SRU
 -- Sean Davis <email address hidden> Sat, 25 Jan 2014 07:02:36 -0500

Changed in xubuntu-docs (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for xubuntu-docs has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Pasi Lallinaho (knome) on 2014-03-11
Changed in xubuntu-docs (Ubuntu):
assignee: nobody → Pasi Lallinaho (knome)
Changed in xubuntu-docs (Ubuntu Precise):
assignee: nobody → Pasi Lallinaho (knome)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers