default browser has changed, but not for thunderbird (and prefers firefox?)

Bug #922264 reported by GophrenOli on 2012-01-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xubuntu-default-settings (Ubuntu)
Medium
Unassigned

Bug Description

I am using Xubuntu, Firefox had been the default browser.

Since using Chromium as my default browser (Firefox has not been uninstalled), Thunderbird still uses Firefox as the default browser.

How do I know what's my default browser? Chromium asked/told me.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: thunderbird 8.0+build1-0ubuntu0.11.10.1
ProcVersionSignature: Ubuntu 3.0.0-15.25-generic-pae 3.0.13
Uname: Linux 3.0.0-15-generic-pae i686
NonfreeKernelModules: fglrx
AddonCompatCheckDisabled: False
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.23-0ubuntu4
Architecture: i386
BuildID: 20111124200334
CRDA: Error: [Errno 2] Datei oder Verzeichnis nicht gefunden
Card0.Amixer.info:
 Card hw:0 'SB'/'HDA ATI SB at 0xfe024000 irq 16'
   Mixer name : 'Realtek ALC889A'
   Components : 'HDA:10ec0885,1458a002,00100101'
   Controls : 39
   Simple ctrls : 22
Card1.Amixer.info:
 Card hw:1 'U0x4710x308'/'USB Device 0x471:0x308 at usb-0000:00:12.0-1, full speed'
   Mixer name : 'USB Mixer'
   Components : 'USB0471:0308'
   Controls : 2
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'Mic',0
   Capabilities: cvolume cvolume-joined cswitch cswitch-joined penum
   Capture channels: Mono
   Limits: Capture 0 - 3
   Mono: Capture 0 [0%] [26.00dB] [on]
Card2.Amixer.info:
 Card hw:2 'Audiophile192'/'M Audio Audiophile192 at 0xcf00, irq 21'
   Mixer name : 'ICE1724 - multitrack'
   Components : ''
   Controls : 15
   Simple ctrls : 10
Card3.Amixer.info:
 Card hw:3 'HDMI'/'HDA ATI HDMI at 0xfdffc000 irq 19'
   Mixer name : 'ATI RS690/780 HDMI'
   Components : 'HDA:1002791a,00791a00,00100000'
   Controls : 4
   Simple ctrls : 1
Card3.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Channel: release
Date: Thu Jan 26 20:22:56 2012
DefaultProfilePlugins:
 Shockwave Flash - Lib=libflashplayer.so, Location=/usr/lib/flashplugin-installer
 IcedTea-Web Plugin (using IcedTea-Web 1.1.3 (1.1.3-1ubuntu1.1)) - Lib=IcedTeaPlugin.so, Location=/usr/lib/jvm/java-6-openjdk/jre/lib/i386
ForcedLayersAccel: False
IfupdownConfig:
 auto lo
 iface lo inet loopback
InstallationMedia: Xubuntu 11.04 "Natty Narwhal" - Release i386 (20110427)
IpRoute:
 default via 192.168.91.191 dev eth0 proto static
 169.254.0.0/16 dev eth0 scope link metric 1000
 192.168.91.0/24 dev eth0 proto kernel scope link src 192.168.91.101 metric 1
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
Profile1Plugins:
 Shockwave Flash - Lib=libflashplayer.so, Location=/usr/lib/flashplugin-installer
 IcedTea-Web Plugin (using IcedTea-Web 1.1.3 (1.1.3-1ubuntu1.1)) - Lib=IcedTeaPlugin.so, Location=/usr/lib/jvm/java-6-openjdk/jre/lib/i386
Profile2Plugins:
 Shockwave Flash - Lib=libflashplayer.so, Location=/usr/lib/flashplugin-installer
 IcedTea-Web Plugin (using IcedTea-Web 1.1.3 (1.1.3-1ubuntu1.1)) - Lib=IcedTeaPlugin.so, Location=/usr/lib/jvm/java-6-openjdk/jre/lib/i386
Profile2Prefs:
 extensions.lastAppVersion - 8.0
 network.cookie.prefsMigrated - true
Profiles:
 Profile0 (Default) - LastVersion=8.0/20111124200334 (Running)
 Profile1 - LastVersion=8.0/20111124200334
 Profile2 - LastVersion=8.0/20111124200334
RfKill:

RunningIncompatibleAddons: False
SourcePackage: thunderbird
UpgradeStatus: Upgraded to oneiric on 2012-01-07 (18 days ago)
dmi.bios.date: 07/12/2010
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: FDf
dmi.board.name: GA-MA78G-DS3H
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrFDf:bd07/12/2010:svnGigabyteTechnologyCo.,Ltd.:pnGA-MA78G-DS3H:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnGA-MA78G-DS3H:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: GA-MA78G-DS3H
dmi.sys.vendor: Gigabyte Technology Co., Ltd.

GophrenOli (gophrenoli) wrote :
affects: ubuntu → thunderbird (Ubuntu)
Micah Gersten (micahg) wrote :

Thank you for reporting this to Ubuntu. Which browser is set as the default in the Preferred Applications pane in Xfce Settings Manager?

Changed in thunderbird (Ubuntu):
status: New → Incomplete
GophrenOli (gophrenoli) wrote :

Hi! The answer is: Chromium - see also attached picture.

Chris Coulson (chrisccoulson) wrote :

Please attach your ~/.local/share/applications/mimeapps.list if you have one

GophrenOli (gophrenoli) wrote :

here is the requested file

Chris Coulson (chrisccoulson) wrote :

This isn't a Thunderbird bug then :)

Thunderbird, like most applications, uses gio to look up protocol handlers. In 11.04, this lookup was delegated to gvfs which looked up the handlers from some keys in gconf. In 11.10, glib was changed so that gio uses the same mechanism that already exists for looking up mimetype handlers (eg, desktop files), using the x-scheme-handler types for protocol handlers.

It looks like your configuration tool hasn't been updated for the glib changes, else there would be a "x-scheme-handler/http=chromium-browser.desktop" in the "[Default Applications]" section of your mimeapps.list

tags: added: needs-reassignment
GophrenOli (gophrenoli) wrote :

alright, I have added that line manually and it works for me.

I am using Xubuntu 11.10.

So, this ticket is [SOLVED]?

GophrenOli (gophrenoli) wrote :

> This isn't a Thunderbird bug then :)
> [...]
> your configuration tool hasn't been updated for the glib changes

well, if this is no bug, what else is it while using the common Xubuntu update- and (synaptic-) installing-procedures?

Changed in thunderbird (Ubuntu):
status: Incomplete → Confirmed
affects: thunderbird (Ubuntu) → ubuntu
Micah Gersten (micahg) on 2012-02-22
tags: removed: needs-reassignment
affects: ubuntu → xfce4-settings (Ubuntu)
Changed in xfce4-settings (Ubuntu):
status: Confirmed → New
affects: xfce4-settings (Ubuntu) → exo (Ubuntu)
Lionel Le Folgoc (mrpouit) wrote :

This was removed upstream because some GNOME users complained:
* https://bugzilla.xfce.org/show_bug.cgi?id=7257
* http://git.xfce.org/xfce/exo/commit/?id=2e3744b9f9e64fbed18513027c0d000cbc8d046b and http://git.xfce.org/xfce/exo/commit/?id=41b00df8433e832f9cee43d596dc16bf8d56971c

I'd be very happy to reintroduce the feature, because I decided one minute ago that I don't care about GNOME/Unity, but I'm not sure other people will like that. ;-)

More seriously, I suppose we shouldn't reintroduce that, and instead let exo-preferred-applications set "x-scheme-handler/*" when you change a default app? Maybe this won't upset GNOME users...

Lionel Le Folgoc (mrpouit) wrote :

Even simpler, update /usr/share/xubuntu/applications/defaults.list with something like that:

--- /usr/share/xubuntu/applications/defaults.list 2011-07-02 15:26:41.000000000 +0200
+++ defaults.list 2012-02-22 12:18:50.553624035 +0100
@@ -136,7 +136,7 @@ image/x-portable-pixmap=ristretto.deskto
 image/x-psd=ristretto.desktop
 image/x-xbitmap=ristretto.desktop
 image/x-xpixmap=ristretto.desktop
-inode/directory=Thunar.desktop
+inode/directory=exo-file-manager.desktop
 misc/ultravox=parole.desktop
 multipart/x-zip=file-roller.desktop
 text/abiword=abiword.desktop
@@ -173,5 +173,11 @@ video/x-ms-asf=parole.desktop
 video/x-msvideo=parole.desktop
 video/x-ms-wmv=parole.desktop
 video/x-nsv=parole.desktop
-x-directory/normal=Thunar.desktop
+x-directory/normal=exo-file-manager.desktop
+x-scheme-handler/file=exo-file-manager.desktop
+x-scheme-handler/ftp=exo-file-manager.desktop
+x-scheme-handler/http=exo-web-browser.desktop
+x-scheme-handler/https=exo-web-browser.desktop
+x-scheme-handler/mailto=exo-mail-reader.desktop
+x-scheme-handler/trash=exo-file-manager.desktop
 zz-application/zz-winassoc-xls=gnumeric.desktop

It will only affect Xubuntu sessions, and seems to work as expected here.

(exo-preferred-applications should probably be rewritten to be able to get/set x-scheme-handler/* instead of the current custom format, but that's too big and needs some discussion upstream)

affects: exo (Ubuntu) → xubuntu-default-settings (Ubuntu)
Changed in xubuntu-default-settings (Ubuntu):
status: New → Confirmed
Changed in xubuntu-default-settings (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xubuntu-default-settings - 12.04.7

---------------
xubuntu-default-settings (12.04.7) precise; urgency=low

  * etc/xdg/xdg-xubuntu/Terminal/terminalrc: add a color theme matching
    Greybird colors. lp: #938779
  * usr/share/xubuntu/applications/defaults.list:
    - refreshed for precise.
    - add the exo wrappers as default scheme handlers, so that programs
      set through exo-preferred-applications are actually used by default.
      lp: #922264
  * debian/xubuntu-default-settings.gconf-defaults: hide nm-applet from the
    systray by default (required since yesterday's upload).
 -- Lionel Le Folgoc <email address hidden> Thu, 23 Feb 2012 20:17:38 +0100

Changed in xubuntu-default-settings (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.