[xubuntu] There is no screen title

Bug #840094 reported by Efren D. Montales Jr. on 2011-09-03
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xubuntu-default-settings (Ubuntu)
High
Lionel Le Folgoc
Oneiric
High
Unassigned
Precise
High
Lionel Le Folgoc
xubuntu-meta (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

Description: Ubuntu oneiric (development branch)
Release: 11.10

XUBUNTU 20110902 iso image

TEST CASES:

1. Boot the iso on virtualbox
2. Select language
3. Select install Xubuntu

Result:

Embedded language options not displayed, some image as well, fall back to classic view.

Screenshots attached.

description: updated
tags: added: iso-testing
tags: removed: iso-testing
tags: added: iso-testing
description: updated
summary: - [xubuntu] There is no screen title
+ [xubuntu] There is no screen tittle
summary: - [xubuntu] There is no screen tittle
+ [xubuntu] There is no screen title
Charlie Kravetz (charlie-tca) wrote :

Thank you for reporting this issue. This is a change since beta1 released.

Changed in ubiquity (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Charlie Kravetz (charlie-tca) wrote :

I have confirmed this issue in both hardware and VirtualBox. It was not present in Beta1 testing, thus is a regression in Ubiquity.

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

tags: added: regression-release
Mario Limonciello (superm1) wrote :

In beta1 testing, were you running in the only-ubiquity session or in the XFCE session? I suspect that this is only present in the only-ubiquity session with xubuntu. Mythbuntu encountered something similar and has a casper hook for this to set the theme.

Charlie Kravetz (charlie-tca) wrote :

It only happens when selecting "Install Xubuntu" from the menu after selecting the language. I tested using the icon on the live desktop, using the menu -> System -> Install, and using "install Xubuntu" from the cd menu.

tags: added: rls-mgr-o-tracking
Lionel Le Folgoc (mrpouit) wrote :

> Mythbuntu encountered something similar and has a casper hook for this to set the theme.

And where can we find it? Thanks.

Steve Langasek (vorlon) wrote :

mythbuntu's casper hooks appear to be in the mythbuntu-live-autostart package.

$ dpkg -c ~/ubuntu/pool/universe/m/mythbuntu-live-autostart/mythbuntu-live-autostart_0.57_all.deb |grep casper
drwxr-xr-x root/root 0 2011-08-29 07:43 ./usr/share/initramfs-tools/scripts/casper-bottom/
-rwxr-xr-x root/root 814 2011-02-25 06:33 ./usr/share/initramfs-tools/scripts/casper-bottom/46disable_services
-rwxr-xr-x root/root 1484 2010-09-12 15:25 ./usr/share/initramfs-tools/scripts/casper-bottom/47fixup_icons
-rwxr-xr-x root/root 588 2010-08-25 17:46 ./usr/share/initramfs-tools/scripts/casper-bottom/48maybe_ubiquity
$

affects: ubiquity (Ubuntu Oneiric) → xubuntu-meta (Ubuntu Oneiric)
Lionel Le Folgoc (mrpouit) wrote :

Thanks, I found them while searching but I wasn't sure they were the correct ones.

Changed in xubuntu-meta (Ubuntu Oneiric):
status: Confirmed → Triaged
Lionel Le Folgoc (mrpouit) wrote :

Hi ubuntu-release,

I'm not really sure how to fix that in the least intrusive way at this point: the hook needs some casper functions, so if I put it in xubuntu-default-settings, it will show an error (but harmless in fact) each time update-initramfs is run, because casper isn't present on a common xubuntu install.

So I've added a new binary package to xubuntu-default-settings, called xubuntu-live-settings. It will be present only in live builds -- I'll update the seeds (like mythbuntu-live-autostart). It only contains the hook (/usr/share/initramfs-tools/scripts/casper-bottom/48xubuntu_maybe_ubiquity) needed for only-ubiquity to fix the issue described here (Embedded language options not displayed, some image as well, fall back to classic view). This should work fine (this is what mythbuntu does as well), and I tested that there's no regression in the existing xubuntu-default-settings binary package.

So, because of the new binary package, the build would have to go through binary new. Is it fine like that?

Thanks.

affects: xubuntu-meta (Ubuntu Oneiric) → xubuntu-default-settings (Ubuntu Oneiric)
Changed in xubuntu-default-settings (Ubuntu Oneiric):
assignee: nobody → Lionel Le Folgoc (mrpouit)
status: Triaged → New
Lionel Le Folgoc (mrpouit) wrote :

Here's a candidate debdiff (changelog not written yet). Note that most of the changes are packaging changes because of the introduction of the new binary package: renamed debian/{preinst,postrm,postinst,gconf-defaults} to debian/xubuntu-default-settings.{preinst,postrm,postinst,gconf-defaults}.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xubuntu-default-settings (Ubuntu):
status: New → Confirmed
Changed in xubuntu-default-settings (Ubuntu Oneiric):
status: Confirmed → Won't Fix
assignee: Lionel Le Folgoc (mrpouit) → nobody
Changed in xubuntu-default-settings (Ubuntu Precise):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xubuntu-default-settings - 12.04.0

---------------
xubuntu-default-settings (12.04.0) precise; urgency=low

  * Fix broken theme in only-ubiquity mode (lp: #840094):
    - debian/control: add a new xubuntu-live-settings binary package.
    - debian/{gconf-defaults,post*,pre*}: renamed to
      debian/xubuntu-default-settings.*.
    - debian/*.install: added, now that we have several binary packages.
    - casper/48xubuntu_maybe_ubiquity: added, stolen from
      mythbuntu-live-autostart.
  * debian/xubuntu-default-settings.gconf-defaults: fix default command to
    browse a device with blueman. lp: #882621
  * etc/xdg/xdg-xubuntu/Terminal/terminalrc: reduce the default font size
    for xfce4-terminal. lp: #752886
  * etc/skel/.xscreensaver: added, set blank mode by default. lp: #799268
  * Call dh_installgsettings instead of manually shipping an override file.
 -- Lionel Le Folgoc <email address hidden> Sat, 19 Nov 2011 20:39:27 +0100

Changed in xubuntu-default-settings (Ubuntu Precise):
status: Fix Committed → Fix Released
Lionel Le Folgoc (mrpouit) wrote :

xubuntu-live-settings package needs to be added to the seeds (only for 'live', I guess).

Changed in xubuntu-meta (Ubuntu Oneiric):
status: New → Won't Fix
Changed in xubuntu-meta (Ubuntu Precise):
status: New → Triaged

The attachment "proposed changes" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Changed in xubuntu-meta (Ubuntu Precise):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers