LightDM has two Xubuntu Session options after upgrade to xubuntu-default-settings on 2011-08-01

Bug #819585 reported by Unit 193 on 2011-08-02
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Light Display Manager
Undecided
Unassigned
lightdm (Ubuntu)
Medium
Robert Ancell
xubuntu-default-settings (Ubuntu)
Medium
Xubuntu Developers

Bug Description

Install: Xubuntu Oneiric daily live entire disk - all updates done.

One of the Xubuntu sessions looks like Xfce Session or a modified version of Xfce Session. The bottom session is the one working for me.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: xubuntu-default-settings 11.10.2
ProcVersionSignature: Ubuntu 3.0.0-7.9-generic 3.0.0
Uname: Linux 3.0.0-7-generic i686
Architecture: i386
Date: Mon Aug 1 21:20:48 2011
InstallationMedia: Xubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110801)
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: xubuntu-default-settings
UpgradeStatus: No upgrade log present (probably fresh install)

Unit 193 (unit193) wrote :
Lionel Le Folgoc (mrpouit) wrote :

Thanks for your bug report. It's probably xubuntu.desktop and it's symlink default.desktop (lightdm is supposed to handle that correctly...). Could you provide the lightdm logs (somewhere in /var/log/lightdm I think) for each of the two session?

Charlie Kravetz (charlie-tca) wrote :

logs from first Xubuntu Session when live session is started using xubuntu oneiric-desktop-i386.iso dated 2011-08-02

Charlie Kravetz (charlie-tca) wrote :

logs from first Xubuntu Session when live session is started using xubuntu oneiric-desktop-i386.iso dated 2011-08-02

Charlie Kravetz (charlie-tca) wrote :

logs from first Xubuntu Session when live session is started using xubuntu oneiric-desktop-i386.iso dated 2011-08-02

Charlie Kravetz (charlie-tca) wrote :

logs from second Xubuntu Session when live session is started using xubuntu oneiric-desktop-i386.iso dated 2011-08-02. This session does use the greybird theme.

Charlie Kravetz (charlie-tca) wrote :

logs from second Xubuntu Session when live session is started using xubuntu oneiric-desktop-i386.iso dated 2011-08-02. This session does use the greybird theme.

Charlie Kravetz (charlie-tca) wrote :

logs from second Xubuntu Session when live session is started using xubuntu oneiric-desktop-i386.iso dated 2011-08-02. This session does use the greybird theme.

Charlie Kravetz (charlie-tca) wrote :

Thank you for reporting this issue. I have attached logs from both sessions when booting the Oneiric i386 live session.

Changed in xubuntu-default-settings (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
tags: added: iso-testing
Lionel Le Folgoc (mrpouit) wrote :

Thanks.

First session:
> [+207.64s] DEBUG: Launching process 2979: DISPLAY=:0 HOME=/home/ubuntu XDG_SESSION_COOKIE=b9aed8166d79d5930576ff4d0226ad3e-1312294437.696917-1933059891 GDMSESSION=default RUNNING_UNDER_GDM=yes LANG=en_US.UTF-8 USERNAME=ubuntu DESKTOP_SESSION=default USER=ubuntu SHELL=/bin/bash PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games /usr/sbin/lightdm-session 'startxfce4'

Second session:
> [+885.81s] DEBUG: Launching process 3417: DISPLAY=:0 HOME=/home/ubuntu XDG_SESSION_COOKIE=b9aed8166d79d5930576ff4d0226ad3e-1312295115.864867-1990294184 GDMSESSION=xubuntu RUNNING_UNDER_GDM=yes LANG=en_US.UTF-8 USERNAME=ubuntu DESKTOP_SESSION=xubuntu USER=ubuntu SHELL=/bin/bash PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games /usr/sbin/lightdm-session 'startxfce4'

So lightdm is doing something wrong imho: it's not "dereferencing" the default.desktop symlink to the real xubuntu.desktop, instead it's displaying two sessions as if they were distinct. Moreover, as it uses "default.desktop" as the key for the first session, all our xdg scripts are gonna break (because DESKTOP_SESSION=default instead of DESKTOP_SESSION=xubuntu will fill XDG_{CONFIG,DATA}_DIRS with incorrect paths).

(of course, I explicitly warned about this wrong behavior in another bug report when this feature was presented...)

Changed in lightdm (Ubuntu):
importance: Undecided → Medium
Changed in lightdm (Ubuntu):
status: New → Confirmed
Changed in lightdm (Ubuntu):
assignee: nobody → Robert Ancell (robert-ancell)
Changed in lightdm:
status: New → Confirmed
Changed in xubuntu-default-settings (Ubuntu):
assignee: nobody → Xubuntu Developers (xubuntu-dev)
Sebastien Bacher (seb128) wrote :

is that still an issue? Robert suggested it should be fixed in the current version I think (not sure though)

Charlie Kravetz (charlie-tca) wrote :

This is still an issue, in a fresh install using the Xubuntu oneiric-alternate-amd64.iso dated 2011-08-10. I am attaching a screenshot showing the two Xubuntu sessions clearly. apt-cache policy gives lightdm 0.9.3-0ubuntu1.

Charlie Kravetz (charlie-tca) wrote :

This bug is fixed when using the images dated 2011-08-14 for Xubuntu.

Changed in xubuntu-default-settings (Ubuntu):
status: Triaged → Fix Released
Charlie Kravetz (charlie-tca) wrote :

This is fixed with lightdm 0.9.3-0ubuntu3 when installing using the Xubuntu images dated 2011-08-14.

Changed in lightdm (Ubuntu):
status: Confirmed → Fix Released
Michael Terry (mterry) on 2011-08-18
Changed in lightdm:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers