When drag-droping application from menu to panel random application apperars

Bug #747137 reported by Nikolay Morozov on 2011-04-01
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linaro
Fix Released
Medium
Tom Gall
Xfce panel
Unknown
Unknown
xfce4-panel (Ubuntu)
Medium
Lionel Le Folgoc
xubuntu-default-settings (Ubuntu)
High
Lionel Le Folgoc

Bug Description

Binary package hint: xfce4-panel

Fresh install with updates. I customize the panels to look like gnome2 in ubuntu 10.10. After it wnat to drag-drop applications but many times instead of my application appears random from menu. I have already reported this bug with xubuntu alpha one. But when i reported that bug suddenly diappers. My bug was closed (fixed by update), but no update was made

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: xfce4-panel 4.8.2-1
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
Uname: Linux 2.6.38-7-generic i686
Architecture: i386
Date: Fri Apr 1 14:10:58 2011
EcryptfsInUse: Yes
InstallationMedia: Xubuntu 11.04 "Natty Narwhal" - Beta i386 (20110330)
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: xfce4-panel
UpgradeStatus: No upgrade log present (probably fresh install)

Nikolay Morozov (nmorozov) wrote :
Lionel Le Folgoc (mrpouit) wrote :

Hi,

Thanks for your bug report.
This is usual to close bug reports when nobody, including the original reporter is able to reproduce it.

Could you provide an example of what goes wrong?
* what menu entry you are dragging
* what menu entry is put in the panel instead
(if possible, a screenshot is even better).

Nikolay Morozov (nmorozov) wrote :

easy to reproduce in this install, draging firefox from menu/internet to top panelm instead of firefox appears 4 launcher with empty icon "mail reader" i open proper of it and take screenshot

Nikolay Morozov (nmorozov) wrote :

Edit pressed and another shot

Nikolay Morozov (nmorozov) wrote :

always mail reader instead of firefox
another try got "setting manager" instead of "terminal"

Nikolay Morozov (nmorozov) wrote :

but onece i got proper working first 3 launchers :)

Nikolay Morozov (nmorozov) wrote :

open props for 2 launchers

Nikolay Morozov (nmorozov) wrote :

try n 3
got "App finder" instead of terminal
got "ubuntu Software center" instead of terminal
got Abiword instead of firefox

Lionel Le Folgoc (mrpouit) wrote :

Haha, ok, thanks for the details, I think I'm starting to understand: "mail reader", "settings manager", "app finder", "ubuntu software center" and "abiword" are all in the default xubuntu panel config.

I'll try to reproduce that.

Lionel Le Folgoc (mrpouit) wrote :

Reproduced, this is indeed disturbing.

Changed in xfce4-panel (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Lionel Le Folgoc (mrpouit) wrote :

It turns out it is a default settings issue, we shouldn't ship our default config as xfce4-panel.xml but as default.xml.

affects: xfce4-panel (Ubuntu) → xubuntu-default-settings (Ubuntu)
Changed in xubuntu-default-settings (Ubuntu):
importance: Medium → High
status: Confirmed → Triaged
assignee: nobody → Lionel Le Folgoc (mrpouit)
Changed in xfce4-panel (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Lionel Le Folgoc (mrpouit)
Changed in xfce4-panel (Ubuntu):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfce4-panel - 4.8.2-1ubuntu1

---------------
xfce4-panel (4.8.2-1ubuntu1) natty; urgency=low

  * debian/patches:
    - xubuntu_support-multiple-vendor-default-configs.patch: search for the
      default.xml default config in XDG_CONFIG_DIRS as well, and do not
      display the chooser dialog in this case. lp: #747137
    - 0001-Tasklist-add-button-release-event-to-proxy-item-bug-.patch: taken
      from upstream git 'xfce-4.8' branch, fixes window switching with a
      drop down selector. lp: #743689
    - series: added.
 -- Lionel Le Folgoc <email address hidden> Fri, 01 Apr 2011 20:43:00 +0200

Changed in xfce4-panel (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xubuntu-default-settings - 11.04.17

---------------
xubuntu-default-settings (11.04.17) natty; urgency=low

  * Move etc/xdg/xdg-xubuntu/xfce4/xfconf/…/xfce4-panel.xml to
    etc/xdg/xdg-xubuntu/xfce4/panel/default.xml: this is the correct place
    to store the default settings, and avoid any weird issue when removing
    a panel. lp: #747137
  * Handle the move in the maintainer scripts as well.
 -- Lionel Le Folgoc <email address hidden> Fri, 01 Apr 2011 22:31:55 +0200

Changed in xubuntu-default-settings (Ubuntu):
status: Triaged → Fix Released
Lionel Le Folgoc (mrpouit) wrote :

Steve/Tom:
FYI, there was an issue in previous xubuntu-default-settings' versions.
You will need to move /etc/xdg/xdg-xubuntu/xfce4/xfconf/xfce-perchannel-xml/xfce4-panel.xml to /etc/xdg/xdg-xubuntu/xfce4/panel/default.xml for linaro-default-settings (I just did it for xubuntu-default-settings). Otherwise, bad things (cf. this bug report) will happen if the user removes one panel or one plugin.

Tom Gall (tom-gall) on 2011-04-05
Changed in linaro:
assignee: nobody → Tom Gall (tom-gall)
status: New → In Progress
Tom Gall (tom-gall) on 2011-04-05
Changed in linaro:
status: In Progress → Fix Committed
Tom Gall (tom-gall) on 2011-04-06
Changed in linaro:
importance: Undecided → Medium
Tom Gall (tom-gall) on 2011-04-06
Changed in linaro:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.