Thunar should open .crash files using "Report a problem"

Bug #610284 reported by Kangarooo Jānis on 2010-07-27
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xubuntu-default-settings (Ubuntu)
Wishlist
Lionel Le Folgoc

Bug Description

Binary package hint: thunar

Thunar Thinks i want crash open with mousepad
with double click it opens in mousepad
i have not made any changes to this so its default in 10.10 latest updates
not sure if it was like that since clean 10.10 alpha-2 installation
screenshot http://www.zimagez.com/zimage/ekrnkopija-20100727-033227.php

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: thunar 1.0.2-1ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-11.16-generic 2.6.35-rc5
Uname: Linux 2.6.35-11-generic i686
Architecture: i386
Date: Tue Jul 27 03:35:10 2010
EcryptfsInUse: Yes
InstallationMedia: Xubuntu 10.10 "Maverick Meerkat" - Alpha i386 (20100701)
ProcEnviron:
 LANG=lv_LV.utf8
 SHELL=/bin/bash
SourcePackage: thunar

WORKAROUND:
You can tell Thunar what to use as the default application to open any file. For these files, you must do the following as root user in Thunar:
1) Right-clcik the file you wish to open
2) Left-click "Properties"
3) Left-click the arrow at "Opens With: "
4) Left-click the application you want to use for these files
5) Left-click "Close"
6) Right-click the file you wish to open
7) Hover the mouse over "Open with"
8) Left-click the application you chose in step 4 above

The file will now automatically open with the application you chose.

Kangarooo Jānis (kangarooo) wrote :
description: updated
Charlie Kravetz (charlie-tca) wrote :

Thank you for reporting this issue. Thunar is suggesting using what it knows will be able to read a text file. Mousepad is the default text editor for Xubuntu. Please explain what you are attempting to do with the file.

Changed in thunar (Ubuntu):
status: New → Incomplete

crash files are in /var/crash if i dont report crash immidiatly when
they appear then later i open all unposted crash files.
so i wanted to open .crash file with programm that report crash files-
apport crash reporter and that should be default for crash files. it
was in previous versions and in ubuntu

 Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Xubuntu better!

Changed in thunar (Ubuntu):
importance: Undecided → Wishlist
status: Incomplete → Triaged
description: updated
description: updated
summary: - Thunar Thinks i want crash open with mousepad 10.10 default
+ Thunar should open .crash files using "Report a problem"

yes that needs to be set in as default and updates dont need to change that..

Lionel Le Folgoc (mrpouit) wrote :

Added to xubuntu-default-settings, will be part of the next upload.

affects: thunar (Ubuntu) → xubuntu-default-settings (Ubuntu)
Changed in xubuntu-default-settings (Ubuntu):
assignee: nobody → Lionel Le Folgoc (mrpouit)
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xubuntu-default-settings - 10.10.3

---------------
xubuntu-default-settings (10.10.3) maverick; urgency=low

  * Refreshed translations.
  * etc/xdg/xdg-xubuntu/applications/defaults.list: open crash files using
    apport by default instead of a text editor. lp: #610284
  * etc/xdg/xdg-xubuntu/xfce4/xfconf/xfce-perchannel-xml: switch to Bluebird.
  * debian/control: depends on xubuntu-artwork (>> 10.10.0).
 -- Lionel Le Folgoc <email address hidden> Wed, 25 Aug 2010 23:03:32 +0200

Changed in xubuntu-default-settings (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers