Xubuntu Jaunty "Applications -> Other" menu contains screensavers that are not useable/needed

Bug #360063 reported by Charlie Kravetz
4
Affects Status Importance Assigned to Milestone
xubuntu-default-settings (Ubuntu)
Medium
Lionel Le Folgoc

Bug Description

Binary package hint: xubuntu-default-settings

RELEASE: Jaunty development version
CD/DVD VARIANT: 32-bit xubuntu, 64-bit xubuntu
ISO BUILD: 2009-04-12
SYMPTOMS: Applications -> Settings -> Screensavers had been showing various screensaver selections. Those selections have moved to Applications -> Other. They still cannot be used, since they don't actually work.

Applications -> Settings -> Screensaver now allows the screensaver to be changed, as well as timer set.

CAUSE: Changes to xubuntu-default-settings to resolve bug 350962 might have caused the screensavers to move to the "Other" menu.

Revision history for this message
Mario Limonciello (superm1) wrote :

This is caused by the changes to xfce4-utils, however I'm convinced those are proper changes.

The changset added /etc/xdg to XDG_CONFIG_DIRS path. This means that the gnome screensavers desktop files are now in the path, so when gnome-screensaver goes and tries to use them, it should be able to.

Likely an exclude is needed for the Other menu for these screensavers.

Revision history for this message
Lionel Le Folgoc (mrpouit) wrote :

This is caused by the latest change of xubuntu-default-settings: the "Screensavers" submenu has been dropped, so these screensavers are no more included in any menu, thus ending up in "Other". I'll fix that.

Changed in xubuntu-default-settings (Ubuntu):
assignee: nobody → mrpouit
importance: Undecided → Medium
status: New → In Progress
Revision history for this message
Lionel Le Folgoc (mrpouit) wrote :

Uploaded, waiting for approval.

Changed in xubuntu-default-settings (Ubuntu):
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xubuntu-default-settings - 0.55

---------------
xubuntu-default-settings (0.55) jaunty; urgency=low

  * etc/xdg/xubuntu/menus/xfce-applications.menu: Exclude screensavers' desktop
    files from the "Other" menu (LP: #360063).

 -- Lionel Le Folgoc <email address hidden> Sun, 12 Apr 2009 19:23:24 +0200

Changed in xubuntu-default-settings (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers