thunar: mounts volumes with excessive permissions

Bug #193844 reported by Alex Mauer on 2008-02-20
258
Affects Status Importance Assigned to Milestone
exo (Ubuntu)
Wishlist
Unassigned
xubuntu-default-settings (Ubuntu)
Medium
Lionel Le Folgoc

Bug Description

Binary package hint: thunar

When Thunar mounts a vfat volume, it by default makes the files world-readable.

It should not, as some people keep encryption keys and similar private data on removable media.

Alex Mauer (hawke) wrote :

Accidentally assigned to wrong package.

Changed in cupsys:
status: New → Invalid
description: updated
Charlie Kravetz (charlie-tca) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately we can't fix it, because your description didn't include enough information. You may find it helpful to read "How to report bugs effectively" http://www.chiark.greenend.org.uk/~sgtatham/bugs.html. We'd be grateful if you would then provide a more complete description of the problem.

At a minimum, we need:
1. the behavior you expected, and
2. the behavior you actually encountered (in as much detail as possible).
3. what are the alternatives.

Thanks!

Changed in thunar:
assignee: nobody → charlie-tca
status: New → Incomplete
Alex Mauer (hawke) wrote :

Looks to me like I've already filled your requirements. I'll repeat them using your numbered list format.

1. I expect thunar to not mount vfat volumes with the files world-readable.
2. Thunar mounts vfat volumes with the files world-readable
3. Mount the vfat volumes with the files not world readable.

Thanks.

Alex Mauer (hawke) wrote :

Information was provided.

Changed in thunar:
status: Incomplete → New
Changed in thunar:
assignee: charlie-tca → nobody
Charlie Kravetz (charlie-tca) wrote :

Thank you for your suggestion. Since some will prefer having the volumes world-readable, perhaps some discussion on choice would be appropriate for this. More discussion should be done on an appropriate mailing list or forum. http://www.ubuntu.com/support/community/mailinglists might be a good start for determining which mailing list to use.

Changed in thunar:
importance: Undecided → Wishlist
status: New → Confirmed
affects: thunar (Ubuntu) → exo (Ubuntu)
Lionel Le Folgoc (mrpouit) wrote :

Now we can override default mount options in /etc/xdg/xubuntu/xfce4/mount.rc.

affects: cupsys (Ubuntu) → xubuntu-default-settings (Ubuntu)
Changed in xubuntu-default-settings (Ubuntu):
status: Invalid → Triaged
importance: Undecided → Wishlist
Changed in exo (Ubuntu):
status: Confirmed → Won't Fix
Changed in xubuntu-default-settings (Ubuntu):
assignee: nobody → Lionel Le Folgoc (mrpouit)
importance: Wishlist → Medium
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xubuntu-default-settings - 10.04.5

---------------
xubuntu-default-settings (10.04.5) lucid; urgency=low

  * etc/xdg/xdg-xubuntu/*.rc => etc/xdg/xdg-xubuntu/xfce4/*.rc,
    debian/{pre,post}inst: fixed a bug introduced in a previous upload
    (maybe 10.04.0), use correct config dir.
  * etc/xdg/xdg-xubuntu/xfce4/mount.rc: fix default permissions with
    vfat. lp: #193844
 -- Lionel Le Folgoc <email address hidden> Sat, 06 Mar 2010 11:43:57 +0100

Changed in xubuntu-default-settings (Ubuntu):
status: In Progress → Fix Released
Leszek Lesner (leszek-lesner) wrote :

This bug report is more or less nonsense.
Ubuntu,
Lubuntu,
Kubuntu mount all the vfat formatted USB Sticks with 755 so everyone can at least read files on that stick.
I don't think it makes sense here to derive from the Ubuntu standard.
Shipping the best defaults should be standard. This is definitely not.

Changed in xubuntu-default-settings (Ubuntu):
status: Fix Released → Invalid
Charlie Kravetz (charlie-tca) wrote :

Please don't change a bug report from fix-released to invalid. The issue was fixed by a developer, therefore, it is fix-released. Thanks.

Changed in xubuntu-default-settings (Ubuntu):
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public Security information  Edit
Everyone can see this security related information.

Other bug subscribers