Names are 1, 2, 3, 4, Workspace 5, ...

Bug #1829778 reported by scootergrisen on 2019-05-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xubuntu-default-settings (Ubuntu)
Undecided
Unassigned

Bug Description

https://git.launchpad.net/xubuntu-default-settings/tree/etc/xdg/xdg-xubuntu/xfce4/xfconf/xfce-perchannel-xml/xfwm4.xml#n52 says 1, 2, 3, 4.

It seems workspace 1-4 is called:
1
2
3
4

But then the workspavces after that is called:
Workspace 5
Workspace 6
Workspace 7
Workspace 8
...

So i suggest having it consistent like:
Workspace 1
Workspace 2
Workspace 3
Workspace 4
Workspace 5
Workspace 6
Workspace 7
Workspace 8
...

I have updated Xfce and the translations so it might have happened during that if there was already 4 workspaces in the old versions but maybe someone else can check to see what they got.

Go to workspace switcher settings and add some workspaces to see if they are named consistently in the list.

version 4.13.5.

Copied from https://bugzilla.xfce.org/show_bug.cgi?id=15424

scootergrisen (scootergrisen) wrote :

Also if using the string "Workspace" it should use the localized string so it does not show in english always.

Sean Davis (bluesabre) on 2019-10-26
Changed in xubuntu-default-settings (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xubuntu-default-settings - 20.04

---------------
xubuntu-default-settings (20.04) focal; urgency=medium

  * debian/control:
    - Bump Standards-Version to 4.4.0
    - Add Rules-Requires-Root: no
    - Update Vcs- locations
  * debian/control, debian/compat:
    - Bump debhelper to version 12
  * debian/live/*:
    - Move live config files to subdirectory
  * debian/live/whiskermenu-1.rc,
    debian/xubuntu-live-settings.install:
    - Remove lock menu option in live since locking is disabled (LP: #1835668)
  * debian/live/light-locker.desktop,
    debian/xubuntu-live-settings.install:
    - Remove light-locker autostart entry since we no longer ship it
  * debian/source/lintian-overrides:
    - Add override for testsuite-autopkgtest-missing
  * etc/xdg/xdg-xubuntu/xfce4/xfconf/xfce-perchannel-xml/xfwm4.xml:
    - Drop workspace labels, inconsistent with 5+ workspaces (LP: #1829778)
  * etc/xdg/xdg-xubuntu/xfce4/xfconf/xfce-perchannel-xml/xfce4-desktop.xml:
    - Set the Xubuntu wallpaper as default for up to 4 displays
  * etc/xdg/xdg-xubuntu/menus/xfce-applications.menu,
    etc/xdg/xdg-xubuntu/menus/xfce-settings-manager.menu:
    - Workaround menu handling errors in pyxdg (LP: #1833863)

 -- Sean Davis <email address hidden> Sat, 09 Nov 2019 11:42:38 -0500

Changed in xubuntu-default-settings (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints