[Suggestion] New custom command (file search) for Whisker Menu and Application Finder

Bug #1793393 reported by ondondil on 2018-09-19
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xubuntu-default-settings (Ubuntu)
Undecided
Unassigned

Bug Description

Currently, Whisker Menu does not offer a file search functionality. Therefore, I would like to suggest adding a new search action to Whisker Menu that would let the user search for files within home directory. The new search action could look like this:

name=Search for files
pattern=-
command=catfish --path=~ --start %s
regex=false

The same custom action could also be added to xfce4-appfinder:
Pattern: -
Command: catfish --path=~ --start %s

The reason why I haven't used "catfish --start %s" as a command is because if you try to search for "Music" (or any other term that is a name for one of the folders in user home directory) with this command, it will open that folder in catfish instead of displaying it in a list of files and folders that have been found to match the search term.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xubuntu-default-settings (Ubuntu):
status: New → Confirmed
ondondil (ondondil) wrote :

I'm sorry, I wasn't aware that it's already there. At the time of writing there was no such entry in cosmic which is why I assumed there's no such search action.

Now I see that the config file you linked to does not take any effect on default search actions. It seems that it's being ignored and all search actions available in cosmic are taken from here
https://git.xfce.org/panel-plugins/xfce4-whiskermenu-plugin/tree/panel-plugin/settings.cpp#n182

Mariusz Kubański (spass) wrote :

Theo, the existing one in "defaults.rc" doesn't seem to have any impact, newly created user on my 18.10 install doesn't get that Search Action by default. So it looks like Whisker Menu only takes them from the file (upstream) linked by ondondil above. Besides that, "defaults.rc" has an incomplete command for catfish (the "--path=~" part is pretty important) and misses the "Web Search" action.

Then that issue should be fixed first.

The defaults.rc is missing the line "search-actions=5".

Sean Davis (bluesabre) wrote :

Thanks for all the tips! The below commit applies the new "-" keyword to both Whisker Menu and the Application Finder and makes it actually work.

https://git.launchpad.net/xubuntu-default-settings/commit/?id=37c1122de5db3e6728b5966054c0a2a42a8df223

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xubuntu-default-settings - 18.10.2

---------------
xubuntu-default-settings (18.10.2) cosmic; urgency=medium

  * etc/skel/.config/atril/atril_toolbar.xml:
    - Add items to the Atril toolbar for improved usability (LP: #1792788)
  * etc/xdg/xdg-xubuntu/Thunar/uca.xml.in:
    - Fix file matching for the Print file/s custom command
  * etc/xdg/xdg-xubuntu/xfce4/whiskermenu/defaults.rc,
    etc/xdg/xdg-xubuntu/xfce4/xfconf/xfce-perchannel-xml/xfce4-appfinder.xml:
    - Add file search custom command (-) to Whisker Menu and
      Application Finder (LP: #1793393)
  * usr/share/xubuntu/applications/Thunar.desktop:
    - Removed, Thunar File Manager will now be displayed in
      the menu again (LP: #1774046)
  * debian/xubuntu-live-settings.install,
    debian/light-locker.desktop:
    - Disable lock-on-suspend on the live session (LP: #1421443)

 -- Sean Davis <email address hidden> Mon, 24 Sep 2018 05:02:21 -0400

Changed in xubuntu-default-settings (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers