Some icon themes have missing icons due to missing fallback setting.

Bug #1756187 reported by Alistair Buxton on 2018-03-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xubuntu-default-settings (Ubuntu)
Undecided
Unassigned

Bug Description

To reproduce:

    Install Xubuntu 18.04
    Open Appearance settings -> Icons and set to ubuntu-mono-light
    Open xfce4-settings-manager

Result:

    "Mouse and Touchpad" settings has no icon. The same icon is missing
    in a few other places too.

This affects pretty much any icon theme that does not explicitly inherit
from "gnome", which is quite a lot of themes. It even affects adwaita-icon-theme if you do not have adwaita-icon-theme-full installed too (and -full is not installed by default.)

This is due to some change in the gnome settings. Icon themes can inherit
from other themes. If an icon is still missing then the "hicolor" theme is
checked. However, Gtk+2 and Gtk+3 both also do some undocumented checks.

Gtk+3 is hardcoded to check "Adwaita" and "gnome". "gnome" is where those
missing icons are. But we are not using Gtk+3 yet.

Gtk+2 checks a xsetting called /Net/FallbackIconTheme. This is not set on
either my 16.04 system or my 18.04 system, yet my 16.04 system can find the
missing icons in "gnome". 18.04 however cannot. Setting this key (in
xfce4-settings-editor) fixes the problem. I have not yet figured out why
this was not necessary in 16.04.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: xubuntu-desktop 2.223
ProcVersionSignature: Ubuntu 4.15.0-12.13-generic 4.15.7
Uname: Linux 4.15.0-12-generic x86_64
ApportVersion: 2.20.8-0ubuntu10
Architecture: amd64
Date: Thu Mar 15 21:41:54 2018
InstallationDate: Installed on 2018-03-15 (0 days ago)
InstallationMedia: Xubuntu 18.04 LTS "Bionic Beaver" - Alpha amd64 (20180315)
SourcePackage: xubuntu-meta
UpgradeStatus: No upgrade log present (probably fresh install)

Alistair Buxton (a-j-buxton) wrote :
Alistair Buxton (a-j-buxton) wrote :

This screenshot shows the setting I created in xfce4-settings-manager in order to fix the problem.

description: updated
description: updated
Alistair Buxton (a-j-buxton) wrote :

After playing around with gconf, dconf, xfconf for a long time I ended up getting my 16.04 system to reproduce this problem, which is not really what I expected at all. I'm still not 100% sure what is going on but I think I am comfortable with recommending to set the /Net/FallbackIconTheme key by default to "gnome", for the following reason.

I found this commit: https://github.com/GNOME/gtk/commit/a093cd2a22173369424878eb6d8c38124e7aa1f9

This is the commit I mentioned above which hard codes a (undocumented) check to "gnome" icon theme in Gtk+3. Note what the comment says:

  "This is what we used to get through the Net/FallbackIcontheme
   setting. Nobody has ever set this setting to a different value,
   and people have come to rely on GTK+ applications getting their
   icons this way."

Well, currently, Xubuntu does set this differently - by not setting it at all.

I have looked everywhere and this seems to be the only setting that controls the fallback icon theme in Gtk+2. Note that Gtk+3 apps don't just have this setting by default. They are hard coded to check "gnome" regardless of the value of this setting. So by setting it we would make our Gtk+2 apps behave a tiny bit more like Gtk+3 apps. (And I won't have broken icons in my menus. :)

Kev Bowring (flocculant) wrote :

I see icon for mouse/touchpad - using the xubuntu team ppa's and the shimmer one.

Kev Bowring (flocculant) wrote :

Confirmed - missing icon on panel

Sean Davis (bluesabre) wrote :

Moved to settings

affects: xubuntu-meta (Ubuntu) → xubuntu-default-settings (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xubuntu-default-settings - 18.04.4

---------------
xubuntu-default-settings (18.04.4) bionic; urgency=medium

  * Fix invalid desktop files (LP: #1754888)
    - usr/share/xubuntu/applications/Thunar-bulk-rename.desktop
    - usr/share/xubuntu/applications/Thunar.desktop
    - usr/share/xubuntu/applications/debian-uxterm.desktop
    - usr/share/xubuntu/applications/debian-xterm.desktop
    - usr/share/xubuntu/applications/thunar-settings.desktop
    - usr/share/xubuntu/applications/xfce4-terminal.desktop
  * usr/share/xubuntu/templates/xdg-xubuntu-templates:
    - Fix FileNotFound error (LP: #1694471)
    - Fix UnicodeDecode error (LP: #1668191)
  * etc/xdg/xdg-xubuntu/xfce4/xfconf/xfce-perchannel-xml/xsettings.xml:
    - Set Net/FallbackIconTheme for correct icon inheritance
      on GTK+ 2 (LP: #1756187)
  * etc/xdg/xdg-xubuntu/xfce4/panel/default.xml:
    - Add notification plugin to panel

 -- Sean Davis <email address hidden> Sat, 17 Mar 2018 09:05:16 -0400

Changed in xubuntu-default-settings (Ubuntu):
status: New → Fix Released
Alistair Buxton (a-j-buxton) wrote :

Confirming it is fixed for me. Thanks :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints