Menulibre: invalid desktop files detected!

Bug #1754888 reported by Willem Hobers on 2018-03-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MenuLibre
Undecided
Sean Davis
menulibre (Ubuntu)
Undecided
Unassigned
vim (Ubuntu)
Undecided
Unassigned
xubuntu-default-settings (Ubuntu)
Undecided
Unassigned

Bug Description

Not sure whether to report this as a bug, but:

Running xubuntu 18.04, updated.

Linux Xubuntu-18-04 4.15.0-10-generic #11-Ubuntu SMP Tue Feb 13 18:23:35 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Menulibre 2.1.5

On starting menulibre I get a warning: Menulibre: invalid desktop files detected!

See: http://i.imgur.com/Jqdge9z.png

If I click on details, I get:

http://i.imgur.com/H7RwsOO.png

I think these invalid desktop files are part of the initial installation of menulibre/xubuntu.
As a simple end user I do not know what to do with this warning.

Sean Davis (bluesabre) wrote :

xubuntu-default-settings, affected files:

/usr/share/xubuntu/applications/Thunar-bulk-rename.desktop
/usr/share/xubuntu/applications/Thunar.desktop
/usr/share/xubuntu/applications/debian-uxterm.desktop
/usr/share/xubuntu/applications/debian-xterm.desktop
/usr/share/xubuntu/applications/thunar-settings.desktop
/usr/share/xubuntu/applications/xfce4-terminal.desktop

Sean Davis (bluesabre) wrote :

vim, affected file:

/usr/share/applications/vim.desktop

This file is provided by the vim-common package, which is required by vim-tiny package, but provides a launcher for the vim binary, which is provided by the vim package.

no longer affects: menulibre
Sean Davis (bluesabre) wrote :

After reviewing the package for vim, it doesn't seem like there's a good way to resolve this issue for the vim source package. So this leaves two options.

1) Xubuntu provides vim instead of vim-tiny.
2) MenuLibre adds a way to ignore errors, and Xubuntu provides this override for the base install.

It's still reasonable to leave this bug open since the provided .desktop file is invalid.

Willem Hobers (whobers) wrote :

I'd be willing to test the fix, if that is at useful. If so: could you advice me how to go about this?

Sean Davis (bluesabre) wrote :

Vim's desktop file is actually working as expected here. The TryExec key is used to determine if the desktop file is usable... and when the vim binary is missing, it is not.

Changed in vim (Ubuntu):
status: New → Invalid
Changed in menulibre:
status: New → Fix Committed
assignee: nobody → Sean Davis (bluesabre)
Sean Davis (bluesabre) on 2018-03-17
Changed in menulibre:
milestone: none → 2.2.0
Sean Davis (bluesabre) on 2018-03-17
Changed in menulibre:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xubuntu-default-settings - 18.04.4

---------------
xubuntu-default-settings (18.04.4) bionic; urgency=medium

  * Fix invalid desktop files (LP: #1754888)
    - usr/share/xubuntu/applications/Thunar-bulk-rename.desktop
    - usr/share/xubuntu/applications/Thunar.desktop
    - usr/share/xubuntu/applications/debian-uxterm.desktop
    - usr/share/xubuntu/applications/debian-xterm.desktop
    - usr/share/xubuntu/applications/thunar-settings.desktop
    - usr/share/xubuntu/applications/xfce4-terminal.desktop
  * usr/share/xubuntu/templates/xdg-xubuntu-templates:
    - Fix FileNotFound error (LP: #1694471)
    - Fix UnicodeDecode error (LP: #1668191)
  * etc/xdg/xdg-xubuntu/xfce4/xfconf/xfce-perchannel-xml/xsettings.xml:
    - Set Net/FallbackIconTheme for correct icon inheritance
      on GTK+ 2 (LP: #1756187)
  * etc/xdg/xdg-xubuntu/xfce4/panel/default.xml:
    - Add notification plugin to panel

 -- Sean Davis <email address hidden> Sat, 17 Mar 2018 09:05:16 -0400

Changed in xubuntu-default-settings (Ubuntu):
status: New → Fix Released
Willem Hobers (whobers) wrote :

Sean, I can confirm that this fixes the issue for

  - usr/share/xubuntu/applications/Thunar-bulk-rename.desktop
  - usr/share/xubuntu/applications/Thunar.desktop
  - usr/share/xubuntu/applications/debian-uxterm.desktop
  - usr/share/xubuntu/applications/debian-xterm.desktop
  - usr/share/xubuntu/applications/thunar-settings.desktop
  - usr/share/xubuntu/applications/xfce4-terminal.desktop

Just the message about "vim" remains.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package menulibre - 2.2.0-1

---------------
menulibre (2.2.0-1) unstable; urgency=medium

  [ SVN-Git Migration ]
  * debian/control:
    - Update Vcs fields for git migration

  [ Sean Davis ]
  * New upstream release.
    - Fix TryExec validation (LP: #1754888)
  * debian/copyright:
    - Add myself to debian packaging copyright

 -- Sean Davis <email address hidden> Tue, 20 Mar 2018 21:29:04 -0400

Changed in menulibre (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints