QT apps doesn't have icons from theme

Bug #1451993 reported by Yanpas on 2015-05-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xubuntu-default-settings (Ubuntu)
Undecided
Unassigned

Bug Description

Since 14.10 QT doesn't use gtk icon theme. Moreover by default they do not use gtk style, but it is fixable. But I can't make them to use GTK ICON THEME. In 14.04 everything is good.

Yanpas (yanpaso) wrote :

Workaround from http://www.webupd8.org/2015/03/install-xfce-412-in-xubuntu-1404-or.html COMMENTS

Create (or modify) ~/.kde/share/config/kdeglobals so that it contains e.g.:

[Icons]
Theme=elementary-xfce-darker

You might need to clear the icons cache afterwards:
rm /var/tmp/kdecache-$USER/icon-cache.kcache
 • Reply•Share ›
Avatar
Yan Pashkovsky b3nmore • 21 hours ago
Did it work for you?
 • Edit• Reply•Share ›
Avatar
b3nmore Yan Pashkovsky • 11 hours ago
Yes it does. All kde/qt apps I use (amarok, digikam, k3b, audex) use the correct icon theme.
Make sure, that the theme name you write into kdeglobals concur with the folder name of the icon theme. For xubuntu icon themes are stored under "/usr/share/icons". And clear the cache file after you've changed the theme name.

Yanpas (yanpaso) on 2015-06-18
affects: xfce4-settings (Ubuntu) → xubuntu-default-settings (Ubuntu)
Yanpas (yanpaso) on 2016-06-23
Changed in xubuntu-default-settings (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.