suspending xubuntu live session locks screen and requires password

Bug #1421443 reported by ElTomoLoco on 2015-02-12
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xubuntu-default-settings (Ubuntu)
Undecided
Unassigned

Bug Description

When I suspend the live session of Xubuntu 14.10 and wake up the computer, the screen is locked and I'm asked to give a user name and a password. I had to open a command-live session with ctrl+alt+F1 and run 'users' to find out that the user name is 'xubuntu' and then I guessed the password was blank. A regular user might not know how to do this and it seems to me absolutely pointless to lock the screen of a live session. I mean okay: somebody could walk up to your suspended computer, wake it up and click install on the desktop and proceed to wipe out your hardrive. Ok. If that's your concern, then please let whoever is starting the live session now from the start in a way that is hard to miss what the user name and password are.

Otherwise, I'm really impressed with the progress from xubuntu 13.10 and I'm looking forward to the official release of xfce 4.12!

Should the "lock-on-suspend" behavior be changed?

https://git.launchpad.net/xubuntu-default-settings/tree/debian/xubuntu-default-settings.gsettings-override#n4

Or, maybe it is possible to automatically fill the username input field with "xubuntu", and therefore avoid the username guessing.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xubuntu-default-settings (Ubuntu):
status: New → Confirmed

The above setting is not specific to the live session though.

Instead, reverting the change from the following commit would disable screen lock on suspend:

https://git.launchpad.net/xubuntu-default-settings/commit/?id=2c3f666b2ecfcdda65bb9d622453710eec61df8e

Sean Davis (bluesabre) wrote :

@lastonestanding, thanks for the suggestion! This change was applied here: https://git.launchpad.net/xubuntu-default-settings/commit/?id=c6d1bcaeaf16ec4107745fa6b21019cfc5a97aa7

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xubuntu-default-settings - 18.10.2

---------------
xubuntu-default-settings (18.10.2) cosmic; urgency=medium

  * etc/skel/.config/atril/atril_toolbar.xml:
    - Add items to the Atril toolbar for improved usability (LP: #1792788)
  * etc/xdg/xdg-xubuntu/Thunar/uca.xml.in:
    - Fix file matching for the Print file/s custom command
  * etc/xdg/xdg-xubuntu/xfce4/whiskermenu/defaults.rc,
    etc/xdg/xdg-xubuntu/xfce4/xfconf/xfce-perchannel-xml/xfce4-appfinder.xml:
    - Add file search custom command (-) to Whisker Menu and
      Application Finder (LP: #1793393)
  * usr/share/xubuntu/applications/Thunar.desktop:
    - Removed, Thunar File Manager will now be displayed in
      the menu again (LP: #1774046)
  * debian/xubuntu-live-settings.install,
    debian/light-locker.desktop:
    - Disable lock-on-suspend on the live session (LP: #1421443)

 -- Sean Davis <email address hidden> Mon, 24 Sep 2018 05:02:21 -0400

Changed in xubuntu-default-settings (Ubuntu):
status: Confirmed → Fix Released
Jarno Suni (jarnos) wrote :

Can you still enable lock-on-suspend by manually editing the power manager settings in live session, if you want to test it?

The autostart entry for light-locker was disabled, and now the session will not be locked on suspend despite lock-on-suspend still being enabled.

For testing purpose one has to manually start light-locker.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers