Name For Thunar Settings Launcher Is Unclear (thunar-settings.desktop)

Bug #1396804 reported by Sajan Parikh on 2014-11-26
36
This bug affects 7 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
Unassigned
xubuntu-default-settings (Ubuntu)
Low
Unassigned

Bug Description

Can we change the 'Name' paramenter in the default /usr/share/applications/thunar-settings.desktop from 'File Manager' to 'File Manager Preferences'?

When typing in "File Mana" in Whisker (or any other searchable menu/launcher), two entries come up, both labeled as 'File Manager' and both with the same icon, even though one takes you to the preferences and the other to the actual file manager. It really hurts the common workflow of assigning whisker-popup-menu to the super key, typing in a few letters, and pressing enter to launch stuff. I've launched the preferences many times when I just wanted the file manager.

Editing the name to 'File Manager Preferences' not only makes it clear that it's going to open up the preferences instead of the File Manager, but it also puts the entry below the actual 'File Manager' due to the way its sorted. Allowing easier launch of the File Manager.

--------------------------------
➜ ~ lsb_release -rd
Description: Ubuntu 14.10
Release: 14.10

Using Xubuntu 14.10

➜ ~ apt-cache policy thunar
thunar:
  Installed: 1.6.3-1ubuntu6
  Candidate: 1.6.3-1ubuntu6
  Version table:
 *** 1.6.3-1ubuntu6 0
        500 http://mirrors.gigenet.com/ubuntuarchive/ utopic-updates/universe amd64 Packages
        100 /var/lib/dpkg/status
     1.6.3-1ubuntu5 0
        500 http://mirrors.gigenet.com/ubuntuarchive/ utopic/universe amd64 Packages

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: thunar 1.6.3-1ubuntu6 [modified: usr/share/applications/thunar-settings.desktop]
ProcVersionSignature: Ubuntu 3.16.0-25.33-generic 3.16.7
Uname: Linux 3.16.0-25-generic x86_64
ApportVersion: 2.14.7-0ubuntu8
Architecture: amd64
CurrentDesktop: XFCE
Date: Wed Nov 26 15:58:11 2014
InstallationDate: Installed on 2014-11-25 (1 days ago)
InstallationMedia: Xubuntu 14.10 "Utopic Unicorn" - Release amd64 (20141022.1)
SourcePackage: thunar
UpgradeStatus: No upgrade log present (probably fresh install)

Sajan Parikh (sajanparikh) wrote :
Elfy (elfy) on 2014-11-27
tags: added: vivid
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in thunar (Ubuntu):
status: New → Confirmed
Simon Steinbeiß (ochosi) wrote :

I acknowledge the problem, but for the moment I don't see a good solution for this problem.
Renaming is problematic because:
 * it creates an inconsistency with other items in the Settings Manager ("Desktop" vs. "Desktop Settings", or "Display" vs. "Display Settings")
 * the translations in the desktop file would all have to be updated.

We could also try to hide it from whisker-menu but keep showing it in the Settings Manager, but that again would be inconsistent with the other settings-items showing up in the list.

If anybody has good ideas on how to solve this, don't hesitate to comment.

Sajan Parikh (sajanparikh) wrote :

What about seriously thinking about making those changes across all the settings launchers? I know its a bit drastic for this one issue, but its not just one issue I think. Making the changes across the board fixes it all, while maintaining consistency.

Yes, it's a bit of work, but seeing "Display Settings" vs "Display" definitely sounds like the way it should've been from the get go.

Here's a list of all the ones I that I think would need to be updated. Some make this list because they are vague, others make this list to satisfy consistency.

Desktop (Desktop Settings)
File Manager (File Manager Settings)
Light Locker Settings (!Already Does This!)
Notifications (Notification Settings)
Panel (Panel Settings)
Window Manager (Window Manager Settings)
Workspaces (Workspaces Settings)
Display (Display Settings)
Keyboard (Keyboard Settings)
Mouse and Touchpad (Mouse and Touchpad Settings/ Pointer Settings/ Input Pointer Settings)
Removable Drives and Media (Removable Drives and Media Settings)
Network (Network Settings)
Network Connections (!Fine the way it is!)

I would say that due to the character length on some of these changes would only need to be made in the .desktop launchers, everything can stay as is in the Settings Manager. I don't think consistency is an issue there, because in the Settings Manager, it is already labeled as "File Manager Preferences", while the .desktop launcher is just "File Manager".

Of course, there are many translations to think about and I've no clue whats involved with that; if all the translaters are even around, or how this stuff gets translated in the first place.

Simon Steinbeiß (ochosi) wrote :

I would be opposed to renaming all items in the settings-manager with a -settings postfix. It seems quite redundant, to be honest (in addition to all the translation work it causes). Take a look at other settings managers, e.g. Gnome3 or Unity, there's no -settings there either.

Also, not all of the items you mention above are under our control, e.g. "Network" comes from the network-manager package.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1396804

tags: added: iso-testing
Changed in hundredpapercuts:
status: New → Confirmed
importance: Undecided → Low
Changed in thunar (Ubuntu):
importance: Undecided → Low

How about using a different icon for thunar-settings? This would be the easiest fix, but would it be sufficient?

Simon Steinbeiß (ochosi) wrote :

While we could do that, that would mean that we'd have to change the icon name to something new, like from
"system-file-manager"
to
"system-file-manager-settings"
or even
"thunar-settings"
to be more specific.
The problem I see with this solution is that
1) there is no precedence, so no other icon-theme will supply this icon. Meaning if the user switches to a different theme, that'll look bad.
2) I'm not sure this is a real solution. Only changing the icon and not the label implies that an icon will create a clear distinction between the two, I'm a bit doubtful that really can be achieved.

Another option I could imagine is hiding that launcher altogether. After all, no other application has its preferences dialog hooked into the settings manager. So it would still remain accessible via Thunar's "Edit" > "Preferences" menu.

affects: thunar (Ubuntu) → xubuntu-default-settings (Ubuntu)
Simon Steinbeiß (ochosi) wrote :

@Sean: Thoughts on the option to just hide the launcher everywhere?

Elfy (elfy) wrote :

fwiw - the remove from menu option seems like the sensible choice here, nothing else has it's settings populating the menu

Changed in xubuntu-default-settings (Ubuntu):
status: Confirmed → Fix Committed
Changed in hundredpapercuts:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xubuntu-default-settings - 15.04.3

---------------
xubuntu-default-settings (15.04.3) vivid; urgency=medium

  [ Unit 193 ]
  * debian/xubuntu-default-settings.gsettings-override:
    - Remove override for show-notify-osd-on-scroll, key removed.

  [ Thaddaeus Tintenfisch ]
  * usr/share/xubuntu/applications/thunar-settings.desktop
    - Remove thunar-settings from the menu, redundant (LP: #1396804)

  [ Sean Davis ]
  * usr/share/polkit-1/actions/com.ubuntu.pkexec.thunar.policy.in
    - Dropped, policy included upstream in thunar package
 -- Sean Davis <email address hidden> Sat, 21 Feb 2015 14:39:39 -0500

Changed in xubuntu-default-settings (Ubuntu):
status: Fix Committed → Fix Released
Changed in hundredpapercuts:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints