Qt apps are displaying a very old styled theme as oppose to greybird

Bug #1382741 reported by Shuhao on 2014-10-18
36
This bug affects 8 people
Affects Status Importance Assigned to Milestone
xubuntu-default-settings (Ubuntu)
Undecided
Unassigned

Bug Description

After upgrading to 14.10 some apps are displaying some really old looking themes. System is set to greybird.

See attachment for details.

Programs affected:

 - Lyx
 - KeepassX

This also happens during right after login: xfce4-panel is all grey and what not, eventually switching to greybird, however (after 5s or so).

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: xfwm4 4.11.2-0ubuntu2
ProcVersionSignature: Ubuntu 3.16.0-23.30-generic 3.16.4
Uname: Linux 3.16.0-23-generic x86_64
ApportVersion: 2.14.7-0ubuntu7
Architecture: amd64
CurrentDesktop: XFCE
Date: Sat Oct 18 01:07:50 2014
InstallationDate: Installed on 2013-07-08 (466 days ago)
InstallationMedia: Xubuntu 13.04 "Raring Ringtail" - Release amd64 (20130423.1)
ProcEnviron:
 LANGUAGE=en_US
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/zsh
SourcePackage: xfwm4
UpgradeStatus: Upgraded to utopic on 2014-10-18 (0 days ago)

Shuhao (shuhao) wrote :
Shuhao (shuhao) wrote :

Hm. It looks lie the problem is with qt4 applications. Not sure about the flashing of light grey theme while booting, though.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfwm4 (Ubuntu):
status: New → Confirmed
Elfy (elfy) wrote :

install qt4-qtconfig and set gui style to gtk+ for the apps

I sometimes see *unstyled* apps if apps are open when I shutdown, don't see it while booting

Changed in xfwm4 (Ubuntu):
status: Confirmed → Incomplete
affects: xfwm4 (Ubuntu) → xfce4-settings (Ubuntu)

Does the "visual glitch" right after login affect other user accounts or the guest session? The GTK+ theme will be applied once xfsettingsd has been started by the session manager. Therefore, clearing the session cache may resolve the problem (Settings Manager > Sessions and Startup > Session).

Shuhao (shuhao) wrote :

Doesn't happen with the guest account. Clearing the session cache doesn't work.

Maybe there's some really old still lying around? Not sure how to find it and remove it.

Shuhao (shuhao) on 2014-10-18
Changed in xfce4-settings (Ubuntu):
status: Incomplete → Confirmed
affects: xfce4-settings (Ubuntu) → xubuntu-default-settings (Ubuntu)
Simon Steinbeiß (ochosi) wrote :
Changed in xubuntu-default-settings (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xubuntu-default-settings - 15.04.0

---------------
xubuntu-default-settings (15.04.0) vivid; urgency=medium

  * etc/skel/.config/Trolltech.conf:
    - Set QT defaults to Gtk/Xubuntu defaults (LP: #1382741)
  * etc/xdg/xdg-xubuntu/xfce4/xfconf/xfce-perchannel-xml/xfwm4.xml:
    - Increase xfwm double-click time to 400ms to match defaults in
      xfce4-settings.
  * debian/xubuntu-default-settings.maintscript:
  * etc/skel/.config/gtk-3.0/gtk.css:
  * etc/xdg/xdg-xubuntu/xfce4/xfconf/xfce-perchannel-xml/xsettings.xml:
    - Restore default color scheme, no more pink unicorns.
  * debian/control:
    - Update to Standards Version 3.9.6, no changes needed.
  * debian/copyright:
    - Update maintenance date, copyright email.
 -- Sean Davis <email address hidden> Sun, 02 Nov 2014 19:27:10 -0500

Changed in xubuntu-default-settings (Ubuntu):
status: Fix Committed → Fix Released
summary: - Some apps are displaying a very old styled theme as oppose to greybird
+ Qt apps are displaying a very old styled theme as oppose to greybird
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints