[SRU] Black screen after wakeup from suspending by closing the laptop lid

Bug #1303736 reported by Minium on 2014-04-07
This bug affects 285 people
Affects Status Importance Assigned to Milestone
xfce4-power-manager
Fix Released
Medium
xfce4-power-manager (Ubuntu)
Undecided
Unassigned
Declined for Utopic by Adam Conrad
xubuntu-default-settings (Ubuntu)
High
Jackson Doak
Declined for Utopic by Adam Conrad
Trusty
Undecided
Unassigned

Bug Description

Problem description
---

Expected behaviour:
After putting the computer to sleep (suspend), the display manager (LightDM) appears, I log in and the session resumes.

Behaviour:
After logging back into the session the screen remains black. The system is awake and I can get back to the display
manager, but I cannot continue work due to a black display screen.

[Test Case]
Suspend the computer, then attempt to log back in. The screen will remain black.

[Regression potential]
None apparent, tested in utopic and a ppa.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: linux-image-3.13.0-23-generic 3.13.0-23.45
ProcVersionSignature: Ubuntu 3.13.0-23.45-generic 3.13.8
Uname: Linux 3.13.0-23-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.14.1-0ubuntu1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: minium 2210 F.... pulseaudio
CurrentDesktop: XFCE
Date: Mon Apr 7 13:00:11 2014
HibernationDevice: RESUME=UUID=d5c0f9e8-e1a0-4ca1-a684-4879c98be5d5
InstallationDate: Installed on 2014-04-02 (4 days ago)
InstallationMedia: Xubuntu 14.04 LTS "Trusty Tahr" - Daily amd64 (20140402)
MachineType: LENOVO 4242PT2
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.13.0-23-generic.efi.signed root=/dev/mapper/xubuntu--vg-root ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.13.0-23-generic N/A
 linux-backports-modules-3.13.0-23-generic N/A
 linux-firmware 1.127
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/26/2013
dmi.bios.vendor: LENOVO
dmi.bios.version: 8AET64WW (1.44 )
dmi.board.asset.tag: Not Available
dmi.board.name: 4242PT2
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr8AET64WW(1.44):bd07/26/2013:svnLENOVO:pn4242PT2:pvrThinkPadT520:rvnLENOVO:rn4242PT2:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 4242PT2
dmi.product.version: ThinkPad T520
dmi.sys.vendor: LENOVO

Minium (minium) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.14 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.14-trusty/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
affects: linux (Ubuntu) → light-locker (Ubuntu)
Changed in light-locker (Ubuntu):
status: Incomplete → New
Elfy (elfy) wrote :

Attaching logs

Elfy (elfy) wrote :
Elfy (elfy) wrote :
Elfy (elfy) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in light-locker (Ubuntu):
status: New → Confirmed
Elfy (elfy) wrote :

adding logging - successful resume after suspending via menu

tags: added: kernel-bug-exists-upstream
Elfy (elfy) wrote :

added logging - failed resume after suspending via closed lid

Shuhao (shuhao) wrote :

So a work around:

Bind a keyboard shortcut to a valid xrandr command that maps your screen. This is mine:

#!/bin/sh
xrandr --output LVDS1 --mode 1366x768 --pos 0x0 --rotate normal --output VGA1 --off

You might need to edit this. If you get the black screen simply press your shortcut to execute this command and it should be okay.

Also I would propose this to be urgent rather than medium as it is a blocking issue for many people with laptops.

Minium (minium) wrote :

There is one more symptom:
- The background image of the display manager changes to the default one
   instead of the custom set one after resuming from suspend.

GridCube (gridcube) wrote :

I have also noticed that the screen is not actually off but the brightness of it is so low it appears to be off. Using an xrandr to reset the screen seems to work to reset the brightness.

Can anyone confirm that suspending via menu also triggers the black screen?

Elfy (elfy) on 2014-04-08
affects: light-locker (Ubuntu) → xfce4-power-manager (Ubuntu)
Changed in xfce4-power-manager:
importance: Unknown → Undecided
status: Unknown → New
Pasi Lallinaho (knome) on 2014-04-17
Changed in xfce4-power-manager (Ubuntu):
importance: Medium → High
Minium (minium) wrote :

Regarding comment #14

Going into suspend via the menu does not trigger any faulty behavior. I'm able
to successfully recover from suspend without any troubling symptoms. The problem
only exists when going into suspend via closed lid.

yochaigal (yochaigal) wrote :

Creating an xrandr shell script + key combo works, except the mouse cursor is missing.

wutr (wutr) wrote :

With regards to comment #16:

I have the same problem. The mouse cursor is missing, but the mouse still works. You can see icons, tabs, buttons etc. being highlighted as the mouse passes over it.

You get the pointer back though when you switch to a text tty (ALT-CTRL-F1) and then back to the GUI (ALT-CTRL-F7). You don't need to login to the text terminal.

I've also found that if you disable "Lock on suspend" in the "Light Locker Settings" screen, and then manually lock the screen from the terminal with:

light-locker-command -l

and then close the lid so the laptop suspends, resuming works fine without the need for any workarounds.

Noxious Inc. (noxious-inc) wrote :

I had this error also a few times, the first time however I could get it back by pressing my 'Fn' key and the 'extend monitor' key. Very strange behavior.

Noxious Inc. (noxious-inc) wrote :

For the moment I use the option to not ask for a password after bringing back the system from suspention.

Heikki Ketoharju (heikkiket) wrote :

When I close laptop lid, machine hibernates. But when I open the lid maybe an hour later and give a password screen lock asks, I can remove lock but screen turns blank. I guess screen lock doesn't tell to the powermanager that it should turn screen from blank state to showing desktop. If I remove locking feature, everything works well. I solved the problem by removing light-locker and installing xscreensaver as in my old Xubuntu installation. My installation was new, not upgraded from previous version, but home folder and settings are migrated from old Xubuntu 12.10 installation.

James0r (james-auble2) wrote :

Both of my laptops have most all of these symptoms.

As mentioned in comment #13, the lowest brightness setting is also a symptom of this bug. I can't confirm what he/she is saying about the sessions brightness but I can say that lightdm is at lowest brightness when on resume after suspend by lid close. Furthermore, on system reboot the screen brightness remains at lowest brightness until I adjust it.

James0r (james-auble2) wrote :

For new Xfce users it might also be relevant to mention that you can use xscreensaver to lock and blank the screen. I have substituted xscreensaver for screen locking while I wait for a fix for screen locker.

Paul Schyska (pschyska-m) wrote :

I have the same bug - black screen on resume after unlocking, but only when the suspend was triggered via lid close and not when doing it from the XFCE menu.
Also, the display backlight is very low. Turning the brightness up while on TTY1 with my media keys or cat'ing a high value to /sys/class/backlight/.../brightness makes on difference on TTY7 - still black (like #21 described).

The workaround from #11 works, thank you for that!

I'm basically just writing because the original reporter seems to use nvidia drivers, but I'm on intel.

wutr (wutr) wrote :

After some further testing I'd like to add this:

As I mentioned before, locking with the command "light-locker-command -l" and then closing the laptop lid allows you to resume just fine, with the session being locked properly.

Running "light-locker-command -l" on suspend (via a script in /usr/lib/pm-utils/sleep.d) with the use of 'xdotools' and the standard keyboard shortcut assigned via the XFCE keyboard settings (sudo -u <USERNAME> sh -c 'xdotools key Control+Alt+Delete') which runs the script 'xflock4' (calls 'light-locker-command -l') results in the same behaviour as when "Lock on suspend" is enabled in the "Light Locker" settings.

Could this mean that light-locker locks the screen too late? Should the screen be locked before anything else related to suspending happens?

As Heikki and James mention, replacing light-locker helps. In my case I removed light-locker light-locker-settings packages and installed gnome-screensaver package. gnome-screensaver locker looks much nicer than xscreensaver IMHO.

Paul Schyska (pschyska-m) wrote :

Reinis,

do I have to change any setting or just remove/install the mentioned packages? Does xflock4 pick gnome-screensaver as locker automatically?

wutr (wutr) wrote :

Paul,

xflock4 (a shell script), tries to use either light-locker, xscreensaver or gnome-screensaver, so you should be OK.

I can note that I also suffer from the issue when I disable suspending when closing the laptop lid: Settings > Power Manager > When laptop screen is closed: "Lock Screen". In this case light-locker still locks the screen when closing the lit and the laptop display itself is also shutdown. When suspending, the laptop screen also is shutdown.

So rather than 'suspend to RAM' being the culprit I argue that powering off the laptop screen (which happens both with and without suspend when closing the lid) is the cause for the blank screen after unlocking. I can confirm that the xrandr fix also works in this case (which lead me to suspect it has to do something with the monitor being shutdown), unfortunately "Configure new displays when connected" under Settings > Displays doesn't seem to do the trick.

Liviu Andronic (landronimirc) wrote :

I notice a very similar issue on a fresh install of Xubuntu 14.04 on a Dell Inspiron:
I'm noticing issues with putting the laptop to Suspend. Whether I do it from xfce4-session-logout or from xfce4-power-manager, the laptop will hang on attempting to Suspend, when I hit the power button the laptop shuts down, when I restart
there is the "Report a problem" wizard which reports that the laptop failed to resume properly from suspend.

HOWEVER, the awkward issue is that when I do Suspend from within LightDM it works fine (doesn't hang _and_ resumes fine). Also, `sudo pm-suspend` works, too, without a glitch.

rathboma (matthew-rathbone) wrote :

I can confirm this happens on Intel graphics too. I'm running a Lenovo Edge E431. It has the Intel 4000HD

Liviu Andronic (landronimirc) wrote :

To confirm, for my system (Xubuntu 14.04 on a Dell Inspiron) removing 'light-locker' and 'light-locker-settings' and installing 'xscreensaver' solves the issue of buggy suspend/resume.

GridCube (gridcube) wrote :

That doesn't solve the issue, it just avoids it.

Nick Rhodes (ngrhodes) wrote :

For me I get this issue on lid close, no matter if on battery or mains, suspend on lid close enabled not.

Artyom Nosov (artyom.nosov) wrote :

The same issue. The following workaround as a hotkey works for me:

xrandr --output LVDS-1-0 --mode 1920x1080 --pos 0x0 --rotate normal --output VGA-1-0 --off

Thanks, Shuhao (shuhao)

Bernard Decock (decockbernard) wrote :

I have this issue on a Dell Inspiron 6000 after a regular shut-down. The screen stay blank. One has to power down the machine. After powering up everything works fine again. This phenomenon happens frequently. I don't suspend the computer.

Chris Wilson (laun5hpad) wrote :

I can also confirm this behaviour in Xubuntu 14.04 (on my trusty ol' Vaio TZ21 using the venerable Intel 945GM chipset). I did not have this problem for 13.10 or 13.04.

Interestingly, when I switch off Light Locker and rely on Power Manager to suspend the laptop when closing the lid, the screen is restored okay, but for some reason the Display settings window is now visible..!? Also, there is no issue when suspending via the menu.

This leads me to think that the issue is with Light Locker, and not Power Manager. (Although is Power Manager responsible for the mysterious appearance of the Display settings window on resume..??)

Glad to see this is now high priority...

Rory Yorke (ryorke) wrote :

Confirmed on Xubuntu 14.04 on Dell Inspiron 3521, which has a dual GPU (Intel/AMD). Removing light-locker and installing xscreensaver (I already had it installed -- probably had it since 13.04?) is a successful workaround.

Download full text (3.7 KiB)

For me at least this completely fixes the issues around suspending

It seems they included broken / buggy packages in the main build,
completely disabling this "lightlocker" crap seems to have a tremendous
benefit in mitigating the issue.

I am unsure of how this affects my laptop's suspend or sleep modes but it
means I can use the thing after going from A->B, I would recommend backing
up everything you work on using Ubuntu 14.04 anyway as I have noticed
several other bugs, however as I feel this has been a drawn out bug request
which I have had to fix myself I dont see any point using ubuntu any more
and will switch distros until it becomes more stable​

On 26 April 2014 09:07, Rory Yorke <email address hidden> wrote:

> Confirmed on Xubuntu 14.04 on Dell Inspiron 3521, which has a dual GPU
> (Intel/AMD). Removing light-locker and installing xscreensaver (I
> already had it installed -- probably had it since 13.04?) is a
> successful workaround.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1307918).
> https://bugs.launchpad.net/bugs/1303736
>
> Title:
> Black screen after login from suspend in Xubuntu 14.04
>
> Status in Xfce4 Power Manager:
> New
> Status in “xfce4-power-manager” package in Ubuntu:
> Confirmed
>
> Bug description:
> Problem description
> ---
>
> Expected behaviour:
> After putting the computer to sleep (suspend), the display manager
> (LightDM) appears, I log in and the session resumes.
>
> Behaviour:
> After logging back into the session the screen remains black. The system
> is awake and I can get back to the display
> manager, but I cannot continue work due to a black display screen.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 14.04
> Package: linux-image-3.13.0-23-generic 3.13.0-23.45
> ProcVersionSignature: Ubuntu 3.13.0-23.45-generic 3.13.8
> Uname: Linux 3.13.0-23-generic x86_64
> NonfreeKernelModules: nvidia
> ApportVersion: 2.14.1-0ubuntu1
> Architecture: amd64
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC0: minium 2210 F.... pulseaudio
> CurrentDesktop: XFCE
> Date: Mon Apr 7 13:00:11 2014
> HibernationDevice: RESUME=UUID=d5c0f9e8-e1a0-4ca1-a684-4879c98be5d5
> InstallationDate: Installed on 2014-04-02 (4 days ago)
> InstallationMedia: Xubuntu 14.04 LTS "Trusty Tahr" - Daily amd64
> (20140402)
> MachineType: LENOVO 4242PT2
> ProcFB: 0 inteldrmfb
> ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.13.0-23-generic.efi.signed
> root=/dev/mapper/xubuntu--vg-root ro quiet splash vt.handoff=7
> RelatedPackageVersions:
> linux-restricted-modules-3.13.0-23-generic N/A
> linux-backports-modules-3.13.0-23-generic N/A
> linux-firmware 1.127
> RfKill:
> 0: phy0: Wireless LAN
> Soft blocked: no
> Hard blocked: no
> SourcePackage: linux
> UpgradeStatus: No upgrade log present (probably fresh install)
> dmi.bios.date: 07/26/2013
> dmi.bios.vendor: LENOVO
> dmi.bios.version: 8AET64WW (1.44 )
> dmi.board.asset.tag: Not Available
> dmi.board.name: 4242PT2
> dmi.board.vendor: LENOVO
> dmi.board.version: Not Availab...

Read more...

I'm seeing this problem occasionally ever after removing light-locker and light-locker-settings. I'm using gnome-screensaver and xscreensaver is not installed.

I saw these symptoms in 13.10 and was only able to resolve it by upgrading to a development version of lightdm. The issue was with virtual terminal switching I believe. Perhaps some affected users could use gdm in place of lightdm. In my case gdm isn't an option as gdm loads very slowly on my system.

Mike Chelen (mchelen) wrote :

Disabling lightlocker according to #38 fixed the problem for me.

Elfy (elfy) on 2014-05-15
summary: - Black screen after login from suspend in Xubuntu 14.04
+ Black screen after wakup from suspending by closing the laptop lid
summary: - Black screen after wakup from suspending by closing the laptop lid
+ Black screen after wakeup from suspending by closing the laptop lid
Changed in xfce4-power-manager:
importance: Undecided → Unknown
status: New → Unknown
Changed in xfce4-power-manager (Ubuntu):
status: Confirmed → Triaged
Changed in xfce4-power-manager:
importance: Unknown → Undecided
status: Unknown → New
Changed in xfce4-power-manager (Ubuntu):
status: Triaged → Fix Released
Jackson Doak (noskcaj) on 2014-06-05
summary: - Black screen after wakeup from suspending by closing the laptop lid
+ [SRU] Black screen after wakeup from suspending by closing the laptop
+ lid
description: updated
Changed in xfce4-power-manager (Ubuntu):
assignee: nobody → Jackson Doak (noskcaj)
Colin Watson (cjwatson) on 2014-07-17
tags: added: verification-needed
Scaramanga (scaramanga) on 2014-07-18
tags: added: verification-done
removed: verification-needed
tags: added: verification-failed
removed: verification-done
Adam Conrad (adconrad) on 2014-07-21
Changed in xfce4-power-manager (Ubuntu Trusty):
status: New → Fix Committed
Adam Conrad (adconrad) on 2014-07-21
Changed in xfce4-power-manager (Ubuntu Trusty):
status: Fix Committed → Fix Released
affects: xfce4-power-manager (Ubuntu) → xubuntu-default-settings (Ubuntu)
Changed in xfce4-power-manager (Ubuntu):
status: New → Fix Released
no longer affects: light-locker-settings (Ubuntu)
Changed in light-locker-settings (Ubuntu Trusty):
status: New → Fix Released
no longer affects: xfce4-power-manager (Ubuntu)
Changed in xfce4-power-manager (Ubuntu Trusty):
status: New → Fix Released
tags: removed: verification-failed
Changed in xfce4-power-manager:
importance: Undecided → Unknown
status: New → Unknown
Changed in xfce4-power-manager:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in xfce4-power-manager:
status: Confirmed → Fix Released
162 comments hidden view all 242 comments
londumas (helion331990) wrote :

I meant Ubuntu Utopic

inode77 (simon-gerber) wrote :

Having the same issue here on Lenovo T420s with Xubuntu 14.10.
After closing the lid or sleep upon resume the lock screen is displayed as intended.
After having entered the password the screen blanks and stays that way.
Binding xrandr --auto to a shortcut works but is an ugly workaround.

Is there no possability to fix or automate the workaround and having a working resume process?

Packages used:
nvidia-331:
  Installed: 331.89-0ubuntu5
xfce4-power-manager:
  Installed: 1.4.1-0ubuntu1
lightdm:
  Installed: 1.12.1-0ubuntu1
light-locker:
  Installed: 1.4.0-0ubuntu1

Lawrence Ong (lawrence-ong) wrote :

If executing "xrandr --auto" works, the following script will automate the process:

Add a file, say "00_screen", in

/etc/pm/sleep.d/

with the following content:

######################
#!/bin/bash
case "$1" in
    thaw|resume)
        sleep 5
        sudo -u lolc env DISPLAY=:0 /usr/bin/xrandr --auto
        ;;
    *)
        ;;
esac
#######################

Make the file 00_screen executable, i.e., "chmod +x 00_screen".

bmaupin (bmaupin) wrote :

1. This bug is not fixed. I'm running a fully updated Xubuntu 14.04.1 and just ran into this bug today.

2. The fix here is only temporary:
https://bugs.launchpad.net/ubuntu/+source/xubuntu-default-settings/+bug/1303736/comments/152

I followed the steps, and the problem went away for a week or so then came back.

3. The scope of this bug is too small. I am neither on a laptop nor am I suspending. I'm encountering this exact same issue on a desktop after manually locking the screen.

I filed a separate bug report since as per the above comment and many others, I'm sure I'm only going to be told I'm not experiencing the same bug. Be that as it may, I am experiencing the same symptoms:

https://bugs.launchpad.net/ubuntu/+source/light-locker-settings/+bug/1389278

In the meantime, I think the only permanent fix is uninstalling light-locker:

https://bugs.launchpad.net/ubuntu/+source/xubuntu-default-settings/+bug/1303736/comments/53

J G Rennison (j-g-rennison) wrote :

I just ran into this after resuming from hibernate.
As a workaround, sending a SIGTERM to the lightdm children other than the one which is your actual session seems to resolve the issue. Presumably one of these is the lock screen session; killing it leads to it being re-spawned, at which the point the screen is restored to a sensible state and the lock screen appears, without needing to kill all the running applications. This can be done from the terminal with sudo/root.

MichiGreat (michi20091979) wrote :

I just ran into this bug again. Even blindly typing in the password didn't bring my screen back. I could get my screen back by switching to vt1 and killing "light-locker". Finding the right PID is convenient with "pgrep -l light-locker".

Linus Drumbler (ldrumbler) wrote :

Having applied all the recommended fixes and reset my settings to the defaults, I can now resume after suspend, but the screen is black, and I must type in my password blindly. I guess it'll have to be xscreensaver for me.

Linus Drumbler (ldrumbler) wrote :

Not even xscreensaver works on my Asus K751. It allows me to resume (without a password, I should note), but the system is left in a broken state. I cannot click on many parts of XFCE (such as the panel or the settings menu) and can only use keyboard shortcuts and the terminal.

Linus,

I occasionally see the "my mouse doesn't work" problem, and it is cured by a VT switch (CTRL+ALT+F1 then CTRL+ALT+F7). That seems to kick the mouse in the head.

Linus Drumbler (ldrumbler) wrote :

These tips worked for me on my previous computer: http://trisquel.info/en/wiki/troubleshooting-suspendhibernate They didn't work on my current one, but I hope they help others.

meolic (meolic) wrote :

I have the problem with "Xfce4 Power Manager does not restore screen power" on Intel NUC mini-system. My solution is based on other suggestions:
1. press CTRL+ALT+F1 to go to the console and login
2. sleep 10; xrandr --auto --display :0.0
3. press CTRL+ALT+F7 to go back to X screen
4. wait 10s and the picture appears

Robert

JJR (jjroblarn) wrote :

Fresh install of Xubuntu 14.04.1 64 bit on a Toshiba Satellite Pro U300 still suffers from this bug, so it seems that this bug hasn't actually been fixed in this point release, as stated.

I was previously using Ubuntu 14.04.1 64 bit (with Unity) on the same machine without problems.

I tried most (all?) of the solutions above and the only one that worked for me was to blindly run "xrandr --auto" when I get the blank screen.

Andreas Siegert (afx) wrote :

Yup, still present on my T520 running a fully updated 14.04 with Nvidia drivers.

Hell Pé (hellpe) wrote :

I was suffering from this bug while using Xubuntu 14.04 on my Asus EeePC 1015T. After a 14.10 fresh install, I'm still having this issue.

Gsus (jeguiluz) wrote :

The #205 workaround works for me, and is the most simple.

I'm using Mint 17 (Qiana) with Xfce 4.11.1

Jan (jankanis) wrote :

Upgraded my Asus EeePC to 14.10 (from 13.10) and I now also have this problem. Workaround of binding xrandr --auto to a hotkey works, but automating that according to comment 205 does not for me. I also tried automating it by creating an event handler in /etc/acpi/events/ but that also failed.

Lawrence Ong (lawrence-ong) wrote :

Jan, did you change the user name in the script to your own?

Jan (jankanis) wrote :

@Lawrence Yes, I did.
Enabling the /etc/pm/sleep.d/ script makes my desktop flash for a moment after I unlock my screen, and then I'm thrown back to the unlock screen and I have to log in again. The second time nothing happens and I have to unblank my screen using the hotkey. It also happend that my laptop suspended again after I logged in, but I can't reproduce that now.

The /etc/acpi/events script works more or less, but the timeout starts counting the moment I open the lid, so if I type my password within the 5 second timeout it works but if I am not fast enough it doesn't. I could enlagre the timeout but then I would have to wait longer if I do log in quicker.

After trying unsuccessfully to use all the fixes I found online, I finally managed it to fix this problem myself today:

1. Install Gnome Screensaver
    sudo apt-get install gnome-screensaver
2. Replace Light Locker with Gnome Screen Saver
    Do it first for all new users
    sudo vi /etc/xdg/autostart/light-locker.desktop
    Change the line from:
         Exec=light-locker
     to:
         Exec=gnome-screensaver
   and then do the same for every existing user
   su <username>
   vi ~/.config/autostart/light-locker.desktop
3. Hide light-locker-settings from menu for all users
   sudo vi /usr/share/applications/light-locker-settings.desktop
   Add the line:
   Hidden=true

Hope that helps everyone affected by his bug until Light Locker is actually production ready enough to warrant it's place in a LTS release.

no longer affects: light-locker-settings (Ubuntu Trusty)
no longer affects: xfce4-power-manager (Ubuntu Trusty)
Changed in xfce4-power-manager (Ubuntu):
status: New → Fix Released

Does this newly released fix solve the issue? I've since given up on Xubuntu because of that, but I would love to go back if it's solved.

I still experience this with 14.10 32bit Xubuntu (fresh install, all packages up to date) on Dell Insiron 9300 laptop.
The xrandr command bound to shortcut workaround works.

Michael Wyraz (michael-wyraz) wrote :

It seems that the fix is likely to have regressions:

- Fresh install of XUbuntu 14.04.2 on an Acer TravelMate-8371
- > Lid close, Lid open, Wakeup by keypress, Login -> works fine

- Enable hibernate-after-suspend (using method 1 from http://www.webupd8.org/2012/11/how-to-use-hybrid-suspend-in-ubuntu.html)
- > Lid close, Lid open, Wakeup by keypress, Login -> Screen remains black

- removing /etc/pm/config.d/00-use-suspend-hybrid
- > Lid close, Lid open, Wakeup by keypress, Login -> again works /fine

- Installing xfce 4.12 from PPA
- > Lid close, Lid open, Wakeup by keypress, Login -> Screen remains black

Unfortunately I could not find out in this issue what exactly was changed (there's only a "fixed" comment). So I cannot check what must be done to make the fix work for the situations above.

jss (jsantossilva) wrote :

I too felt a regression today after installing xfce 4.12 from the PPA over xubuntu 14.04, on a macbook pro 8.2.

Everything was working fine before the installation, including suspend by closing the lid.
Now, suspend and wakeup by menu work, but closing the lid the screen is black after wakeup. The machine is working though.
Enabling or disabling light-locker doesn't have any effect on the problem, although the login screen is activated when enabled.
I think I can see the "shadow" of the login screen which might indicate this is a display backlight problem.

I'm now constrained to use menu suspend only but configured a shortcut "xrandr --auto" just in case I forget and close the lid, which works, by the way, although I have to go to vt1 and back to vt7, as someone suggested, to get the mouse cursor back.

I would be really happy if this got fixed. TIA.

Vegard (skvate) wrote :

Same problem with Xubuntu 14.10. Suddenly backlight control keys stopped working, and resume when lid is opened only shows black screen. I can get to vt1 and it works normally, but when i go back to vt7 it is still black screen. I will try the xrandr --auto as workaround.

information type: Public → Public Security
information type: Public Security → Public
Asmodehn (asmodehn) wrote :

I recently experienced the same problem after an update done a few days ago.

I am running Xubuntu 14.04.2 LTS and I had the same issue. https://bugs.launchpad.net/ubuntu/+source/xfce4-power-manager/+bug/1259339/comments/30 seems to have fixed the problem...

Rishabh (rishabh1351995) on 2015-05-16
Changed in xfce4-power-manager (Ubuntu):
assignee: nobody → Rishabh (rishabh1351995)
Changed in xfce4-power-manager (Ubuntu):
assignee: Rishabh (rishabh1351995) → nobody
Tomáš Karger (tomak) wrote :

This bug also affects me on a fresh install of xubuntu 15.04. Suspend works as expected when I do it via menu, but when I close the lid and open it, I get a password prompt with a default wallpaper in the background. After I type in my password and hit enter, the screen goes blank. Also, the fix proposed on the official website does not work here:

http://xubuntu.org/news/laptop-users-fix-available-for-the-black-screen-on-unlock-bug/

This is on Dell XPS M1330 with Nvidia graphics handled via the nouveau driver. However, suspend works as expected with this setup on both Ubuntu GNOME 15.04 or Ubuntu 14.04.

Luke Schlather (luke2760) wrote :

Can someone remove the "fix released" tag? It looks like XFCE punted to Red Hat's bug tracker on the assumption that the issue is distro-specific, which seems wrong and like the bug should be reopened upstream, since as near as I can tell nobody has a fix, or even understands the issue.

max (neverov-max) wrote :

#205, #221 didn't work for me.
Freshly installed Ubuntu 15.10, lenovo w510.
Change from nouveau to NVIDIA binary driver v 340.96 from nvidia-340(proprietary, tested) works.

nobody (tuimonen) wrote :

#230 worked for me

Fresh install of Linux Mint 17.3 Xfce, Dell Latitude E6500

nobody (tuimonen) wrote :

Without nvidia drivers, when on the tty1, I get these when lid is closed:

xfsettingsd-WARNING **: No available CRTC for LVDS-1
xfsettingsd-WARNING **: No available CRTC for LVDS-1
xfsettingsd-WARNING **: Failed to configure CRTC 95
xfsettingsd-WARNING **: Failed to configure CRTC 96

stcqu (stcqu) wrote :

#227 Worked for me on Xubuntu 14.04.4 LTS

Piotr Admin (piotr-wroclaw) wrote :

This solution works on my laptop (ubuntu 16.04, but should work on previous OS):
open as root file
/etc/UPower/UPower.conf
and change IgnoreLid=false ==> IgnoreLid=true
save changes, restart system and now it works :-)
You can remove light-locker now.

You can use bash for these:
sudo sed -i -e 's/IgnoreLid=false/IgnoreLid=true/g' /etc/UPower/UPower.conf
sudo apt-get remove --purge -y light-locker light-locker-settings
and restart system now

Dave Mitchell (reset3x) wrote :

Dell Inspiron E1505 with Xubuntu 16.04-LTS. The above (#234) did not work for me. First time closing and opening the lid, two instances of display settings popped up. The second attempt I got a black screen again and had to reboot using TTY2 and blindly logging on and doing [sudo reboot now]. Reinstalled light-locker and changed IgnoreLid=true back to false in Upower.conf. Still doing the same as #17. Still no fix?

PeppeKorg (peppekorg) wrote :

Still seeing it with Xubuntu 16.10:

Preconditions:
Xfce4-power-manager->Security->Automatically lock the session: When the screen sever is activated
Xfce4-power-manager->General-> Laptop Lid -> When laptop lid is closed: switch off display.

Actions:
1. Close laptop lid
2. Open laptop
Observed:
1. Laptop goes to suspend (should not go into suspend)
2. Lock screen shown: making login system ends up in a black screen (should resume normally)

Occurrence: systematic

Recovery to black screen:
1. reboot
2. kill xorg process (from tty1)

Is there a fix?

Podesta (podesta) wrote :

Reporting the exact same problem as @PepeKong on #236. Quoting:

-----------
Preconditions:
Xfce4-power-manager->Security->Automatically lock the session: When the screen sever is activated
Xfce4-power-manager->General-> Laptop Lid -> When laptop lid is closed: switch off display.

Actions:
1. Close laptop lid
2. Open laptop
Observed:
1. Laptop goes to suspend (should not go into suspend)
2. Lock screen shown: making login system ends up in a black screen (should resume normally)

Occurrence: systematic

Recovery to black screen:
1. reboot
2. kill xorg process (from tty1)
---------------

Tried the solution for the close lid into sleep posted over at bug #1307545: xfconf-query -c xfce4-power-manager -p /xfce4-power-manager/logind-handle-lid-switch -n -t bool -s false
Doesn't work. Tried manually editing ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-power-manager.xml the value of logind-handle-lid-switch from "empty" to type="bool" value="false" also doesn't work. The value keeps reverting back to "empty".

The only workaround that is much less annoying than having to reboot the system every single time that I close the lid is changing the settings on the power manager of the "laptop lid" from "switch off display" to "lock scree". That will force you to retype password, but will not cause the black screen problem that suspend does, forcing into reboot.

Simeon Ackermann (amseon) wrote :

From blank screen I can reload my session with Ctr+Alt+Backspace. Its just faster than rebooting an bring me to the normal login screen.

Hélio Nunes (dedalu-dedalu) wrote :

After years without suffering this bug, it is back in my Ubuntu Studio 16.04, kernel 4.13.0-32, nvidia 340-104, xfce4-power-manager 1.4.4 and light-locker 1.7.0.

I see the login window, but after the unlock the screen goes black. All keys work, even the backlight up and down Fn keys (I can see changes in backlight), but nothing is displayed.

If I open a terminal and type (blind) "xrandr --auto" everything comes back.

I'm using the same workaround I used years ago, assign a keyboard shortcut to "xrandr --auto", but this must be fixed...

Thanks.

Tipi Koivisto (tipit) wrote :

I also got this bug again after upgrading from 17.04 to 17.10. And it is definitely NVIDIA related so I wrote an issue also here: https://devtalk.nvidia.com/default/topic/1029413/linux/blanc-screen-after-suspend-on-ubuntu-17-10-nvidia-390-12-driver/

apjjr (alex-ourwoods) wrote :

This happened on my Toshiba Satellite C55 running Ubuntu 16.04 LTS after the last update. I ran "xrandr --auto" once after finally getting into the GUI by booting into maintenance mode and resuming normal boot. It seems to have fixed the problem for the time being. I can close the lid for sleep mode and upon opening the lid, the screen comes back with the login prompt, even after a power down. I am mystified.

Happened the same bug today after installing Xubuntu. Helped #221 + #234.

Displaying first 40 and last 40 comments. View all 242 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.