Xubuntu|Mythbuntu|UbuntuStudio installers have debian background wallpaper

Bug #1284910 reported by ToZ on 2014-02-26
50
This bug affects 11 people
Affects Status Importance Assigned to Milestone
mythbuntu-live-autostart (Ubuntu)
Undecided
Unassigned
ubuntustudio-default-settings (Ubuntu)
High
Dimitri John Ledkov
xubuntu-default-settings (Ubuntu)
Critical
Dimitri John Ledkov

Bug Description

When installing Xubuntu 14.04 Beta 1, the ubiquity background is a wallpaper with the debian logo.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: ubiquity (not installed)
ProcVersionSignature: Ubuntu 3.13.0-12.32-generic 3.13.4
Uname: Linux 3.13.0-12-generic i686
ApportVersion: 2.13.2-0ubuntu5
Architecture: i386
CurrentDesktop: XFCE
Date: Tue Feb 25 20:09:50 2014
InstallCmdLine: file=/cdrom/preseed/xubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
InstallationDate: Installed on 2014-02-26 (0 days ago)
InstallationMedia: Xubuntu 14.04 LTS "Trusty Tahr" - Alpha i386 (20140225)
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

ToZ (toz) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1284910

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Elizabeth K. Joseph (lyz) wrote :

I saw this too. I will also note that if I go into "Try Xubuntu" the background is what I expect (no Debian swirl background).

Elfy (elfy) wrote :

I didn't see this yesterday following the testcase - ie using Try Xubuntu and then installing.

Installing directly today - saw the debian wallpaper.

Elizabeth K. Joseph (lyz) wrote :

It pops up on the screen where you select Try or Install, so following the testcase you should see it at least on that screen before going into the Live session. See attached, I moved the dialog out of the way to show the background.

Changed in ubiquity (Ubuntu):
importance: Undecided → High
tags: added: xubuntu
cpatrick08 (cpatrick08) wrote :

still present on try or install xubuntu screen on xubuntu i386 daily 20140201

Jane Atkinson (irihapeti) wrote :

Still present in install xubuntu screen in beta 2

summary: - Xubuntu Beta 1 installer has debian background wallpaper
+ Xubuntu Beta 1 and Beta 2 installer has debian background wallpaper
Pasi Lallinaho (knome) on 2014-03-29
Changed in ubiquity (Ubuntu):
importance: High → Critical

Most likely a bug in ubiquity-dm w.r.t. how the background is selected/painted.

Changed in ubiquity (Ubuntu):
assignee: nobody → Dimitri John Ledkov (xnox)
Simon Steinbeiß (ochosi) wrote :

So would you say this is related to the changes in rev 6044?
(I'm guessing that this issue affects ubuntu-studio and lubuntu as well.)

affects: ubiquity (Ubuntu) → xubuntu-default-settings (Ubuntu)
Changed in xubuntu-default-settings (Ubuntu):
status: Confirmed → Fix Committed
summary: - Xubuntu Beta 1 and Beta 2 installer has debian background wallpaper
+ Xubuntu|Mythbuntu has debian background wallpaper
summary: - Xubuntu|Mythbuntu has debian background wallpaper
+ Xubuntu|Mythbuntu installers have debian background wallpaper
summary: - Xubuntu|Mythbuntu installers have debian background wallpaper
+ Xubuntu|Mythbuntu|UbuntuStudio installers have debian background
+ wallpaper
Changed in ubuntustudio-default-settings (Ubuntu):
status: New → Fix Committed
importance: Undecided → High
assignee: nobody → Dimitri John Ledkov (xnox)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xubuntu-default-settings - 14.04.4

---------------
xubuntu-default-settings (14.04.4) trusty; urgency=medium

  * Set default wallpaper key for gsettings based applications, e.g. such
    that ubiquity installer paints correct background. (LP: #1284910)
 -- Dimitri John Ledkov <email address hidden> Wed, 09 Apr 2014 16:10:38 +0100

Changed in xubuntu-default-settings (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntustudio-default-settings - 0.54

---------------
ubuntustudio-default-settings (0.54) trusty; urgency=medium

  * Set default wallpaper key for gsettings based applications, e.g.
    such that ubiquity installer paints correct background. (LP:
    #1284910)
 -- Dimitri John Ledkov <email address hidden> Wed, 09 Apr 2014 17:20:30 +0100

Changed in ubuntustudio-default-settings (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

affects: mythbuntu-default-settings (Ubuntu) → mythbuntu-live-autostart (Ubuntu)
Changed in mythbuntu-live-autostart (Ubuntu):
status: New → Fix Released
Changed in mythbuntu-live-autostart (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints