non existing key specified in override file

Bug #1227637 reported by Thaddaeus Tintenfisch on 2013-09-19
62
This bug affects 13 people
Affects Status Importance Assigned to Milestone
ubuntustudio-default-settings (Ubuntu)
Low
Unassigned
xubuntu-default-settings (Ubuntu)
Low
Unassigned

Bug Description

This warning appears while installing/updating packages:

"No such key 'auto-launch' in schema 'com.ubuntu.update-notifier' as specified in override file '/usr/share/glib-2.0/schemas/20_xubuntu-default-settings.gschema.override'; ignoring override for this key."

$ apt-cache policy xubuntu-default-settings
xubuntu-default-settings:
  Installed: 13.10.4
  Candidate: 13.10.4
  Version table:
 *** 13.10.4 0
        500 http://de.archive.ubuntu.com/ubuntu/ saucy/universe amd64 Packages
        100 /var/lib/dpkg/status

$ apt-cache policy update-notifier
update-notifier:
  Installed: 0.145
  Candidate: 0.145
  Version table:
 *** 0.145 0
        500 http://de.archive.ubuntu.com/ubuntu/ saucy/main amd64 Packages
        100 /var/lib/dpkg/status

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xubuntu-default-settings (Ubuntu):
status: New → Confirmed
Elfy (elfy) wrote :

hob@hob:~$ sudo apt-get install --reinstall xubuntu-default-settings
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
Need to get 0 B/20.8 kB of archives.
After this operation, 0 B of additional disk space will be used.
(Reading database ... 199729 files and directories currently installed.)
Preparing to replace xubuntu-default-settings 13.10.5 (using .../xubuntu-default-settings_13.10.5_all.deb) ...
Unpacking replacement xubuntu-default-settings ...
Processing triggers for libglib2.0-0:amd64 ...
No such key 'auto-launch' in schema 'com.ubuntu.update-notifier' as specified in override file '/usr/share/glib-2.0/schemas/20_xubuntu-default-settings.gschema.override'; ignoring override for this key.
Processing triggers for libglib2.0-0:i386 ...
No such key 'auto-launch' in schema 'com.ubuntu.update-notifier' as specified in override file '/usr/share/glib-2.0/schemas/20_xubuntu-default-settings.gschema.override'; ignoring override for this key.
Processing triggers for gconf2 ...
Setting up xubuntu-default-settings (13.10.5) ...

seeing the same here

Pasi Lallinaho (knome) on 2013-09-23
Changed in xubuntu-default-settings (Ubuntu):
importance: Undecided → Low

"Remove auto-launch key in the gsettings schema as update-manager has been updated"

https://launchpad.net/ubuntu/+source/update-notifier/0.138

Pasi Lallinaho (knome) on 2013-09-23
Changed in xubuntu-default-settings (Ubuntu):
status: Confirmed → Triaged
shadowwraith (tcmitchell957) wrote :

No such key 'auto-launch' in schema 'com.ubuntu.update-notifier' as specified in override file '/usr/share/glib-2.0/schemas/20_ubuntustudio-default-settings.gschema.override'; ignoring override for this key.

Seeing the same here on ubuntu studio

tags: added: trusty
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntustudio-default-settings (Ubuntu):
status: New → Confirmed
Erazor84 (erazor84) on 2013-12-12
Changed in xubuntu-default-settings (Ubuntu):
assignee: nobody → Erazor84 (erazor84)
assignee: Erazor84 (erazor84) → nobody
Damien (takahara) wrote :

Removing the offending file:

/usr/share/glib-2.0/schemas/20_xubuntu-default-settings.gschema.override

solves the problem. Yeah, I know it's not a real solution ;-)

Changed in ubuntustudio-default-settings (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xubuntu-default-settings - 14.04.1

---------------
xubuntu-default-settings (14.04.1) trusty; urgency=medium

  * defaults.list - Use parole for mpegurl mimetype (lp: #1221426)
  * xubuntu-default-settings.gsettings-override - Remove unsupported key (lp: #1227637)
  * debian/control - Update standards version to 3.9.4
  * debian/copyright - Update to latest format specification
  * debian/xubuntu-live-settings.install
  * debian/light-locker.desktop
    - Prevent autostart of light-locker in live session (see LP: #1281323)
 -- Sean Davis <email address hidden> Tue, 18 Feb 2014 22:42:17 -0500

Changed in xubuntu-default-settings (Ubuntu):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntustudio-default-settings - 0.60

---------------
ubuntustudio-default-settings (0.60) xenial; urgency=medium

  [ Krytarik Raido ]
  * Sync settings with Xubuntu as appropriate (LP: #1227637)

  [ Kaj Ailomaa ]
  * Pointing default wallpaper to the newly created link "ubuntustudio-default.png",
    so that changing wallpapers can be done directly from ubuntustudio-look

 -- Kaj Ailomaa <email address hidden> Mon, 11 Apr 2016 17:22:09 +0200

Changed in ubuntustudio-default-settings (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers