mkinitramfs blows up on casper dependency

Bug #1211933 reported by Jay Carlson on 2013-08-13
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ubuntustudio-live (Ubuntu)
Undecided
Kaj Ailomaa
xubuntu-default-settings (Ubuntu)
Undecided
Unassigned

Bug Description

When running uck-remaster to rebuild the xubuntu livecd, mkinitramfs blows up because 48xubuntu_maybe_ubiquity can't source /scripts/casper-functions. But this is the only script which fails.

I believe these scripts are designed to run outside the initrd environment when called with the "prereq" parameter.

The attached patch moves ". /scripts/casper-functions" below the prereq argument handling like the other scripts.

Bug found in binary package xubuntu-live-settings_12.04.11 from source package xubuntu-default-settings_12.04.11. The bug seems likely to be present in intermediate releases and HEAD.

DistroRelease: Ubuntu 12.04
Package: xubuntu-live-settings 12.04.11
SourcePackage: xubuntu-default-settings

Jay Carlson (nop-nop) wrote :

The attachment "move casper dependency below prereq handling" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Andrew Bloxom (abloxom) wrote :

For clarity, this is the error message that appears during execution of update-initramfs:

/tmp/mkinitramfs_TubQhv/scripts/casper-bottom/48xubuntu_maybe_ubiquity: 6: .: Can't open /scripts/casper-functions

However insignificant, the error message appearing is disconcerting when it's during an important process like building of the initramfs.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xubuntu-default-settings (Ubuntu):
status: New → Confirmed
Jay Carlson (nop-nop) wrote :

I haven't looked at this in a bit, but I am pretty certain the result I experienced was more than just a diagnostic message at the time of filing. This blew up uck-remaster.

uck-remaster is a hack and I don't expect it to be supported. However, the ordering in 48xubuntu_maybe_ubiquity (compared to all similar parts) seemed to break an (unwritten?) architectural rule about casper-bottom parts. 48xu looked like it might cause problems for other packages later; I felt I should at least write down what I found. :-)

The rationale for where that hook was created can be found here: https://bugs.launchpad.net/ubuntu/+source/xubuntu-default-settings/+bug/840094

First of all, I'm not familiar with the actual problem. However, we need someone to check if this bug also affects the current LTS release of Ubuntu (14.04). If yes, does the proposed patch fix the bug without breaking anything else?

Changed in xubuntu-default-settings (Ubuntu):
status: Confirmed → Incomplete
Changed in uck:
status: New → Incomplete
Karteum (karteum) wrote :

> we need someone to check if this bug also affects the current LTS release of Ubuntu (14.04)

I am running XUbuntu 14.04 on a Sony VGN-NR11S laptop. I just got the following message when updating :

VGN-NR11S:~$ sudo dpkg-reconfigure initramfs-tools
update-initramfs: deferring update (trigger activated)
Traitement déclenché pour initramfs-tools (0.103ubuntu4.2) ...
update-initramfs: Generating /boot/initrd.img-3.13.0-27-generic
/tmp/mkinitramfs_g4jQfI/scripts/casper-bottom/48xubuntu_maybe_ubiquity: 6: .: Can't open /scripts/casper-functions

Changed in xubuntu-default-settings (Ubuntu):
status: Incomplete → Confirmed
affects: uck → ubuntustudio-live (Ubuntu)
Changed in ubuntustudio-live (Ubuntu):
status: Incomplete → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xubuntu-default-settings - 15.04.1

---------------
xubuntu-default-settings (15.04.1) vivid; urgency=medium

  * Move casper-functions script below prereq (LP: #1211933)
 -- Sean Davis <email address hidden> Wed, 03 Dec 2014 20:20:55 -0500

Changed in xubuntu-default-settings (Ubuntu):
status: Confirmed → Fix Released
Kaj Ailomaa (zequence) on 2015-02-17
Changed in ubuntustudio-live (Ubuntu):
status: Confirmed → Fix Committed
assignee: nobody → Kaj Ailomaa (zequence)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntustudio-live - 1.3

---------------
ubuntustudio-live (1.3) vivid; urgency=medium

  * Move casper-functions script below prereq (LP: #1211933)
 -- Kaj Ailomaa <email address hidden> Tue, 17 Feb 2015 12:28:53 +0100

Changed in ubuntustudio-live (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers