Some Applications menu items are missing icons

Bug #105493 reported by Dmitry Agafonov
32
This bug affects 1 person
Affects Status Importance Assigned to Milestone
epdfview (Ubuntu)
Fix Released
Low
Unassigned
tango-icon-theme (Ubuntu)
Invalid
Undecided
Unassigned
xfburn (Ubuntu)
Fix Released
Low
Unassigned
xfce4-session (Ubuntu)
Fix Released
Low
Unassigned
xfce4-taskmanager (Ubuntu)
Fix Released
Low
Lionel Le Folgoc
xubuntu-default-settings (Ubuntu)
Invalid
Undecided
Unassigned

Bug Description

Binary package hint: xubuntu-default-settings

After default installation some menu items do not contain icons. Looks not good...
http://agafonov.pp.ru/bugz/NoMenuIcons.jpg

Revision history for this message
Gauvain Pocentek (gpocentek) wrote :

Each application which lacks an icon needs to have it's .desktop file fixed.

Changed in xubuntu-default-settings:
status: Unconfirmed → Confirmed
Revision history for this message
Lionel Le Folgoc (mrpouit) wrote :

Trying to guess affected packages.
About the missing icon for the "About Xfce" dialog, it seems tango-icon-theme is missing an icon named gnome-info.

Changed in xubuntu-default-settings:
status: Confirmed → Rejected
Changed in xfburn:
status: Unconfirmed → Confirmed
Revision history for this message
Lionel Le Folgoc (mrpouit) wrote :

For xfce4-session, this is already reported in Bug #58251.

Changed in xfce4-session:
importance: Undecided → Low
status: New → Triaged
Changed in xfburn:
importance: Undecided → Low
status: Confirmed → Triaged
Changed in xfce4-taskmanager:
importance: Undecided → Low
status: New → Triaged
Revision history for this message
Lionel Le Folgoc (mrpouit) wrote :

xfce4-session (4.4.1-1ubuntu3) gutsy; urgency=low

  * debian/pixmaps/xfce4-autostart-editor.png.uue, debian/rules: add a menu
    icon (from Jozsef Mak) for the autostart-editor. (LP: #58251,#105493)

 -- Lionel Le Folgoc <email address hidden> Thu, 06 Sep 2007 10:56:27 +0200

Changed in xfce4-session:
status: Triaged → Fix Released
description: updated
Revision history for this message
Jani Monoses (jani) wrote :

some of these are fixed in gutsy
for the others please open a bug on the specific package not default settings or the icon theme

Changed in tango-icon-theme:
status: New → Invalid
Changed in xfce4-taskmanager:
assignee: nobody → mrpouit
status: Triaged → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfce4-taskmanager - 0.4.0~rc2really0.3.2-0ubuntu1

---------------
xfce4-taskmanager (0.4.0~rc2really0.3.2-0ubuntu1) hardy; urgency=low

  * New upstream release; fixes units displaying issues. (LP: #85660)
  * Try to get out of this versioning mess.
  * debian/xfce4-taskmanager.desktop: specify an icon. (LP: #105493)
  * debian/compat: bump to 5.
  * debian/control:
    - update Maintainer
    - b-d on debhelper (>=5)
    - use the correct Homepage

 -- Lionel Le Folgoc <email address hidden> Sun, 20 Jan 2008 20:07:20 +0100

Changed in xfce4-taskmanager:
status: In Progress → Fix Released
Revision history for this message
Jérôme Guelfucci (jerome-guelfucci-deactivatedaccount) wrote :

xfburn now has an icon in trunk, this will be fixed in the future 0.3.0.

Changed in xfburn:
status: Triaged → Fix Committed
Revision history for this message
Lionel Le Folgoc (mrpouit) wrote :

It'll be fixed when xfburn 0.3.0 is synced from debian unstable (Bug #240061)

Changed in xfburn:
status: Fix Committed → Triaged
Changed in xfburn:
status: Triaged → Fix Released
Revision history for this message
Matthias Mailänder (mailaender) wrote :

The education icon is also missing. It just shows the red X. I tried all installed icon themes: Human, Tango, GNOME, GNOME-Brave, Rodent. There is always the no icon placeholder shown.

Revision history for this message
Matthias Mailänder (mailaender) wrote :

The missing education icon has it's own Bug #392290.

Revision history for this message
Matthias Mailänder (mailaender) wrote :

There is also a missing application icon for ePDFviewer in Xfce menu in Ubuntu 9.04 Jaunty Jackelope.

/usr/share/applications/epdfview.desktop

in line 11 it says "Icon=postscript-viewer.png"

I found epdfview.xpm in /usr/share/pixmaps as a replacement and there are some PNG icons in the project trunk: http://trac.emma-soft.com/epdfview/browser/trunk/data

Revision history for this message
Charlie Kravetz (charlie-tca) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find. This missing icon in ePDFviewer has been fixed in ePDFview version 0.1.7-2 included in Xubuntu 9.10. The icon can be found in /usr/share/epdfview/pixmaps/icon_epdfview-48.png.

I am closing it because the bug has been fixed in the latest stable version of Xubuntu - Karmic Koala 9.10. It won't be fixed in previous versions of Ubuntu because the package doesn't fit the requirements for backporting. See https://help.ubuntu.com/community/UbuntuBackports for more information.

Changed in epdfview (Ubuntu):
status: New → Fix Released
importance: Undecided → Low
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers