xubutnu-plymouth-theme "post-installation script" returns an error and exit status 127 on every package operation. (Prevents uninstalling that package)

Bug #549699 reported by Ian Mitchell
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xubuntu-artwork (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: xubuntu-plymouth-theme

Ubuntu Version: 10.04 Beta 1 (Lucid Lynx)
Package: xubuntu-plymouth-theme version 10.04.3

Expected Behavior: Smooth installation
Actual Behavior: Throwing errors on every package manager use, refusing to be either fixed or uninstalled, basically behaving poorly.
Description: On any package operation (installation, uninstallation, upgrading, etc.) a "post-installation script" installed by a subprocess (of apt-get, I'm assuming) will fail to run due to an error, returning an error code 127. Unfortunately, this is not a particularly descriptive error code, and this error appears to prevent either reinstalling or uninstalling the package.
Attempted Fixes: Reinstallation (whether via Synaptic or apt-get) failed; on Synaptic due to the primary bug, on apt-get due to being unable to lock /var/cache/apt/archives/lock. Uninstallation failed whether via Synaptic or apt-get for the same reasons. Purging via dpkg (as recommended on the wiki page) also failed, due to the primary bug.

Reproduction: Install xubutnu-artwork on 9.10. Upgrade to 10.04. Installation of xubuntu-plymouth-theme should fail with same error during the upgrade process. If any other package operations are undertaken afterwards, should encounter same error at end.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: xubuntu-plymouth-theme 10.04.3
ProcVersionSignature: Ubuntu 2.6.32-17.26-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-17-generic x86_64
Architecture: amd64
Date: Sat Mar 27 11:31:36 2010
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/zsh
SourcePackage: xubuntu-artwork

Revision history for this message
Ian Mitchell (thdoe45) wrote :
Revision history for this message
Lionel Le Folgoc (mrpouit) wrote :

Thanks for your bug report.

They changed lots of things in plymouth yesterday, that's why it's failing to install/uninstall. We need to update the packaging of our theme.

Changed in xubuntu-artwork (Ubuntu):
importance: Undecided → High
status: New → Triaged
Revision history for this message
Ian Mitchell (thdoe45) wrote :

Further update: Problem appears tide to the single command in the postinstallation script not actually existing, to wit:

/usr/sbin/plymouth-set-default-theme --rebuild-initrd xubuntu-logo

<em>There is no /usr/sbin/plymouth-set-default-theme.</em> (In fact, this has a #FIXME comment just above)

Changed in xubuntu-artwork (Ubuntu):
status: Triaged → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xubuntu-artwork - 10.04.4

---------------
xubuntu-artwork (10.04.4) lucid; urgency=low

  * Port xubuntu-plymouth-theme to the new system using
    update-alternatives. lp: #549699
 -- Lionel Le Folgoc <email address hidden> Sat, 27 Mar 2010 21:38:51 +0100

Changed in xubuntu-artwork (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers