Decryption passphrase prompt not displayed until escape is pressed (Xubuntu hirsute test case)

Bug #1917062 reported by Sai Vinoba
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
plymouth (Ubuntu)
High
Unassigned
xubuntu-artwork (Ubuntu)
Undecided
Unassigned

Bug Description

Release: Xubuntu daily build (20210226 ISO). Testing installation with lvm+encryption (1451)

SW and version: Not sure which package so reporting under cryptsetup. Could be plymouth?

Expected: After a successful install with lvm+encryption, decryption prompt should be displayed during boot to enter passphrase.

Actual: No prompt is displayed. If we hit 'Escape', text prompt is displayed and hitting 'Escape' again shows graphical prompt. This is main issue.

Secondary issue with UX.
a) on text prompt there is no space after the prompt. Not even colon.
b) on graphical prompt no box is provided so user is confused where to click mouse button (unless it is just my (wrong) assumption, most people click on text input area first before start typing). Also either the hidden box is wrongly aligned or too large so that typed passphrase is not center-aligned below prompt text.

Screenshots attached.

Revision history for this message
Sai Vinoba (saivinob) wrote :

Makes a good wallpaper :p

Revision history for this message
Sai Vinoba (saivinob) wrote :

text prompt after hitting escape.

Revision history for this message
Sai Vinoba (saivinob) wrote :

graphical prompt after hitting escape second time.

Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1917062

tags: added: iso-testing
tags: added: hirsute xubuntu
Revision history for this message
Yousuf 'Jay' Philips (philipz85) wrote :

The problem maybe that the field is black and the xubuntu background is also black.

Revision history for this message
Sai Vinoba (saivinob) wrote :

As of 20210331 (Xubuntu) iso, the decryption passphrase screen appears.

However, in that screen it is not clear where the input box is. This is a usability issue. Functionally, typing passphrase and hitting return works as expected.

Attaching screenshots from Xubuntu as well as Ubuntu MATE for reference.

Revision history for this message
Sai Vinoba (saivinob) wrote :

Xubuntu passphrase screen.

Revision history for this message
Sai Vinoba (saivinob) wrote :

Ubuntu MATE passphrase screen for reference.

Revision history for this message
Sean Davis (bluesabre) wrote :

Correcting this should just be a matter of replacing the password dialog image.

https://github.com/Xubuntu/xubuntu-artwork/tree/master/usr/share/plymouth/themes/xubuntu-logo

affects: cryptsetup → xubuntu-artwork
Revision history for this message
Yousuf 'Jay' Philips (philipz85) wrote :
Revision history for this message
Sean Davis (bluesabre) wrote :

I pushed up a new password prompt field.

https://github.com/Xubuntu/xubuntu-artwork/commit/90de999997e46c70b282877ccc9eb744ba6149d3?short_path=df1752b#diff-df1752b6d15e72d87ffb1adfe6e37990c78afcdd56d3d10c6c14202feb0bd621

It will still need to be tested. Can you try replacing your installed /usr/share/plymouth/themes/xubuntu-logo/passw-dialog.png with the above file and see if it works and looks right?

Revision history for this message
Sai Vinoba (saivinob) wrote :

I tried as suggested but still cannot make out input box from the background. Do we simply copy the file over to mentioned folder or anything else needs to be done for plymouth theme to be updated?

Also, as a suggestion please consider changing passphrase box's border color instead of inside (may be blue of plymouth progressbar?).

Revision history for this message
Sai Vinoba (saivinob) wrote :

My apologies. I had not run `sudo update-initramfs -u`. After running it the text box is visible, although the text is top-left aligned whereas it would have been nice if it is vertically center aligned.

Revision history for this message
Sai Vinoba (saivinob) wrote :

text box visible

Revision history for this message
Sai Vinoba (saivinob) wrote :

passphrase box with text

Revision history for this message
Sean Davis (bluesabre) wrote :

Is this still an issue? We pushed up a new xubuntu-artwork package earlier this month.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xubuntu-artwork (Ubuntu):
status: New → Confirmed
Sean Davis (bluesabre)
affects: xubuntu-artwork → xubuntu-artwork (Ubuntu)
Changed in xubuntu-artwork (Ubuntu):
status: New → Incomplete
Revision history for this message
Sean Davis (bluesabre) wrote :

Verified today, absolutely nothing is displayed until a button is pressed, just a black screen.

Changed in xubuntu-artwork (Ubuntu):
status: Incomplete → Confirmed
status: Confirmed → Fix Released
Revision history for this message
Sean Davis (bluesabre) wrote :

The input was improved in xubuntu-artwork (Fix Released), but I'd suspect the all-black screen is plymouth.

Revision history for this message
Sean Davis (bluesabre) wrote :

The same issue (reboot to black screen) is also present on Ubuntu Mate 21.04 daily.

tags: added: ubuntu-mate
Revision history for this message
fossfreedom (fossfreedom) wrote :

Same issue on Ubuntu Budgie

Revision history for this message
Bill (franksmcb) (franksmcb) wrote :

Not seeing this in Ubuntu MATE current daily in QEMU. Will try on bare metal.

Revision history for this message
Bill (franksmcb) (franksmcb) wrote :

Not seeing on Ubuntu MATE on T430

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

The plymouth package hasn't changed in over 5 months so that's probably not the cause. More likely theming or the kernel version.

Revision history for this message
Sai Vinoba (saivinob) wrote :

To test, I installed `plymouth-theme-ubuntu-mate-logo` and switched to it. Issue still exists; passphrase prompt not displayed till we hit 'Esc'.

Revision history for this message
Sean Davis (bluesabre) wrote :

Still seeing this on Xubuntu 20210420. Adding more information on my test environment:

Running in a virtual machine on a Bionic host with packages:
- virt-manager 1:1.5.1-0ubuntu1.2
- qemu-kvm 1:2.11+dfsg-1ubuntu7.36

Revision history for this message
Sebastien Bacher (seb128) wrote :

Thanks, it's confusing that this bug was used to handled some artwork issue and repurposed for another problem now.

Could someone having the issue give details of the configuration used (ISO version, hardware or VM, how the encryption was configured?)

We would also need a journal log from a system just after it had the issue with a mention of the time where the problem happened (to be able to match the log), ideally a debug log as explained on https://wiki.ubuntu.com/Plymouth#Enabling_Debugging

Changed in plymouth (Ubuntu):
importance: Undecided → High
status: New → Incomplete
Revision history for this message
Sean Davis (bluesabre) wrote :

To be fair, the bug was originally about the password prompt not being displayed, with the secondary issue about the artwork.

I enabled Plymouth debugging to try to capture relevant logs, but any time plymouth debugging was enabled, this issue did not present itself. Disabling plymouth debugging returned to the same issue. Maybe it's timing related?

VM configuration:
- Bionic host
- virt-manager 1:1.5.1-0ubuntu1.2
- qemu-kvm 1:2.11+dfsg-1ubuntu7.36
- 16 CPUs allocated, configured as model: EPYC-IBPB
- 4GB ram
- Single 20GB VirtIO disk stored on an SSD
- SATA CDROM where the image is being installed from
- virtio network device, bridged
- Generic PS2 mouse
- Generic PS2 keyboard
- EVTouch USB Graphics Tablet
- Display Spice: Spice server, Address, localhost only, no OpenGL
- Sound ich6
- Serial device 1: pty, /dev/pts/0
- Channel spice: spicevmc, virtio, com.redhat.spice.0
- Video QXL: 16 MiB, 1 head
- Controller PCI 0
- Controller IDE 0
- Controller VirtIO Serial 0
- Controller USB 0, USB 3
- Controller SATA 0
- USB Redirector 1, SpiceVMC
- USB Redirector 2, SpiceVMC

Installation steps:
1. Installing from Xubuntu 20210420 media
2. Click Install Xubuntu
3. Select language and Continue
4. Select Normal installation, Download updates while installing Xubuntu and Continue
5. Select Erase disk and install Xubuntu
6. Click Advanced features...
7. Select Use LVM with the new Xubuntu installation
8. Check Encrypt the new Xubuntu installation for security and OK
9. Click Install Now
10. Enter and confirm a security key and click Install Now. The following popup is displayed:
  The following partitions are going to be formatted:
  LVM VG vgxubuntu, LV root at ext4
  LVM VG vgxubuntu, LV swap_1 as swap
  partition #2 of Virtual disk 1 (vda) as ESP
11. Click Continue
12. Select timezone and Continue
13. Enter user details and Continue
14. Installation completes and device reboots
15. Following post and hidden grub, blank screen until you press Escape.

I also tried this with grub not hidden and with a timeout of 5, and with plymouth not debugging, there is still no visible password prompt.

Without plymouth debugging, is there another log that will suffice?

Revision history for this message
Sean Davis (bluesabre) wrote :

Attaching system journal.

6:54 AM:
- First attempted boot from grub, issue did not present. Rebooted.
- Second attempted boot, issue presented.
6:55 AM:
- Pressed Escape to reveal password prompt and continued to login.

Revision history for this message
Sean Davis (bluesabre) wrote (last edit ):

I'm seeing this issue (nothing displayed until I press Escape) with Xubuntu 20.04.3.

tags: added: focal
Changed in plymouth (Ubuntu):
status: Incomplete → Confirmed
tags: added: rls-ff-incoming
Revision history for this message
William Wilson (jawn-smith) wrote :

I tested this on the regular gnome ubuntu 20.04.3 and did not see the same error.

Revision history for this message
Brian Murray (brian-murray) wrote :

Given William's testing this seems Xubuntu specific and not necessarily and issue with plymouth.

tags: removed: rls-ff-incoming
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers