vpn indicator icon is not appearing

Bug #1796183 reported by Paulius on 2018-10-04
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
elementary-xfce (Ubuntu)
Undecided
Unassigned
Cosmic
Undecided
Unassigned
xubuntu-artwork (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned

Bug Description

When network is connected with wired connection and there is active VPN connection, network icon does not change.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: xubuntu-icon-theme 18.04.5
ProcVersionSignature: Ubuntu 4.15.0-34.37-generic 4.15.18
Uname: Linux 4.15.0-34-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
ApportVersion: 2.20.9-0ubuntu7.4
Architecture: amd64
CurrentDesktop: XFCE
Date: Thu Oct 4 23:09:54 2018
Dependencies:

InstallationDate: Installed on 2018-03-22 (196 days ago)
InstallationMedia: Xubuntu 16.04.4 LTS "Xenial Xerus" - Release amd64 (20180228)
PackageArchitecture: all
SourcePackage: xubuntu-artwork
UpgradeStatus: Upgraded to bionic on 2018-09-05 (29 days ago)

Paulius (peledzius) wrote :
affects: xubuntu-artwork (Ubuntu) → network-manager-applet (Ubuntu)

https://github.com/shimmerproject/elementary-xfce/issues/104

Can you verify that this bug is fixed in 18.10 or by manually adding the missing icon(s) to 18.04?

affects: network-manager-applet (Ubuntu) → xubuntu-artwork (Ubuntu)
Paulius (peledzius) wrote :

I placed missing icons but still same result. Lock symbol is appearing when VPN is in connecting state. BTW I don't have package network-manager-applet installed(E: Unable to locate package network-manager-applet).

The package name is network-manager-gnome, but it listed under network-manager-applet here on launchpad.

It may be necessary to switch to another icon theme and back after adding those four new icon files. Also, a restart of the panel and nm-applet may be required to see any change.

Alternatively, install xubuntu-artwork from this PPA:

https://launchpad.net/~xubuntu-dev/+archive/ubuntu/ppa

Paulius (peledzius) wrote :

Installing xubuntu-artwork package fixed the problem. Thanks :)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xubuntu-artwork (Ubuntu):
status: New → Confirmed
Sean Davis (bluesabre) on 2019-03-31
no longer affects: elementary-xfce (Ubuntu Bionic)
no longer affects: xubuntu-artwork (Ubuntu Cosmic)
Changed in elementary-xfce (Ubuntu Cosmic):
status: New → Fix Released
Changed in elementary-xfce (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.