Mousepad search highlights hard to see

Bug #1508192 reported by Kev Bowring
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xubuntu-artwork (Ubuntu)
Fix Released
Medium
Pasi Lallinaho

Bug Description

In Xubuntu using Mousepad with the default Xubuntu Light colour scheme it is hard to differentiate between the searched term and the rest of the text.

It should show up as

 <!-- Search Matching ?? -->
 <style name="search-match" foreground="white" background="green" />

<color name="green" value="#228822" />
<color name="white" value="#ffffff" />

from http://bazaar.launchpad.net/~xubuntu-art/xubuntu-artwork/wily/view/head:/usr/share/gtksourceview-2.0/styles/xubuntu-light.xml#L45

 from x-dev irc channel "it currently uses "selection" (or at least seems to) instead of using "search-match" "

gedit uses the tags correctly

Furthermore, the currently selected text/search match isn't distinguishable enough.

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: mousepad 0.4.0-2ubuntu1
ProcVersionSignature: Ubuntu 4.2.0-16.19-generic 4.2.3
Uname: Linux 4.2.0-16-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.19.1-0ubuntu3
Architecture: amd64
CurrentDesktop: XFCE
Date: Tue Oct 20 21:43:11 2015
InstallationDate: Installed on 2015-10-01 (19 days ago)
InstallationMedia: Xubuntu 15.10 "Wily Werewolf" - Alpha amd64 (20151001)
SourcePackage: mousepad
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Kev Bowring (flocculant) wrote :
Revision history for this message
Kev Bowring (flocculant) wrote :

adding screenshot of some text with a short 3 letter section highlighted

Pasi Lallinaho (knome)
Changed in mousepad (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Pasi Lallinaho (knome)
Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/1508192

tags: added: package-qa-testing
Revision history for this message
Pasi Lallinaho (knome) wrote :

This indeed looks like a bug/design decision in Mousepad, instead of the theme.

The following URL *might* be useful in finding the fix we need: https://mail.gnome.org/archives/commits-list/2014-October/msg03101.html

Changed in mousepad (Ubuntu):
assignee: Pasi Lallinaho (knome) → nobody
Revision history for this message
Pasi Lallinaho (knome) wrote :

The bug is a combination of two issues:
1) A bug in Mousepad, which makes Mousepad not respect the set "search-match" style; when you highlight all search matches, the background for the highlights is always light yellow
2) An accessibility issue in the color scheme (shipped in xubuntu-artwork) which makes the current search match not distinguishable enough. This can be fixed by changing the generic selection color.

Thus, targetting xubuntu-artwork too (and assigning myself to that one).

Changed in xubuntu-artwork (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Pasi Lallinaho (knome)
description: updated
Changed in xubuntu-artwork (Ubuntu):
status: Confirmed → Fix Committed
Revision history for this message
Kev Bowring (flocculant) wrote :

been using #bbbbbb for a few days now - much better - thanks

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xubuntu-artwork - 15.12.3

---------------
xubuntu-artwork (15.12.3) xenial; urgency=medium

  [ Pasi Lallinaho ]
  * Change the selection color background for a darker one in
    the Xubuntu light themes (LP: #1508192)
    - usr/share/gtksourceview-2.0/styles/xubuntu-light.xml
    - usr/share/xfce4/terminal/colorschemes/xubuntu-light.theme
  * New wallpaper for Xubuntu 16.o4
    - debian/xubuntu-wallpapers.links
    - usr/share/plymouth/themes/xubuntu-logo/wallpaper.png
    - usr/share/xfce4/backdrops/xubuntu-xenial.png

  [ Sean Davis ]
  * Dropped libreoffice-style-elementary from package,
    now packaged from the libreoffice source package.
    - debian/control
    - debian/copyright
    - debian/libreoffice-style-elementary.install
    - libreoffice-style-elementary
    - Makefile

 -- Sean Davis <email address hidden> Wed, 09 Mar 2016 20:53:44 -0500

Changed in xubuntu-artwork (Ubuntu):
status: Fix Committed → Fix Released
Kev Bowring (flocculant)
no longer affects: mousepad (Ubuntu)
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Related blueprints