Comment 0 for bug 96676

Binary package hint: gnome-terminal

After upgrading from Edgy to Feisty, gnome-terminal started to generate "wrong" sequences when pressing Shift/Alt/Ctrl-F1..F4 keys, and some other (like Shift-Arrows). In particular, it generates:

            Shift Alt Ctrl
F1 \EO1;2P \EO1;3P \EO1;5P
F2 \EO1;2Q \EO1;3Q \EO1;5Q
F3 \EO1;2R \EO1;3R \EO1;5R
F4 \EO1;2S \EO1;3S \EO1;5S

while it should:

            Shift Alt Ctrl
F1 \EO2P \EO3P \EO5P
F2 \EO2Q \EO3Q \EO5Q
F3 \EO2R \EO3R \EO5R
F4 \EO2S \EO3S \EO5S

according to the output of the infocmp command (TERM is set to xterm here, by default). The second ("correct") variant of sequences is also exactly what happens in the Edgy installation on another computer.

It looks like 1; gets inserted to the middle of the sequence for these function keys and also in the middle of sequences for combinations like Shift-Up/Down/Left/Right. As a result, it's no more possible to e.g. create a new file using Shift-F4 in Midnight commander, or to select text in its built-in editor using Shift+Arrows.

Btw, the xterm application both in Edgy and Feisty generates sequences from the first table (i.e. with 1; inserted), but I found how to change it by editing xterm resources (/etc/X11/app-defaults/XTerm-color), which didn't influence gnome-terminal though. It also didn't completely restore the normal behavior of Midnight Commander (Shift-F1..F4 started to work but other function keys stopped to work properly). It looks like these problems in xterm and in gnome-terminal have a common root.

Also, I tried to alter the xterm definition in terminfo by replacing sequences from the second table from ones from the first one. It also worked, but again, only for those F1..F4 keys only, and broke recognition of other function keys. Anyway, I don't think that changing the xterm definition is a correct way to go, because what is in terminfo by default is a kind of standard nowadays (at least for common keys and combinations).