Ubuntu

Typing "exit" in xterm kills X session

Reported by vatbier on 2011-05-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xterm (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xterm

I typed "exit" in an xterm window and pressed enter. My X session got killed instantly and I had to relogin.
It happened twice in a row.
Not funny losing all my work in this way.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: xterm 268-1ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,imgpng,place,move,snap,regex,animation,vpswitch,compiztoolbox,mousepoll,resize,session,grid,expo,wall,gnomecompat,ezoom,unitymtgrabhandles,workarounds,fade,switcher,scale,unityshell]
CompositorRunning: compiz
Date: Fri May 6 12:53:16 2011
DistUpgraded: Log time: 2011-05-02 13:53:12.296621
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus:
 vboxhost, 4.0.4, 2.6.35-28-generic, i686: installed
 vboxhost, 4.0.4, 2.6.38-8-generic, i686: installed
GraphicsCard:
 ATI Technologies Inc RV516 [Radeon X1300/X1550 Series] [1002:7183] (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:0d02]
   Subsystem: Dell Device [1028:0d03]
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
MachineType: Dell Inc. OptiPlex 745
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=3c18f17c-c575-4f9b-8f8b-2a252e9b8ca8 ro quiet splash vt.handoff=7
Renderer: Unknown
SourcePackage: xterm
UpgradeStatus: Upgraded to natty on 2011-05-02 (3 days ago)
dmi.bios.date: 05/21/2007
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 2.3.1
dmi.board.name: 0GX297
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 15
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvr2.3.1:bd05/21/2007:svnDellInc.:pnOptiPlex745:pvr:rvnDellInc.:rn0GX297:rvr:cvnDellInc.:ct15:cvr:
dmi.product.name: OptiPlex 745
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.4+bzr20110415-0ubuntu2
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7.1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

vatbier (vatbier) wrote :

On Fri, 6 May 2011, vatbier wrote:

> Public bug reported:
>
> Binary package hint: xterm
>
> I typed "exit" in an xterm window and pressed enter. My X session got killed instantly and I had to relogin.
> It happened twice in a row.

I seem to recall seeing a similar report against gnome-terminal about a
week ago. Perhaps the problem is in the shell, e.g., sending a "kill -1"
for some reason (or even the window manager).

--
Thomas E. Dickey
http://invisible-island.net
ftp://invisible-island.net

Chris Linstid (clinstid) wrote :

I have also been hitting this both in Ubuntu 11.04 and Mint 11. Window manager doesn't seem to matter because it happened in Unity, "Classic" and Fluxbox.

gnome-terminal and rxvt did not exhibit this behavior for me.

Thomas Dickey (dickey-his) wrote :

Can you reproduce the problem if you're not using compiz?

Bryce Harrington (bryce) wrote :

Hey vatbier,

You filed this bug report against natty, but I see it's still open and
doesn't appear to have much activity recently. So, now that oneiric
is released and stable, this may be a good point for you to upgrade
and re-test if this issue is still present there.

If it's solved in the new release and you think it's worth backporting
the fix, please indicate that. Or if having the fix in the new release
is good enough, feel free to close out the bug (or let us know and we'll
close it.)

If it's not solved, leave the bug report open. I can't promise we'll
get to it (we get way more bugs filed than we can usually get to), but
your testing and feedback can help out if and when we do.

Changed in xterm (Ubuntu):
status: New → Incomplete
bugbot (bugbot) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xterm (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.