Xterm fails character sets test in vttest

Bug #230919 reported by Kevin Lamonte on 2008-05-16
4
Affects Status Importance Assigned to Milestone
xterm (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xterm

Xterm version 229 produces two incorrect glyphs in the vttest version 2.7 (20030301) "Test of character sets". Specifically, the British pound symbol is not displayed in place of '#' on the UK / National character set, and the carriage-return character (a drawn CR, Unicode symbol u+240D) in the Special Graphics character set is blank. The British pound symbol is displayed correctly in the Special Graphics character set.

This occurs with LANG=C, LANG=en_US, LANG=en_US.UTF-8 . It also is independent of the font.

$ lsb_release -rd
Description: Ubuntu 8.04
Release: 8.04

Xterm has historically been very accurate with vttest. I am quite surprised to see this.

Thomas Dickey (dickey-his) wrote :

I hadn't noticed the u+240D (will investigate that).

The '#' is a different case - it's due to a check added in the original UTF-8 changes in 1999/04/25,
to prevent xterm from translating Unicode to the National Replacement Characters (like ISO-8859-1).
I'll improve this combination - hadn't had my attention draw to it..

Wouter van Heyst (larstiq) wrote :

According to the changelog for version 236 of xterm, this bug should be fixed in that version. Doesn't seem to be in Debian yet unfortunately.

On Fri, 29 Aug 2008, Wouter van Heyst wrote:

> According to the changelog for version 236 of xterm, this bug should be
> fixed in that version. Doesn't seem to be in Debian yet unfortunately.

yes (I don't recall seeing it updated yet in Debian - checked the
package page and it's not there).

>
> --
> Xterm fails character sets test in vttest
> https://bugs.launchpad.net/bugs/230919
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Thomas E. Dickey
http://invisible-island.net
ftp://invisible-island.net

Julien Cristau (jcristau) wrote :

On Fri, Aug 29, 2008 at 15:47:00 -0000, Thomas Dickey wrote:

> On Fri, 29 Aug 2008, Wouter van Heyst wrote:
>
> > According to the changelog for version 236 of xterm, this bug should be
> > fixed in that version. Doesn't seem to be in Debian yet unfortunately.
>
> yes (I don't recall seeing it updated yet in Debian - checked the
> package page and it's not there).
>
I'll try to get to it soon, but since we're frozen for release at the
moment, this hasn't been a priority.

Cheers,
Julien

Thomas Dickey (dickey-his) wrote :

On Fri, 29 Aug 2008, Julien Cristau wrote:

> On Fri, Aug 29, 2008 at 15:47:00 -0000, Thomas Dickey wrote:
>
>> On Fri, 29 Aug 2008, Wouter van Heyst wrote:
>>
>>> According to the changelog for version 236 of xterm, this bug should be
>>> fixed in that version. Doesn't seem to be in Debian yet unfortunately.
>>
>> yes (I don't recall seeing it updated yet in Debian - checked the
>> package page and it's not there).
>>
> I'll try to get to it soon, but since we're frozen for release at the
> moment, this hasn't been a priority.

hmm (it has been a month, and dialog - more recent - is updated).

thanks

--
Thomas E. Dickey
http://invisible-island.net
ftp://invisible-island.net

Julien Cristau (jcristau) wrote :

On Fri, Aug 29, 2008 at 16:46:40 -0000, Julien Cristau wrote:

> On Fri, Aug 29, 2008 at 15:47:00 -0000, Thomas Dickey wrote:
>
> > On Fri, 29 Aug 2008, Wouter van Heyst wrote:
> >
> > > According to the changelog for version 236 of xterm, this bug should be
> > > fixed in that version. Doesn't seem to be in Debian yet unfortunately.
> >
> > yes (I don't recall seeing it updated yet in Debian - checked the
> > package page and it's not there).
> >
> I'll try to get to it soon, but since we're frozen for release at the
> moment, this hasn't been a priority.
>
Uploaded now, sorry for the delay.

Cheers,
Julien

Thomas Dickey (dickey-his) wrote :

On Tue, 9 Sep 2008, Julien Cristau wrote:

> On Fri, Aug 29, 2008 at 16:46:40 -0000, Julien Cristau wrote:
>
>> On Fri, Aug 29, 2008 at 15:47:00 -0000, Thomas Dickey wrote:
>>
>>> On Fri, 29 Aug 2008, Wouter van Heyst wrote:
>>>
>>>> According to the changelog for version 236 of xterm, this bug should be
>>>> fixed in that version. Doesn't seem to be in Debian yet unfortunately.
>>>
>>> yes (I don't recall seeing it updated yet in Debian - checked the
>>> package page and it's not there).
>>>
>> I'll try to get to it soon, but since we're frozen for release at the
>> moment, this hasn't been a priority.
>>
> Uploaded now, sorry for the delay.

thanks (report bugs)

--
Thomas E. Dickey
http://invisible-island.net
ftp://invisible-island.net

Bryce Harrington (bryce) wrote :

[This is an automated message]

Hi kevin-lamonte,

Please attach the output of `lspci -vvnn`, and attach your /var/log/Xorg.0.log file from after reproducing this issue. If you've made any customizations to your /etc/X11/xorg.conf please attach that as well.

Changed in xterm:
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xterm - 237-1ubuntu1

---------------
xterm (237-1ubuntu1) jaunty; urgency=low

  * Merge from Debian unstable. Remaining Ubuntu changes:
    - Enabled URL hilighting
    - Maintainer field
    - rm -rf for .pc patches
  * Closes (LP: #301451)

xterm (237-1) unstable; urgency=low

  * debian/rules: don't fail in patch if the patches are already applied; also
    create the patch stamp in the same way as the other stamp files
    (closes: #498327). Thanks, Petr Salinger!
  * New upstream release.

xterm (236-1) unstable; urgency=low

  [ Brice Goglin ]
  * Update patches to not use -p0, closes: #485360.

  [ Julien Cristau ]
  * New upstream release.
    + fixes for vt100-style character sets in UTF-8 mode (LP: #230919)
  * Handle parallel=n in DEB_BUILD_OPTIONS.
  * Don't call dh_makeshlibs.
  * Configure with --enable-dabbrev (closes: #454202).
  * Update copyright date to 2008 in debian/copyright for Thomas E. Dickey's
    contributions.

 -- Ryan Kavanagh <email address hidden> Sun, 23 Nov 2008 17:15:10 -0500

Changed in xterm:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers